Download it now!
Bug 36588 - WRITER: shortkey for insert comments does not works in Western Europe
Summary: WRITER: shortkey for insert comments does not works in Western Europe
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 43800 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-25 11:40 UTC by Bram
Modified: 2014-08-21 11:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bram 2011-04-25 11:40:56 UTC
When using the US-international keyboard layout with dead keys, Ctrl+Alt+C gives © instead of inserting a comment. Another keyboard shortcut (one that is not used already) is preferred.
Comment 1 Rainer Bielefeld Retired 2011-07-22 07:07:54 UTC
BTW: in CALC we do not have a shortcut at all?

@Bram:
Any suggestions?
Comment 2 Björn Michaelsen 2011-12-23 12:01:59 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Björn Michaelsen 2011-12-23 17:01:03 UTC
needinfo keyword redundant by needinfo status.
Comment 4 sasha.libreoffice 2012-02-27 07:17:05 UTC
@ Bram
Please, explain what problem is. Impossible change shortcut? Or something else?
Comment 5 Bram 2012-02-27 09:08:28 UTC
I have no idea if shortcuts can be changed or not. Just opting for a
default shortcut that is not already reserved for the © character on the
most used keyboard layout in the entire world.

On 27 February 2012 16:17, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=36588
>
> sasha.libreoffice@gmail.com changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                 CC|                            |
> sasha.libreoffice@gmail.com
>
> --- Comment #4 from sasha.libreoffice@gmail.com 2012-02-27 16:17:05 CET
> ---
> @ Bram
> Please, explain what problem is. Impossible change shortcut? Or something
> else?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 6 sasha.libreoffice 2012-02-28 01:57:05 UTC
> most used keyboard layout in the entire world
Please, provide vendor name and model of keyboard. And which Windows used?
Comment 7 Bram 2012-02-28 02:00:27 UTC
Logitech Illuminated if you're interested.

But please, this is an issue with the US International layout. No matter
what type of keyboard you have on your desk, if you choose this keyboard
layout in Windows this glitch will appear.

On 28 February 2012 10:57, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=36588
>
> --- Comment #6 from sasha.libreoffice@gmail.com 2012-02-28 10:57:05 CET
> ---
> > most used keyboard layout in the entire world
> Please, provide vendor name and model of keyboard. And which Windows used?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 8 sasha.libreoffice 2012-02-28 03:51:45 UTC
Thanks for additional information. In US International layout character © reproducible. I never used "US International" for English, always "US" layout. Why "US International" is better?
Comment 9 Bram 2012-02-28 06:52:38 UTC
It's not better, it's just different. Most Qwerty keyboards in Europe have
the US International layout. The dead keys and additional characters are
used in a lot of languages here, so using the regular US layout is a pain
in the ass that one time you need special characters (there are way too
manu alt codes to remember...)

For the difference between the two layouts, see wikipedia:
http://upload.wikimedia.org/wikipedia/en/5/51/KB_United_States-NoAltGr.svg
http://upload.wikimedia.org/wikipedia/commons/2/22/KB_US-International.svg

On 28 February 2012 12:51, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=36588
>
> --- Comment #8 from sasha.libreoffice@gmail.com 2012-02-28 12:51:45 CET
> ---
> Thanks for additional information. In US International layout character ©
> reproducible. I never used "US International" for English, always "US"
> layout.
> Why "US International" is better?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 10 sasha.libreoffice 2012-02-28 07:07:59 UTC
Thanks for explanations about layout. And now let ask expert.

@ Sophie
What You think about this?
Comment 11 Jorendc 2014-01-31 12:35:51 UTC
*** Bug 43800 has been marked as a duplicate of this bug. ***
Comment 12 Urmas 2014-08-21 11:53:06 UTC
Ctrl-Alt is a legacy keyboard shortcut for the keyboards with only one Alt key.
Do not use keyboards with AltGr register, or reassign the shortcut.