Bug 36915 - Beanshell scripts don't work
Summary: Beanshell scripts don't work
Status: RESOLVED DUPLICATE of bug 37015
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta4
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-06 11:53 UTC by clio
Modified: 2011-07-27 02:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot, See Comment 1 (45.06 KB, image/png)
2011-05-07 11:18 UTC, Rainer Bielefeld Retired
Details
screenshots (28.84 KB, image/png)
2011-05-07 13:01 UTC, clio
Details
error (28.56 KB, image/png)
2011-05-10 04:48 UTC, Noel Power
Details
screenshot of beanshell script failure (383.58 KB, image/png)
2011-05-20 06:53 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2011-05-06 11:53:58 UTC
LibO3.4 beta4: Beanshell scripts don't work
To reproduce, try to run any preset scripts whether from the Beanshell IDE or from the general script manager. Or install this extension https://bugs.freedesktop.org/attachment.cgi?id=42291 and go to Tools - Add-ons menu - Calling scripts - Beanshell: Hello
Comment 1 Rainer Bielefeld Retired 2011-05-07 11:16:17 UTC
Related to "Bug 33355 - Python scripting not available"?
Currently in Menu 'Tools > MAcros > Organize' I only get offered "LibO basic", not "JavaScript", "Beanshell", "Pathon", pls see screenshot!

I tried to install the extension, but I will get an error message, and the macro seems to be not available.
Comment 2 Rainer Bielefeld Retired 2011-05-07 11:18:19 UTC
Created attachment 46426 [details]
Screenshot, See Comment 1
Comment 3 clio 2011-05-07 13:01:09 UTC
Created attachment 46433 [details]
screenshots

On Linux, all scripting languages, except BeanShell, work fine. (Also see screenshots.) BTW, there is a bug 36916 with JavaScript, but, anyways, JavaScript works as well here (Ubuntu 10.04 +JRE6u20).
Comment 4 Petr Mladek 2011-05-09 05:14:40 UTC
David suggested to fix the bug #33355 by enabling some configure switches. I did it for 3.4.0-brta4, see 
http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-4&id=3709e6a8ecdd18dec008094a11f90b3d99d837f9

There must be more problems with the beanshell.
Comment 5 Alex Thurgood 2011-05-09 06:38:56 UTC
@ALL :

I guess the fix never made it into b4, or else the switch wasn't activated for the build because I can see exactly the same thing as Rainer has produced in the screenshot, i.e. only a LibreOffice Basic macros entry. None of the other scripts appear in the list of those managed by LibO.


Alex
Comment 6 Alex Thurgood 2011-05-09 06:39:54 UTC
BTW, I'm on Mac OSX (Intel 10.6.7)

Alex
Comment 7 Noel Power 2011-05-10 04:44:27 UTC
and the same for me even with the latest branch build ( from last night ) 
interestingly if one installs the beanshell scriptprovider manually then although it is displayed it doesn't work ( seems to be some classpath issue )
Comment 8 Noel Power 2011-05-10 04:48:18 UTC
Created attachment 46541 [details]
error

note: a similar error occurs for the javascript provider
Comment 10 Alex Thurgood 2011-05-16 09:34:13 UTC
This isn't beta 5 right ? Coz if it is, it ain't working on MacOSX. See bug 37015 for details.


Alex
Comment 11 Alex Thurgood 2011-05-16 09:45:53 UTC
Sigh, I meant to write "This isn't fixed in beta5, right ?"


Alex
Comment 12 Petr Mladek 2011-05-17 05:32:28 UTC
Hmm, it still does not work with the last build. See also https://bugs.freedesktop.org/show_bug.cgi?id=37015#c13

Noel, did you commit the whole fix?
Comment 13 Noel Power 2011-05-17 06:54:55 UTC
(In reply to comment #12)
> Hmm, it still does not work with the last build. See also
> https://bugs.freedesktop.org/show_bug.cgi?id=37015#c13
> 
> Noel, did you commit the whole fix?

yes I did :-) 
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?h=libreoffice-3-4&id=39c7949d6cfe4ef0421e53bdca70b4b06568b9bc is complete. 

Now the real question is was this before beta5 or not? ( and that, I don't know for sure, I would guess not )
Comment 14 Petr Mladek 2011-05-17 09:17:20 UTC
Ah, I tested beta5 by mistake. It works with today's build => FIXED

I am sorry for the rumour.
Comment 15 manj_k 2011-05-19 04:38:51 UTC
Verified with
LibO 3.4 RC1 - LibreOffice 3.4.0 OOO340m1 (Build:11) [on WinXP 32b]

1. Tested with 'ExtExample-1.0.1.oxt' - OK
(see 'Description' [clio 2011-05-06])

2. Several tests via 'Tools > Macros > Organize Macros > BeanShell...' - OK
Comment 16 Caolán McNamara 2011-05-20 03:38:12 UTC
Honestly, apart from the python one, who on early really uses the javascript and beanshell macro stuff. Still think those two should be defaulted to be uninstalled
Comment 17 Alex Thurgood 2011-05-20 05:34:32 UTC

(In reply to comment #16)
> Honestly, apart from the python one, who on early really uses the javascript
> and beanshell macro stuff. Still think those two should be defaulted to be
> uninstalled

Hi Caolan,

I would have to ask around, but I'm pretty sure there are people developing Beanshell realworld stuff (often via the Netbeans IDE), however, really couldn't say about JS.

Alex
Comment 18 Alex Thurgood 2011-05-20 06:52:15 UTC
Still not working in rc1 for Mac OSX. Changing platform to OSX since others have reported that it works on other OSes.


Enclosing screenshot of trying to run a built-in beanshell script.



Alex
Comment 19 Alex Thurgood 2011-05-20 06:53:16 UTC
Created attachment 46952 [details]
screenshot of beanshell script failure
Comment 20 Caolán McNamara 2011-07-27 02:39:20 UTC

*** This bug has been marked as a duplicate of bug 37015 ***