Bug 37015 - Scripting other than Basic unavailable
Summary: Scripting other than Basic unavailable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords: regression
: 35139 36915 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-09 07:41 UTC by Alex Thurgood
Modified: 2011-10-29 07:38 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of GUI extensions manager in 3.4b5 on mac osx (80.95 KB, image/png)
2011-05-16 09:31 UTC, Alex Thurgood
Details
screenshot of beanshell script failure (383.58 KB, image/png)
2011-05-20 06:47 UTC, Alex Thurgood
Details
screenshot python script failure (61.92 KB, image/png)
2011-05-20 07:01 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2011-05-09 07:41:08 UTC
Scripting, other than Basic, is unavailable in the UI, i.e. no Beanshell, JS, python, etc, entries appear in the Tools > Macros > Manage dialog.


Alex
Comment 1 Alex Thurgood 2011-05-09 07:45:20 UTC
regression compared to 3.3.2.

Alex
Comment 2 vitriol 2011-05-09 07:46:20 UTC
The same in Windows. Changing OS to All.
Comment 3 Petr Mladek 2011-05-09 09:44:28 UTC
Hmm, this should have been fixed by http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-4&id=3709e6a8ecdd18dec008094a11f90b3d99d837f9

It might be related to the bug #33355.
Comment 5 Noel Power 2011-05-10 06:33:28 UTC
*** Bug 35139 has been marked as a duplicate of this bug. ***
Comment 6 Noel Power 2011-05-11 08:57:24 UTC
I will have a look
Comment 7 Noel Power 2011-05-11 09:38:27 UTC
well for beanshell it seems that the bsh.jar isn't found, I guess we need to either put it in the classpath or in the root of the extension ( iirc the scriptframework adds that to it's custom classpath )
Comment 8 Noel Power 2011-05-11 10:19:11 UTC
sigh I am looking at the wrong bug, this one is to do with the packaging of the scriptproviders, I thought I was looking at the bug #36915
Comment 9 Petr Mladek 2011-05-12 10:53:46 UTC
I see all four: Basic, BeanShell, Python, JS in Tools/Macros/Organize Macros on Linux with LO-3.4.0-beta5

I did not see them with LO-3.4.0-beta5 build on Windows. They appeared after I installed the optional "Python-UNO Bridge" component => they are included but not installed by default

=> FIXED

Please open new bug if you want to have them installed on Windows by default.
Comment 10 Don't use this account, use tml@iki.fi 2011-05-12 16:43:18 UTC
Whoa, that "Python-UNO Bridge" component is then seriously misnamed in the installer. One more reason to have *less* optionality in the installer.
Comment 11 Alex Thurgood 2011-05-16 09:23:25 UTC
Not fixed in 34b5 (clean install) on Mac OSX, I can still only see the LibreOffice Basic entry.


Re-opening.

Alex
Comment 12 Alex Thurgood 2011-05-16 09:30:49 UTC
Enclosing a screenshot taken today of the Extensions manager where it can be seen that all of the scripting extensions are alleged to be installed, but where the beanshell extension displays an error as to its status and is in a dimmed state.


Alex
Comment 13 Alex Thurgood 2011-05-16 09:31:39 UTC
Created attachment 46777 [details]
screenshot of GUI extensions manager in 3.4b5 on mac osx
Comment 14 Petr Mladek 2011-05-17 02:28:57 UTC
Thorsten, could you please have a look? It seems that the problem remains only on MAC.

Please, make sure that you use the following configure options:

    --enable-ext-scripting-beanshell
    --enable-ext-scripting-javascript
    --enable-ext-scripting-python
Comment 15 Petr Mladek 2011-05-17 05:36:07 UTC
Ah, I read it more carefully and see that the scripting support is actually available. "Just" the beanshell stuff does not work. This is being solved in the bug #36915.

Let's close this bug because the original problem has been solved. Let's discuss the Beanshell problem in the other bug.
Comment 16 Caolán McNamara 2011-05-20 03:37:07 UTC
Apart from the python one, I really wonder if the others are *ever* really used in the real world.
Comment 17 Alex Thurgood 2011-05-20 05:44:51 UTC
If they aren't (but as I commented on the Beanshell, I suspect that one is used in the realworld), then the minimum would be to provide the extensions as a separate download, so that people don't have to build the whole of LibO just to have them.


Alex
Comment 18 Alex Thurgood 2011-05-20 06:23:00 UTC
Re-opening.


Just tested RC1 for Mac OSX Intel 10.6.7.
Clean install - removed the app bundle and the User/Library/Application Support/LibreOffice folder before installing.


I still only see the Basic entry in the Tools > Macros > Manage Macros.


Alex
Comment 19 Alex Thurgood 2011-05-20 06:23:32 UTC
@Thorsten : can you check this for me ?


Alex
Comment 20 Alex Thurgood 2011-05-20 06:24:53 UTC
(In reply to comment #19)
> @Thorsten : can you check this for me ?
> 
> 
> Alex


My build version :

LibreOffice 3.4.0 
OOO340m1 (Build:11)


Alex
Comment 21 Alex Thurgood 2011-05-20 06:25:45 UTC
Changed platform to Mac OS as others have reported it fixed for other OSes.


Alex
Comment 22 Alex Thurgood 2011-05-20 06:28:41 UTC
Sigh, this isn't bug 34699 again is it ? In the Extensions Manager, the scripts are considered to be installed correctly but the corresponding UI entries do not appear. 


Alex
Comment 23 Alex Thurgood 2011-05-20 06:47:33 UTC
Created attachment 46951 [details]
screenshot of beanshell script failure
Comment 24 Alex Thurgood 2011-05-20 06:49:17 UTC
Tried installing some extra extensions via the Extension Manager UI. Restarted the application. The script menu entries now appear, but some fail to execute with the error shown in the screenshot (for that particular Beanshell script).


Alex
Comment 25 Alex Thurgood 2011-05-20 07:01:44 UTC
Created attachment 46953 [details]
screenshot python script failure
Comment 26 Petr Mladek 2011-05-20 08:01:14 UTC
Reducing the severity a bit. It is used only by extensions => not a core functionality => can't  block the 3.4.0 release
Comment 27 Alex Thurgood 2011-05-20 08:26:12 UTC
Errm, have I misunderstood something here ? Before during the betas, it was considered a blocker, and now it suddenly isn't anymore ? I'm sorry I really don't understand.


Alex
Comment 28 Petr Mladek 2011-05-20 09:22:34 UTC
(In reply to comment #27)
> Errm, have I misunderstood something here ? Before during the betas, it was
> considered a blocker, and now it suddenly isn't anymore ? I'm sorry I really
> don't understand.

I started to clean up the severity of blocker bugs a week ago. I wanted to see where we were for the release. I did not mind about bugs that were fixed or about to be fixed. Otherwise, I would have lowered the severity of this bug a week ago as well.

Note that LO has another release criteria because we use the time based release, see http://wiki.documentfoundation.org/Release_Criteria

By other words, we do not want to wait 3 months until all known annoying bugs are fixed. There were always annoying bugs found after the release and people need to wait another 3-4 months for the fix. Also most of the bugs were annoying only for a selected group of users. We want to release early, do bugfix release every month, inform people about known most annoying bugs in the release notes. This way we make the release predictable and will make bigger and bigger group of users happy every month. Note that we do not stop producing 3.3.x bug fix releases after 3.4.0 is out. The 3.3.x code base will be suggested over 3.4.0 for users that want a perfect stability and usability.
Comment 29 Alex Thurgood 2011-06-28 01:32:45 UTC
Update :

The same problem currently exists in the master nightly builds from 27/06 and 28/06.

In 27/06 build, only Python scripting was unavailable in the UI and non-functional (despite being installed).

In 28/06 build, all of the scripts other than Basic are no longer available in UI (although they appear in the Extensions Manager). The Python scripting provider is greyed out.


Alex
Comment 30 Laurent Godard 2011-07-08 03:55:55 UTC
deploying a python extension, i end with

/basis-link/program/libpyuno.so: undefined symbol: PyUnicodeUCS4_DecodeUTF8

(3.4.0 branch, linux, built --without-system-python)
Comment 31 Laurent Godard 2011-07-08 04:54:39 UTC
same --with-system-python (ubuntu 10.10)
/basis-link/program/libpyuno.so: undefined symbol: PyUnicodeUCS4_DecodeUTF8
Comment 32 Laurent Godard 2011-07-08 06:22:19 UTC
regarding PyUnicodeUCS4_DecodeUTF8 error

solved by cleaning and rebuilding pyuno after changes wi the configure python switch

(15:19:28) caolan: lgodard: looks to me that this *specific* error is that pyuno_util.o was created from pyuno_util.cxx on the original setup with external system python, and there are no rules to rebuild it when relinked against the internal one or something like that
Comment 33 Caolán McNamara 2011-07-27 02:39:20 UTC
*** Bug 36915 has been marked as a duplicate of this bug. ***
Comment 34 Caolán McNamara 2011-08-04 04:25:57 UTC
ok, 

a) so, reportedly now on mac for python:

Christian Lohmaier wrote: "On both 3.4.2 as well as on master all the supplied samples work."

if there are remaining problem, lets open new bugs for them (feel free to assign/cc me on them), its gets really messy when a bug gets reopened as similar symptoms may not be the same problem as the original.