Bug Hunting Session
Bug 37179 - [UX] options set in Find&Replace dialogue, influence how Find tool bar works
Summary: [UX] options set in Find&Replace dialogue, influence how Find tool bar works
Status: RESOLVED DUPLICATE of bug 62601
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: All All
: medium major
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-13 07:05 UTC by Cor Nouws
Modified: 2013-11-15 01:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2011-05-13 07:05:45 UTC
- open Writer document
- type [enter] Weekend [enter] 
- Ctrl-ALt-F, set check 'Whole words only'
- Search something

- close dialog

- ctrl-F
- type 'wee', Enter 
  > not found

- open dlg again, remove check at 'Whole words only', cls dlg

- ctrl-F
- type 'wee', Enter 
  > found

same prob in Calc and prolly other parts.

annoying bug, IMO
Comment 1 Rainer Bielefeld Retired 2011-05-13 09:45:10 UTC
[Reproducible] with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:5)]". It seems that Case Sensitivity wil not be transferred from F/R to F.

@Kendiy
I believe I wrongly assigned some Find Bar Bugs to Kohei:
Bug 33593 - FindBar use breaks the normal 'Find and replace' by columns
Bug 33379 - Searching in all sheets will not work after using the Find toolbar
May be you want to take them?
Comment 2 Rainer Bielefeld Retired 2011-05-30 22:36:31 UTC
During my investigations for "Bug 37760 - Writer - Find&Replace - Format - indents work wrong" I found that also Formatting "Find & Replace" conditions will be used for Find bar, that's calamitous!

Modified Status due to facts.
Comment 3 Rainer Bielefeld Retired 2011-07-22 10:31:53 UTC
Worked with 3.3.3 (no Find Bar)
Comment 4 Jan Holesovsky 2011-07-26 15:53:25 UTC
Rainer: No, this bug was in 3.3 too, but because the FindBar was not that much used, nobody noticed ;-)  Now when it is much more visible, this became more annoying.

I've proposed a stop-gap solution on the mailing list for 3.4, and pushed it to master for 3.5, so I think we can close this bug.
Comment 5 Kumāra 2013-11-13 05:44:02 UTC
(In reply to comment #2)
> I found that also Formatting "Find & Replace" conditions
> will be used for Find bar, that's calamitous!

Yes, and it hasn't been fixed (as far as I can tell). So, why is this marked as resolved?
Comment 6 Jan Holesovsky 2013-11-13 09:37:21 UTC
Kumara: Maybe you have a use case that was not affected by the fix, sorry for that.  Please open a new bug, and describe the behavior you are seeing, and what you expect instead.

Thank you in advance!
Comment 7 Kumāra 2013-11-15 01:29:21 UTC

*** This bug has been marked as a duplicate of bug 62601 ***
Comment 8 Kumāra 2013-11-15 01:31:48 UTC
From bug 62601: "abdulmajeed ahmed committed a patch related to this issue."
target:4.2.0