Bug 37210 - UI: Calc usability improvement: Merge cells on right mouse click
Summary: UI: Calc usability improvement: Merge cells on right mouse click
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: Other All
: low enhancement
Assignee: Greggory Hernandez
QA Contact:
URL:
Whiteboard: target:3.6.0
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2011-05-14 12:42 UTC by gleppert
Modified: 2015-12-18 10:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Fix for this bug (611 bytes, patch)
2012-02-21 21:57 UTC, Greggory Hernandez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-05-14 12:42:13 UTC
Usability problem: No "merge cells" on right mouse click in Calc

Using OpenCalc, I tried to merge two (or more) cells. I expected this
functionality to be available in the context menu after performing a right
mouse click. This is the way, how it is handled in the table tool of Writer,
but also Excel. This would be a very handy addition.

Currently, this functionality is only available via "Format"-"Merge Cells".

Thank you!

Related OOo bugzilla entry: https://openoffice.org/bugzilla/show_bug.cgi?id=102938
Comment 1 Björn Michaelsen 2011-12-23 12:07:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 gleppert 2012-02-07 05:42:40 UTC
Enhancement request is still valid for LibreOffice 3.5.
Set report from "NeedInfo" back to "New" again.
Comment 3 gleppert 2012-02-07 05:44:29 UTC
This could be an easy hack. Can any developer confirm that this is an easy hack?
Comment 4 Greggory Hernandez 2012-02-21 21:57:49 UTC
Created attachment 57433 [details]
Fix for this bug

Is the positioning in the context menu and the location of the ~ appropriate?
Comment 5 Not Assigned 2012-02-22 06:16:16 UTC
Greggory Hernandez committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aff6db70245a74039b5331810d3ff654b1f6af63

fdo#37210 - UI: Calc usability improvement: Merge cells on right mouse click
Comment 6 gleppert 2012-04-08 10:57:18 UTC
@Greggory: Thanks a lot! Since this is bug entry has a patch and is marked for target 3.6.0 I add it to the wiki: https://wiki.documentfoundation.org/ReleaseNotes/3.6

Please correct me, in case the patch does not go into 3.6
Comment 7 Jaise James 2012-04-27 06:11:20 UTC
Will it possible to do unmerge for the merged cell in right click menu.
Comment 8 Michael Meeks 2012-05-08 13:54:34 UTC
marking closed :-) the unmerge is not present, but would indeed be nice - left as an exercise for the next easy-hacker :-)
Comment 9 gleppert 2012-05-09 12:35:39 UTC
On Michael's suggestion, I opened a new bug 49704 based on the idea to unmerge cells on right mouse click. 

Could you please also mark that bug a EasyHack? Thanks.
Comment 10 Robinson Tryon (qubit) 2015-12-18 10:02:01 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]