Bug Hunting Session
Bug 49704 - UI: Calc usability improvement: Unmerge cells on right mouse click
Summary: UI: Calc usability improvement: Unmerge cells on right mouse click
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.0.0
Keywords: easyHack
: 50151 (view as bug list)
Depends on:
Blocks: Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2012-05-09 12:34 UTC by gleppert
Modified: 2017-06-03 20:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
proposed patch (1.63 KB, patch)
2012-11-28 17:02 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2012-05-09 12:34:09 UTC
This is a follow-up enhancement for bug 37210. That enhancement allows to merge cells on right mouse click. In the comments to that bug, it came up that also the possibility to "un-merge" cells on right mouse click would be needed.

Could you please ad this bug as EasyHack. Thanks.
Comment 1 Joel Madero 2012-06-20 11:23:50 UTC
*** Bug 50151 has been marked as a duplicate of this bug. ***
Comment 2 Laurent Godard 2012-11-28 17:02:18 UTC
Created attachment 70738 [details]
proposed patch
Comment 3 Not Assigned 2012-11-28 17:15:13 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03949c87206046d3a2ed2bf41f5c020458d07a8f

fdo#49704 add split cells menu entry in calc popup



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Laurent Godard 2012-11-29 09:35:55 UTC
a patch has been committed
Comment 5 Robinson Tryon (qubit) 2015-12-18 10:02:58 UTC Comment hidden (obsolete)