Bug 37219 - Add exported PDF files to the recent documents list in current desktop environment
Summary: Add exported PDF files to the recent documents list in current desktop enviro...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: VOTE
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 03:53 UTC by Milan Bouchet-Valat
Modified: 2016-08-23 13:58 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2011-05-15 03:53:22 UTC
When you export a PDF from a LibreOffice document, it doesn't get added to the recent documents list (~/.local/share/recently-used.xbel). It would be convenient to do add it, so that you can quickly find it e.g. to open it to see the result, or to attach it to a mail (though I know you can use the File->Send menu).

The general idea is that if you export a document to PDF, you're likely to do something with it right after that. (For example, in GNOME 3, typing part of the file name in the overview allows me to find the file to open it, now or later, which I often need.)
Comment 1 Rainer Bielefeld Retired 2011-05-15 06:30:26 UTC
It must be checked whether that will not hurt any other OS conventions.
If we get such a behavior, it should be the same or similar in all OS. In WIN7 until today I did not understand all details of recent documents.

I also miss a possibility to get the pdf export automatically or with 1 click so that I can check the result easily (for example because of "Bug 31606 - Exporting a selection of pages to PDF has pagerange wrong because of blank pages" and other reasons).

But I would prefer a different solution, pls. see
Bug 37222 - UI: Possibility to open exported PDF in a simple way immediately after export required

May be you want to vote for this enhancement request on the nonofficial Voting Page?
<http://wiki.documentfoundation.org/index.php?title=Vote_for_Enhancement&action=submit#Bug_37219_-_Bug_37219_-_Add_exported_PDF_files_to_recent_documents>
Comment 2 Milan Bouchet-Valat 2011-10-30 02:14:34 UTC
I think my proposition is not completely redundant with
Bug 37222 - UI: Possibility to open exported PDF in a simple way immediately
after export required

The idea is that when you're done with a document, you often want to create a PDF of it that you save somewhere, and e-mail or publish it. You often want to rename the file before sending it, in which case you need to save it first. Adding the PDF to the recent docs allows you to attach it to an e-mail easily by choosing it in the recent docs list (at least with the GtkFileChooser, not sure elsewhere). Same if you want to publish the file on a website, e.g. Google docs.

The more general argument is that recent docs should contain all files you touched in a way or another. It should reflect your activity on documents. This is especially important on Linux where e.g. Zeitgeist logs everything you do, and uses the recent documents to track that (else, it would need a LO extension just for that). In GNOME Shell, typing a few letters of the file name in the overview is enough to find a recent document; but if it's not added to the list, you have to find it manually.

This is the same on Windows Vista and Seven, with the search entry in the Start menu, and on Mac OS X with the search bar in the top panel.

Last but not least, I can't find any reasonable argument against that feature. If that PDF file wasn't interesting for you, you'd have used the File->E-mail as... feature. Or you'd have removed the file, which makes it disappear from the recent docs.
Comment 3 Björn Michaelsen 2011-12-23 12:03:25 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 13:58:17 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 13:59:34 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:04:10 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:06:23 UTC Comment hidden (obsolete)
Comment 8 Milan Bouchet-Valat 2012-08-14 17:45:59 UTC
Not implemented in LibreOffice 3.5.5.3 (Fedora 17).
Comment 9 Florian Reisinger 2012-08-16 11:34:34 UTC
Please always use the oldest version in version field..
Comment 10 Karl Relton 2013-06-11 15:22:14 UTC
Perhaps a better solution here would be to upgrade Libreoffice so it is a first class citizen wrt zeitgeist, i.e. build in a proper dataprovider for zeitgeist into libreoffice.

I can see the arguments for/against included exported docs like PDF in the recent files - but the dilemma goes away if proper zeitgeist events are pushed from libreoffice (instead of relying on zeitgest to trawl the recently used list as it does at the moment, which is never going to be fully satisfactory).

With proper dialogue with zeitgeist, then you can get other benefits as well, e.g. push events when images are inserted so zeitgeist can log that too.

There are downstream bugs in distros like Ubuntu asking for libreoffice to have full zeitgest support (e.g. https://bugs.launchpad.net/ubuntu/+source/zeitgeist-datahub/+bug/934542)
Comment 11 Joel Madero 2014-11-04 03:31:05 UTC
Never confirmed by QA team - moving back to UNCONFIRMED.
Comment 12 Robinson Tryon (qubit) 2014-12-27 16:35:00 UTC
One for the UX Team

Status -> NEW.
Comment 13 Heiko Tietze 2016-08-23 13:58:39 UTC
Export allows to save a document in alien formats, e.g. a PNG. That will never be handled with LibreOffice. And the PDF would be opened for editing in Draw, which might not be what you wanted. So I close this ticket as WONTFIX.