Download it now!
Bug 37356 - Paste Special of copied cells with transposition causes LibreOffice to hang
Summary: Paste Special of copied cells with transposition causes LibreOffice to hang
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4.1
Keywords: regression
: 37711 37788 38002 38217 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-19 04:26 UTC by Alexander Grimalovsky
Modified: 2011-10-29 07:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Grimalovsky 2011-05-19 04:26:59 UTC
Using "Transpose" option in "Paste Special" will cause LibreOffice to hang, it looks like it falls into infinite loop because CPU usage jumps to 100%

Steps to reproduce:
1. Create new empty spreadsheet 
2. Insert some values into several cells, e.g.:
  A1 = "a"
  B1 = "b"
  C1 = "c"
3. Select all cells
4. Copy cells into clipboard
5. Use Edit -> Paste Special 
6. Into "Paste Special" options dialog check "Transpose" checkbox
7. Click "OK" button

Expected results: Copied cells should be inserted in spreadsheet with transposition

Actual results: LibreOffice stops responding and CPU usage raises to 100%
Comment 1 vitriol 2011-05-19 04:31:16 UTC
Confirmed. Regression from 3.3.2.
Comment 2 Yifan Jiang 2011-05-25 22:40:25 UTC
in 3.4 RC1 / SLED 11 sp1 i586, when paste special (transpose), Calc always pops out a dialog saying:

    'There is not enough space on the sheet to insert here'

after which no paste is done, finally clicking OK button will bring calc to a normal status. Hanging issue seems not here in the build.

Since it is a regression problem, so better for Kohei's review, thanks!
Comment 3 Kohei Yoshida 2011-05-26 12:10:08 UTC
I can't reproduce a CPU race or an error message, but the transposition is definitely not working.
Comment 4 Kohei Yoshida 2011-05-26 12:16:12 UTC
(In reply to comment #3)
> I can't reproduce a CPU race or an error message, but the transposition is
> definitely not working.

Nevermind I just reproduced both of them at the same time. ;-)
Comment 5 Kohei Yoshida 2011-05-26 12:51:59 UTC
Found the cause.  Posted the fix to the mailing list for review.
Comment 7 vitriol 2011-05-29 05:54:32 UTC
*** Bug 37711 has been marked as a duplicate of this bug. ***
Comment 8 vitriol 2011-05-31 06:29:01 UTC
*** Bug 37788 has been marked as a duplicate of this bug. ***
Comment 9 vitriol 2011-06-06 13:02:48 UTC
*** Bug 38002 has been marked as a duplicate of this bug. ***
Comment 10 GerardF 2011-06-12 13:39:02 UTC
*** Bug 38217 has been marked as a duplicate of this bug. ***