Bug Hunting Session
Bug 37403 - EDIT: Crash when second edit on DRAW object "arc"
Summary: EDIT: Crash when second edit on DRAW object "arc"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords: regression
: 40267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-20 06:11 UTC by Rainer Bielefeld Retired
Modified: 2011-08-23 06:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-20 06:11:33 UTC
"LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) German UI [OOO340m1 (Build:11)]" WRITER crashes 100% when I do a second edit at an "arc" drawing

Steps to reproduce. For Steps 1-3 you can also open attached sample10.odt:

1. Open new WRITER document
2. Add icon "arc" to Drawing toolbar, if necessary
3. draw a small arc (5cm diameter) 1/4 open to the bottom
4. if necessary, click arc to get control points
5. move mouse pointer to bottom middle control point
6. push left mouse button 
7. drag bottom middle control point 1/3 diameter up
8. release mouse button
9. move mouse pointer to bottom middle control point
10. push left mouse button, drag bottom middle control point 1/3 diameter up
    Expected: Edit
    Actual: crash

I already saw that with 3.4Beta5, DRAW and CALC are not affected.

You won't believe it, 95% of my Drawings in 80% of my WRITER documents are arcs - sigh.
Comment 1 vitriol 2011-05-20 06:25:52 UTC
Confirmed under Win7. No problem with 3.3.2 -> regression
Comment 2 Rainer Bielefeld Retired 2011-05-20 09:04:03 UTC
NEW to comment 1

@vitriol:
Thank you for confirming!

@Cédric:
Please feel free to reassign if it's not your area!
Comment 3 Cédric Bosdonnat 2011-07-08 08:29:39 UTC
(In reply to comment #2)
> NEW to comment 1
> 
> @vitriol:
> Thank you for confirming!
> 
> @Cédric:
> Please feel free to reassign if it's not your area!

Fixed in master branch by commit: 
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=21ec661d09ed9d7bbbec5e52ee2b382d8c465324
Comment 4 Rainer Bielefeld Retired 2011-08-11 06:19:44 UTC
Cherrypick to 3-4 possible?
Comment 5 Cédric Bosdonnat 2011-08-16 05:54:50 UTC
Reverted the previous commit and replaced by this one:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3852d41a419331277d0b98b02792f0bbf704d5b

This fix is much cleaner and may go to 3.4.
Comment 7 Caolán McNamara 2011-08-23 05:29:47 UTC
*** Bug 40267 has been marked as a duplicate of this bug. ***
Comment 8 Dorange-Pattoret Didier 2011-08-23 06:32:05 UTC
Hello,

It seems to be a problem about the LineWith property.

Please take a look at my macro :
https://bugs.freedesktop.org/show_bug.cgi?id=40288

Thanks.