Bug 40267 - EDITING: Crash when copy/paste particular DRAWing object to Writer or CALC
Summary: EDITING: Crash when copy/paste particular DRAWing object to Writer or CALC
Status: CLOSED DUPLICATE of bug 37403
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL: CONFIRMED
Whiteboard:
Keywords:
: 40288 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-21 06:29 UTC by Rainer Bielefeld Retired
Modified: 2011-08-23 05:30 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document, pls see original report! (35.97 KB, application/vnd.oasis.opendocument.graphics)
2011-08-21 07:10 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-08-21 06:29:46 UTC
I observed that with "LibreOffice 3.4.3 RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:301)]" and attahced sample.

Steps tor reproduce:

1. Open attached "sample.odg"
2. Click into white space of drawing
3. <ctrl+a> to slect all
4. <ctrl+c> for copy
5. Menu 'File -> New -> WRITER Text Document'
6. click into new WRITER document
7. <ctrl+v> for paste
   expected: drawing appears
   actual: Crash

Sometimes LibO already crashes in step 4.
Comment 1 Rainer Bielefeld Retired 2011-08-21 07:10:20 UTC
Created attachment 50424 [details]
Sample document, pls see original report!
Comment 2 Jeffrey 2011-08-22 06:24:18 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.
Comment 3 Jeffrey 2011-08-22 06:36:20 UTC
*** Bug 40288 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2011-08-22 08:22:40 UTC
CONFIRMED due to Comment 3.

@Caolàn:
I saw you puzzling in some other Vector graphic issues, and it's not only WRITER. Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Caolán McNamara 2011-08-22 08:49:46 UTC
This doesn't crash for me in 3-4, will try in master and under valgrind.
Comment 6 Caolán McNamara 2011-08-23 04:55:23 UTC
I can't get it to crash there either.

caolanm->rodo: its a drawing thing, vaguely casting around, you sort of know drawing things. Able to reproduce this ? comment #2 suggests it should be possible to see this under Linux
Comment 7 Caolán McNamara 2011-08-23 05:26:55 UTC
hang on, I can see it with the "vanilla" rpms
Comment 8 Caolán McNamara 2011-08-23 05:29:47 UTC
#0  0x00007fffd3c3dbf4 in XPolygon::~XPolygon()	() from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#1  0x00007fffd3aee963 in SdrRectObj::~SdrRectObj() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#2  0x00007fffd3abc987 in SdrCircObj::~SdrCircObj() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#3  0x00007fffd3b12b0b in SdrObjList::Clear() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#4  0x00007fffd3b13906 in SdrObjList::~SdrObjList() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#5  0x00007fffd3acf4f1 in SdrObjGroup::~SdrObjGroup() ()
   from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#6  0x00007fffd3b12b0b in SdrObjList::Clear() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#7  0x00007fffd3b13906 in SdrObjList::~SdrObjList() () from /opt/libreoffice3.4/program/../basis-link/program/libsvxcorelx.so
#8  0x00007fffd3acf4f1 in SdrObjGroup::~SdrObjGroup() ()

so its in the dtor of XPolygon, and that'll be from the mpXPoly which means its another manifestation of bug 37403

*** This bug has been marked as a duplicate of bug 37403 ***
Comment 9 Caolán McNamara 2011-08-23 05:30:28 UTC
closing as dup