Download it now!
Bug 37426 - problem Quickstart
Summary: problem Quickstart
Status: RESOLVED DUPLICATE of bug 37110
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86 (IA32) Windows (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-20 23:26 UTC by TB
Modified: 2011-06-03 22:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TB 2011-05-20 23:26:36 UTC
Sorry for my poor english

QuickStart launches libreoffice to the starting of windows (OK in beta 5)

When I click on quickstart.exe libreoffice opens, which was not the case in previous versions
Comment 1 Don't use this account, use tml@iki.fi 2011-05-21 01:09:53 UTC
QuickStart is mostly useless in my opinion, I wouldn't even bother to try to use it. I think we should just drop it. It definitely does not do anything when Windows starts, it is set to be used or not by each user separately. (Of course, on machines with only one user and automatic login, the difference is theoretical...)

Please try to explain in more detail what problem you see.
Comment 2 TB 2011-05-25 06:56:14 UTC
Sorry for my poor english
Once QuickStart start in systray, to start windows Libreoffice launches, while in previous versions is not the case. This slows the machine startup and creates an instabilitée (crash of the machine.) (the machine freezes). If it's disabled problem more.




> Message du 21/05/11 10:09
> De : bugzilla-daemon@freedesktop.org
> A : mnguyen75@laposte.net
> Copie à : 
> Objet : [Bug 37426] problem Quickstart
>
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=37426
> 
> Tor Lillqvist changed:
> 
> What |Removed |Added
> ----------------------------------------------------------------------------
> Platform|All |x86 (IA32)
> OS/Version|All |Windows (All)
> Severity|major |normal
> Priority|medium |low
> 
> --- Comment #1 from Tor Lillqvist 2011-05-21 01:09:53 PDT ---
> QuickStart is mostly useless in my opinion, I wouldn't even bother to try to
> use it. I think we should just drop it. It definitely does not do anything when
> Windows starts, it is set to be used or not by each user separately. (Of
> course, on machines with only one user and automatic login, the difference is
> theoretical...)
> 
> Please try to explain in more detail what problem you see.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
> 
> 

Une messagerie gratuite, garantie à vie et des services en plus, ça vous tente ?
Je crée ma boîte mail www.laposte.net
Comment 3 Leif Lodahl 2011-05-29 02:02:06 UTC
Hi,

Also in RC2.
Confirmed on Windows XP and Vista.

The problem is that quickstarter.exe starts LibO in full screen where it should be with no GUI (only a small icon in the system tray). The result is that the whole application startes when Windows is started or restarted. It should only run in memory.

I suggest that this issue is changed to be a blocker because many Windows users are using the quickstarter and will find this problem annoying.


Cheers,
Leif Lodahl
Comment 4 Joergen 2011-05-29 07:33:15 UTC
This bug is also present in Windows 7 64-bit.

Launching LibreOffice with quickstart.exe is not only very annoying but also intrusive. This bug should be fixed before the final release.
Comment 5 Werner Knudsen 2011-05-30 00:38:39 UTC
I agree that this should be solved before final release of 3.4 as this behaviour will be a major annoyance to Windows users.
Comment 6 Don't use this account, use tml@iki.fi 2011-05-30 01:43:40 UTC
> this behaviour will be a major annoyance to Windows users

Just don't use the "QuickStarter"
Comment 7 Don't use this account, use tml@iki.fi 2011-05-30 01:48:01 UTC
I can't reproduce any full-screen effect here. Please give *exact* reproduction instructions. And I am not sure if you are supposed to run quickstart.exe manually at all. Shouldn't one go through Tools:Options:Memory to turn on the "QuickStarter"?

Werner: no, this doesn't block the 3.4(.0) release.
Comment 8 Leif Lodahl 2011-05-30 10:10:01 UTC
I believe this is a bug report and not a discussion weather or not the feature is good. Many Windows users like this feature because it speeds up opening of documents.


To reproduce...
If you start LibreOffice 3.4 on Windows and go to Tools - Options - LibreOffice - Memory select the last checkbox "Activate quickstart in system tray".
Close the Options dialog
Close LibreOffice
Start LibreOffice
Close LibreOffice

Restart Windows

LibreOffice will now start as an application with GUI, where it should run as a task in the background. If you close LibreOffice the icon will remain in the system tray and running in the background.

It is possible to activate Quickstart by rinning the quickstart.exe with the same result.


Cheers,
Leif
Comment 9 Don't use this account, use tml@iki.fi 2011-05-31 01:01:24 UTC
> not a discussion weather or not the feature is good

But if a feature is fairly pointless, and nobody wants to maintain it, and it causes only trouble, the right solution is to remove the feature.

> because it speeds up opening of documents

Do you have any proof? Speeds up by how much? Compared to what? What does it then slow down instead? 

> Restart Windows

and log in as the same user, presumably?

Anyway, thanks for the instructions. Will try to reproduce.
Comment 10 TB 2011-05-31 22:48:18 UTC
Thank you for your reply.

This is a new feature of v3.4, the start of the launch of Windows libreoffice?

With slower computers, this causes problems, yat it means to have the same quick start function in previous versions?
Thank you




> Message du 30/05/11 19:10
> De : bugzilla-daemon@freedesktop.org
> A : mnguyen75@laposte.net
> Copie à : 
> Objet : [Bug 37426] problem Quickstart
>
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=37426
> 
> --- Comment #8 from Leif Lodahl 2011-05-30 10:10:01 PDT ---
> I believe this is a bug report and not a discussion weather or not the feature
> is good. Many Windows users like this feature because it speeds up opening of
> documents.
> 
> 
> To reproduce...
> If you start LibreOffice 3.4 on Windows and go to Tools - Options - LibreOffice
> - Memory select the last checkbox "Activate quickstart in system tray".
> Close the Options dialog
> Close LibreOffice
> Start LibreOffice
> Close LibreOffice
> 
> Restart Windows
> 
> LibreOffice will now start as an application with GUI, where it should run as a
> task in the background. If you close LibreOffice the icon will remain in the
> system tray and running in the background.
> 
> It is possible to activate Quickstart by rinning the quickstart.exe with the
> same result.
> 
> 
> Cheers,
> Leif
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
> 
> 

Une messagerie gratuite, garantie à vie et des services en plus, ça vous tente ?
Je crée ma boîte mail www.laposte.net
Comment 11 vitriol 2011-06-03 22:38:32 UTC

*** This bug has been marked as a duplicate of bug 37110 ***