Bug Hunting Session
Bug 37110 - Start Centre opens at login if QuickStarter enabled
Summary: Start Centre opens at login if QuickStarter enabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) All
: highest major
Assignee: Robert Nagy
URL:
Whiteboard:
Keywords: regression
: 37426 37910 38037 38333 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-11 05:46 UTC by Scott
Modified: 2011-06-21 04:00 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Fix. (819 bytes, patch)
2011-06-18 17:14 UTC, Robert Nagy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott 2011-05-11 05:46:48 UTC
I enabled QuickStart at system startup and now in 3.4 B4 quick start starts up maximized and I have to X it out to close it to the systray.  It used to always startup minimized to the systray.
Comment 1 Don't use this account, use tml@iki.fi 2011-05-11 05:55:56 UTC
One more reason to kill the whole QuickStart concept.
Comment 2 Alex Kurd 2011-05-22 23:14:27 UTC
Also 3.4b5 on win7
Comment 3 Scott 2011-05-23 07:08:51 UTC
And still in 3.4RC1.
Comment 4 Don't use this account, use tml@iki.fi 2011-05-23 07:37:42 UTC
No need to add comments for each new build/version where you see a problem. If there is no indication here otherwise, you can assume the issue is still there. (Although note that you seem to be the only person seeing this problem.)

If you see that the problem goes away "by itself" (i.e. without explicit indication here that somebody would have understood what is going for you on and fixed it on purpose), *then* add a comment please, and resolve the bug as WORKSFORME
Comment 5 vitriol 2011-06-03 22:38:32 UTC
*** Bug 37426 has been marked as a duplicate of this bug. ***
Comment 6 vitriol 2011-06-03 22:39:10 UTC
*** Bug 37910 has been marked as a duplicate of this bug. ***
Comment 7 Don't use this account, use tml@iki.fi 2011-06-04 00:11:35 UTC
Is it sure this is about Windows? The "systray" term is not used on Windows, as far as I know. But apparently it is a common misconception to use that term: http://blogs.msdn.com/b/oldnewthing/archive/2003/09/10/54831.aspx .

Anyway, the hilariously named QuickStarter is no way supposed to be started at "System Start", but when the user who has enabled it logs in. Sure, with automatic logon to single-user machines, the difference might be hard to understand. But it is an important one.

Just disable the QuickStarter. My opinion is that we should just remove this silly and useless feature which causes nothing but trouble.
Comment 8 vitriol 2011-06-04 00:26:41 UTC
(In reply to comment #7)
> Is it sure this is about Windows? The "systray" term is not used on Windows, as
> far as I know. But apparently it is a common misconception to use that term:
> http://blogs.msdn.com/b/oldnewthing/archive/2003/09/10/54831.aspx .

Yes, it's a term commonly used for Windows. AFAIK the correct term is "Notification Area", but "System Tray" or "SysTray" are widespread.
Comment 9 vitriol 2011-06-04 00:33:35 UTC
In my opinion, useful or not, there is a bad regression in QuickStart functionality. If your idea is to remove all regressed functionalities present in version 3.4, I think that you must remove almost 1/3 of OOo/LibO functionalities ;-)
Comment 10 Don't use this account, use tml@iki.fi 2011-06-04 01:47:59 UTC
Removing useless features is no regression. Does removing "QuickStarter" affect in any way what LibreOffice can be used for?
Comment 11 vitriol 2011-06-04 02:00:50 UTC
(In reply to comment #10)
> Removing useless features is no regression. Does removing "QuickStarter" affect
> in any way what LibreOffice can be used for?

Regardless the speedup controversy, I have seen many user that use shortcuts that QuickStarter icon provides (launch of applications or open file dialog).
In any case, QuickStarter is present in 3.4 and is buggy. Therefor, here and now, is an evident regression against 3.3.2.
Comment 12 Don't use this account, use tml@iki.fi 2011-06-04 02:24:20 UTC
Whatever. My opinion is still that there is a simple workaround: Don't use it.
Comment 13 Cor Nouws 2011-06-05 13:45:18 UTC
#tor: best workaround is using a type-writer :-)
And serous: the QuickStarter is an often used feature. Are you going to write to the UX-advise list, to propose dumping this feature?
Comment 14 Don't use this account, use tml@iki.fi 2011-06-05 14:06:01 UTC
No, I am just going to keep answering "don't use it then". Unless my boss orders me to fix the problem, of course.
Comment 15 Cor Nouws 2011-06-05 15:00:48 UTC
:-p
Comment 16 Don't use this account, use tml@iki.fi 2011-06-06 02:29:39 UTC
Anyway, I can reproduce that the *Start Centre* (i.e. the LibreOffice window with the large "Text Document", "Spreadsheet" etc buttons) opens when logging in if you have QuickStarter enabled.

I don't know what it would mean if the "QuickStarter" would be maximized. There is no QuickStarter window that could be maximized, is there?

I don't see the Start Centre becoming maximized by itself, though. If I myself maximize the Start Centre before I close it, then the next time the Start Centre opens it will of course be maximized, and also then in the case where it now opens automatically and unexpectedly when logging in.

Re-titling the bug accordingly.
Comment 17 Nodens 2011-06-06 10:27:12 UTC
How can you post the final version of 3.4 when you know that this bug exists?
Comment 19 Don't use this account, use tml@iki.fi 2011-06-06 11:05:24 UTC
So you think *this* bug is the most seriouos of all bugs. and because of *this* bug we should have slipped the release schedule of 3.4.0? Not the .0. 3.4(.0) is not the "final" 3.4, but the first one. Software always has bugs. This bug in particular causes no data loss, and is extremely simple to avoid: Just turn off the QuickStarter.
Comment 20 Don't use this account, use tml@iki.fi 2011-06-06 11:07:49 UTC
Argh, confusing typo, when I said "Not the .0" I meant "Note the .0".
Comment 21 Nodens 2011-06-06 11:16:19 UTC
Why do you try to defend yourselves? I am not attacking you guys or the development team! I think you got it all wrong. What I meant is that when you have a software release that goes from Alpha to Beta to RC and then to Final, then I think that there is a lot a time to find out bugs that are discovered by you or by beta testers. This bug in particular is an easy bug to find and I believe to solve. Didn't anyone of you restart the computer during the development? I know that I can turn off this feature and solve the problem, I am not stupid you know. The reason I use it is because I think there is a speed improvement. If I am wrong then say it and I will never use it again. As far as I am concerned I use Linux where this option does not exist. The Windows version of Libreoffice is used in my company.
Comment 22 vitriol 2011-06-07 07:08:45 UTC

*** This bug has been marked as a duplicate of bug 38037 ***
Comment 23 vitriol 2011-06-07 07:11:36 UTC
*** Bug 38037 has been marked as a duplicate of this bug. ***
Comment 24 popxunga 2011-06-13 16:27:17 UTC
Hi...
LibreOffice tray icon IS NOT useless.
This function worked before. Please fix it.
Thank you!
Comment 25 Don't use this account, use tml@iki.fi 2011-06-13 17:18:07 UTC
popxunga: so how do you use the QuickStarter tray icon then?
Comment 26 parafine 2011-06-14 09:19:36 UTC
(In reply to comment #25)
> popxunga: so how do you use the QuickStarter tray icon then?

I don't use it really very much. But I know people that open many files in few time to check it content quickly and I think quickstart helps speed-up the process.

The quickstart needs to be run on system start up but without opening OpenOffice/LibreOffice, just putting the icon in the systray.
Comment 27 Don't use this account, use tml@iki.fi 2011-06-14 11:38:33 UTC
> I don't use it really very much

So how do you then know that it actually has any measureable effect on the speed?

> But I know people that open many files in few time to check it 
> content quickly and I think quickstart helps speed-up the
> process.

You "think"? You have not measured?

And do even these people actually use *the icon* in the systray?

They could just as easily "pin" a shortcut to LibreOffice into the taskbar, no?

> The quickstart needs to be run on system start but without 
> opening OpenOffice/LibreOffice,

The "QuickStarter" *is* OpenOffice.org/LibreOffice. It is the same soffice.bin process that is running.

It is not and has never been run on "system start", but when the user who has turned it on logs in.
Comment 28 Scott 2011-06-14 11:46:12 UTC
Isn't the idea of the quickstarter that it pre-loads things for LO to speed the launch of each application?  Plus I can right click on the icon in the system tray and choose an app right from there. Again for quick access.  And why do I want to pin anything to my task bar to waste space that could be used by running apps.
Comment 29 Scott 2011-06-14 11:47:29 UTC
Oh yea also if the quick starter has no real purpose why was it created in the first place?  It must have had a purpose to spend time creating it?
Comment 30 Don't use this account, use tml@iki.fi 2011-06-14 12:02:10 UTC
Sure, it "pre-loads" in the sense that it keeps an instance of OOo/LO running all the time. But you get the same effect by simply keeping a document open and not closing it.

You can also have shortcuts to the LO application "aspects" pinned in the top level of the Start Menu. And if you use LO a lot, the shortcuts will even automatically be kept there by Windows in the latest Windows versions, as far as I know. 

(With "aspect" I mean Writer, Calc etc. I don't want to call them "applications" as they are not separate programs. It is all the same program.) 

Starting/opening LO from there is also just two clicks.

You can also "pin" shortcuts to the LO application aspects right on the taskbar, then one click is enough.

Finally, before somebody actually does measurements: Sure, I admit it is a second or two faster to open a new document window if LO is already running (either the "QuickStarter" is running, i.e. if LO is running without any document window open, or one or several document windows are open). No splash screen is displayed etc. This even on a fast modern machine. But is that enough gain to make all the complexity and bugginess involved worthwhile?

And people for which this matters, who claim they keep opening documents dozens of times per hour for the whole day, why do they keep closing all documents inbetween then? If they just keep one document window open (but minimized, for instance), the effect will be the same as if "QuickStarter" was running.

And on slower, older, resource-starved machines, people who *don't* open documents in LO except a couple of times a day, or even more seldom, do they really want to keep the LO process running all the time?
Comment 31 Cor Nouws 2011-06-14 12:32:50 UTC
Hi Tor,
On windows, depending on your configuration, it is considerable faster.
And yes, people do use the menu from the quickstarter.
I've been long enough around with OOo to have seen a lot of people using it, that it is known and sort of popular.
You may bring a lot of reasons forward that it is moot. That would not be my choice.. 
(Example from my position: it's better to remove (nearly) all toolbars, since shortcut keys and menu's are as handy and faster. Saves space, lots of build, download, load time... :-) )
I prefer to make changes like this on user data.
Comment 32 popxunga 2011-06-14 17:17:03 UTC
(In reply to comment #25)
> popxunga: so how do you use the QuickStarter tray icon then?

Hi Tor!

I use it whenever I want to create a new document... 
I use it because is quite faster to open a document having LO preloaded. 

Depending on...
 the OS being used 
 how much memory is available
 how efficiently the OS uses memory for caching purposes
 other concurrent activities running in the system 
... time needed to load the same document may suffer huge variations.

As no one provided any figures/measures (you included) I give you some taken 
from my system, i5-520M(2.4GHz), 4GB RAM, 320GB 7200rpm HD, running RHEL 6.x:

1st load: aprox 10 seconds
2nd load: 1 < t < 1,5 seconds
3rd load (keeping 2nd doc open) 0,1 < t < 0,3 seconds

(Spreadsheet used has 15 KB size)

BTW .... preload option seems to have been removed already from RPM 64 bit and DEB 32 bit LibreOffice packages ... but as you see RHEL caching is working very well. 

Maybe I'm wrong (and if yes my apologies) but reading everything you wrote in this bug report, it seems that the decision to remove this function (from Windows too) was already taken. So... go ahead but please don't forget to tell everyone to let one document opened all the time to make LO perform well and to tell all the OS providers to do not page or purge LibreOffice modules from system cache ;-)

Thank you!
Comment 33 Don't use this account, use tml@iki.fi 2011-06-15 00:45:46 UTC
popxunga, no decision has been taken, at least by me. See comment #14.
Comment 34 vitriol 2011-06-15 01:46:08 UTC
*** Bug 38333 has been marked as a duplicate of this bug. ***
Comment 35 vitriol 2011-06-15 01:49:49 UTC
Please, see informations reported by Helmut Leininger for Bug 38333. He seems discovering a trivial cause and a simple solution for this bug.
Comment 36 popxunga 2011-06-15 17:56:37 UTC
Hi ...
Just tested the workaround suggested by Helmut Leininger and didn't work here :-(
Thanks :-)
Comment 37 Helmut Leininger 2011-06-16 00:24:12 UTC
Sorry for misleading. OpenOffice 3.4 Beta has the same problem.
Comment 38 Robert Nagy 2011-06-17 01:01:54 UTC
This bug is not windows only, it happens on Linux and BSD too. In addition the Quickstart menu entries are missing on UNX from the Options/Memory screen and if you had it enabled, you can't disable it anymore unless you remove the qstart file by hand from autostart.

After a quick look at the codepath the options should be there but they are being removed somehow.
Comment 39 Robert Nagy 2011-06-17 01:03:08 UTC
(In reply to comment #38)
> This bug is not windows only, it happens on Linux and BSD too. In addition the
> Quickstart menu entries are missing on UNX from the Options/Memory screen and
> if you had it enabled, you can't disable it anymore unless you remove the
> qstart file by hand from autostart.
> 
> After a quick look at the codepath the options should be there but they are
> being removed somehow.

Of course I forgot to mention that since quickstart is broken, you will have the start centre opened in a full window every time you login.
Comment 40 Robert Nagy 2011-06-18 17:06:34 UTC
If you start it with one of the components, e.g.: libreoffice --quickstart --nologo --nodefault --calc, then it works fine. Only the start center is being forced to be shown.
Comment 41 Robert Nagy 2011-06-18 17:14:25 UTC
Created attachment 48149 [details]
Fix.

quickstart should not show the start center either
Comment 42 Scott 2011-06-18 18:43:43 UTC
Does this mean that it's been fixed?
Comment 43 Robert Nagy 2011-06-19 02:25:22 UTC
If the fix gets commited then in the next release it is going to be fixed, yes.
Comment 44 Robert Nagy 2011-06-20 03:04:09 UTC
Fixed.

master:f75aec768846bf16bfe1cbe00a602d5b0497ed56
libreoffice-3-4:9c17674951760b8a64276ee8e1c6496e21ad756e