Bug 37436 - Libreoffice 3.4 RC1 has less informative error messages than 3.3.2
Summary: Libreoffice 3.4 RC1 has less informative error messages than 3.3.2
Status: RESOLVED DUPLICATE of bug 37370
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-21 08:40 UTC by sergio.callegari
Modified: 2011-05-21 12:17 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2011-05-21 08:40:37 UTC
On an ubuntu 64 bit system.

Macros scripts that used to work nicely with 3.3.2 now die with "general error" and I cannot understand the reason.

For instance, consider the following snippet


Sub SaveSlidesAsPDF(srcFile)

srcURL = ConvertToURL( srcFile )

dim oPropDoc(0) as New com.sun.star.beans.PropertyValue
oPropDoc(0).Name="Hidden"
oPropDoc(0).Value=True

'msgbox(srcURL)

oDoc = StarDesktop.loadComponentFromURL( srcURL, "_blank", 0, _
  oPropDoc())

pdfFile=Left(srcFile,Len(srcFile)-4)+".pdf"
pdfURL=ConvertToURL( pdfFile )

Dim oPropPDF(1) As New com.sun.star.beans.PropertyValue
oPropPDF(0).Name="ExportNotesPages"
oPropPDF(0).Value=true

Dim oProp(3) As New com.sun.star.beans.PropertyValue
oProp(0).Name="Overwrite"
oProp(0).Value=true
oProp(1).Name="FilterName"
oProp(1).Value="impress_pdf_Export"
oProp(2).Name="FilterData"
oProp(2).Value=oPropPDF()

oDoc.storeToURL(pdfURL,oProp())

oDoc.close( True )

End Sub

This used to work just fine with 3.3.2 but now dies at the

oDoc = StarDesktop.loadComponentFromURL( srcURL, "_blank", 0, oPropDoc())

with "General Error" that unfortunately is not a very informative error message.
Comment 1 sergio.callegari 2011-05-21 12:07:51 UTC
My fault. I was erroneously passing a relative rather than an absolute path. Sorry for the noise.

There is still a problem, though.

For this case, libreoffice 3.4 seems to generate a general error while 3.3.2 was more correctly reporting a path that could not be handled.
Comment 2 sergio.callegari 2011-05-21 12:09:04 UTC
Changed title and importance level accordingly.
Comment 3 vitriol 2011-05-21 12:17:30 UTC

*** This bug has been marked as a duplicate of bug 37370 ***