Download it now!
Bug 37573 - Exporting to PDF with code128-font adds space after first character
Summary: Exporting to PDF with code128-font adds space after first character
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2011-05-25 04:06 UTC by Christofer
Modified: 2019-11-09 20:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of how it looks in adobe reader (39.57 KB, image/png)
2011-05-25 04:06 UTC, Christofer
Details
screenshot of how it looks in libreoffice calc (39.32 KB, image/png)
2011-05-25 04:06 UTC, Christofer
Details
ODS exemple with code 128 (21.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-31 14:58 UTC, François
Details
PDF result of export ODS file with code 128 (54.60 KB, application/pdf)
2014-12-31 14:59 UTC, François
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christofer 2011-05-25 04:06:10 UTC
Created attachment 47135 [details]
screenshot of how it looks in adobe reader

When exporting to PDF using the font and example provided in http://code.google.com/p/openoffice-code128/ it adds an additional space after the first character. Since it's an barcode-font the space can't be there or the barcode can't be read.

It displays it correctly in LibreOffice Calc, but the exported pdf is invalid in both Adobe Reader and Google Chrome. 

Windows version: Windows 7 professional SP 1
LibreOffice version: LibO_3.3.2_Win_x86_install_multi.exe
Adobe Reader version: 10.0.1
Google Chrome version: 11.0.696.68
Comment 1 Christofer 2011-05-25 04:06:49 UTC
Created attachment 47136 [details]
screenshot of how it looks in libreoffice calc
Comment 2 Björn Michaelsen 2011-12-23 12:07:47 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:00:45 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:01:53 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:06:35 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:08:37 UTC Comment hidden (obsolete)
Comment 7 François 2013-04-30 09:06:23 UTC
Hi,
I reopened the bug. I have the same problem as described by Christofer.
I did a test with 3.6.5.2 & 4.0.2.2 LibreOffice release.

You can reproduce the problem with the example: http://code.google.com/p/openoffice-code128/

Windows version: Windows 7 Enterprise N SP 1
LibreOffice version: LibO_3.6.5_Win_x86_install_multi.msi + LibO_3.5.6_Win_x86_helppack_fr.msi (3.6.5.2)
Adobe Reader version: 10.1.3

Windows version: Windows 7 Enterprise N SP 1
LibreOffice version: LibreOffice_4.0.2_Win_x86.msi + LibreOffice_4.0.2_Win_x86_helppack_fr.msi (4.0.2.2)
Foxit Reader version: 5.1.0.1021
Comment 8 Joel Madero 2014-11-04 03:34:57 UTC
Never confirmed by QA team - moving to UNCONFIRMED.
Comment 9 Robinson Tryon (qubit) 2014-12-23 20:03:10 UTC
(In reply to François from comment #7)
> Hi,
> I reopened the bug. I have the same problem as described by Christofer.
> I did a test with 3.6.5.2 & 4.0.2.2 LibreOffice release.

Christofer/Francois: Could one of you please upload an example ODS and exported PDF?

Thanks!

(Change status -> UNCONFIRMED after uploading the documents)
Comment 10 François 2014-12-31 14:58:32 UTC
Created attachment 111579 [details]
ODS exemple with code 128
Comment 11 François 2014-12-31 14:59:19 UTC
Created attachment 111581 [details]
PDF result of export ODS file with code 128
Comment 12 François 2014-12-31 15:03:35 UTC
Hi,

I updload an example ODS and exported PDF.
I download my exemple from : http://code.google.com/p/openoffice-code128/

Today, I use LibreOffice : 4.2.6.2
Regards.
Comment 13 retired 2015-01-04 11:23:20 UTC
Hi all, I don't understand what the issue is here.

bug description says "the exported pdf is invalid in both Adobe Reader and Google Chrome".

For me the " PDF result of export ODS file with code 128" does load fine in chromium, osx preview.app and acrobat.

So original problem is def. fixed and this bug is worksforme. If other bugs with the test file are remaining, please open a new bug and add exact reproduce steps.

Thanks.
Comment 14 Buovjaga 2015-01-04 11:31:23 UTC
Installed the code 128 font. Exported attachment 111579 [details] from Calc to PDF and can confirm that the gap is there.

Setting to NEW.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 57626f2132f73e4e42b31e364b25c5867336e718
TinderBox: Win-x86@42, Branch:master, Time: 2014-12-26_09:26:33
Comment 15 QA Administrators 2016-01-17 20:05:37 UTC Comment hidden (obsolete)
Comment 16 Aron Budea 2016-05-06 08:54:50 UTC
Still reproducible.

Version: 5.1.2.2
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: hu-HU (hu_HU)
	
Important information:
Behavior depends on this setting (Windows 7): Control Panel -> Region and Language -> Administrative tab -> Language for non-Unicode programs: Change system locale...

With system locale set to Hungarian (Hungary), in Calc text has some squares (bug 88021), but looks fine in exported PDF (no squares, no extra space).
With system locale set to English (United States), in Calc text looks fine, but has the space in exported PDF.
Comment 17 QA Administrators 2017-10-30 08:33:42 UTC Comment hidden (obsolete)
Comment 18 eisa01 2019-11-09 20:40:25 UTC
This works fine

Tested in Edge Firefox, Preview Mac and Adobe Acrobat Pro Mac

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded