Bug 37608 - Index of Tables cannot generate hyperlinks
Summary: Index of Tables cannot generate hyperlinks
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: TableofContents-Indexes Hyperlink
  Show dependency treegraph
 
Reported: 2011-05-25 17:01 UTC by Aaron Williams
Modified: 2017-08-21 11:48 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2011-05-25 17:01:37 UTC
There appears to be no way to generate hyperlinks when creating an index of tables. This should behave like the table of contents.
Comment 1 Jean-Baptiste Faure 2011-05-29 07:58:45 UTC
I agree, that would be better but it works as designed, so that is not a bug: changed for enhancement.
Comment 2 Björn Michaelsen 2011-12-23 12:04:38 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2011-12-25 14:17:04 UTC
Enhancement => setting as NEW.

Best regards. JBF
Comment 4 Davide Cavestro 2012-05-23 23:49:55 UTC
Still happens on
LibreOffice 3.4.6 
OOO340m1 (Build:602)

This feature would be very useful.
See also https://bugs.freedesktop.org/show_bug.cgi?id=39904
Comment 5 Jose Gómez 2014-05-18 19:09:46 UTC
Same issue is still present in 4.2.3.3. Illustration Index and Table of Contents can include hyperlinks, but for some reason not Index of Tables. It definitely doesn't look like a design decision.
Comment 6 Jose Gómez 2014-05-18 19:11:49 UTC
Note that there is no workaround available.
Comment 7 Jorge Telechea 2015-09-08 02:29:29 UTC
It's still present on LibreOffice 5.0.1.2 as of september 7, 2015. It would be nice if you people fix this minor bug in a future release.
Comment 8 Johnny_M 2016-07-27 20:05:07 UTC
(In reply to Jose Gómez from comment #6)
> Note that there is no workaround available.

Actually, there seems to be a workaround available: When inserting the index, select "Illustration Index" (instead of the "Index of Tables") as type, and set the category to "Table" (instead of "Illustration"). And change the title to "Index of Tables".

There is a problem currently, though: The "Illustration Index" has a bug - it loses its hyperlinks after the file gets closed and reopened and the index then updated. See bug 71737 comment 7. But it could be enough to do, e.g., a PDF export right after index creation.

As pointed out in comment 5, and since "Illustration Index" and "Index of Tables" are almost the same, it's strange that the latter doesn't have hyperlinks. In fact, the issue seems to be rather configurational: The only difference between the two indexes seems to be their "Structure" in the "Entries" tab of the "Insert Index or Table of Contents" window, where the "Index of Tables" lacks the "LS" (hyperlink start) and "LE" (hyperlink end) fields.
Comment 9 Ulrich Windl 2016-10-24 13:50:33 UTC
(In reply to Jean-Baptiste Faure from comment #1)
> I agree, that would be better but it works as designed, so that is not a
> bug: changed for enhancement.

Could you please explain that "design": In LibreOffice 5.1.5 I can have hyperlinks in the table of contents, I can have hyperlinks in the table of figures (images), but I cannot have hyperlinks in the table of tables.
Hopefully it is not because someone was afraid of endless recursion ;-)
Comment 10 Jean-Baptiste Faure 2016-10-25 04:32:26 UTC
(In reply to Ulrich Windl from comment #9)
> (In reply to Jean-Baptiste Faure from comment #1)
> > I agree, that would be better but it works as designed, so that is not a
> > bug: changed for enhancement.
> 
> Could you please explain that "design" [...]

This function has not been coded so it can't be bugged. I agree it is missing, so it is not a bug, it is an enhancement.

Best regards. JBF