Bug 37636 - VIEWING: Underlining / Overlining in running Slide Show black despite colored
Summary: VIEWING: Underlining / Overlining in running Slide Show black despite colored
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 69475 (view as bug list)
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2011-05-26 08:59 UTC by Christopher M. Penalver
Modified: 2019-11-27 19:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
underline.odp (9.03 KB, application/vnd.oasis.opendocument.presentation)
2011-05-26 08:59 UTC, Christopher M. Penalver
Details
View on Slide Show mode: all text are black (9.44 KB, image/png)
2013-01-15 17:17 UTC, vulcain
Details
Noramal view with LibreOffice 4.0: text with color (111.13 KB, image/png)
2013-01-15 17:19 UTC, vulcain
Details
sample with multi-color text (8.62 KB, image/png)
2015-02-05 10:51 UTC, ifanlo
Details
Illustrating the colour underline bug in Impress 5.1.4.2 (100.76 KB, image/jpeg)
2016-11-10 11:51 UTC, Nick T
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-26 08:59:30 UTC
Created attachment 47192 [details]
underline.odp

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/107854

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=56520

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/107854/+attachment/2143745/+files/underline.odp && loimpress -nologo underline.odp

the text with colored underlines should remain colored in Slide Show.

4) What happens instead is the underlines are black in Slide Show.
Comment 1 Don't use this account, use tml@iki.fi 2011-05-27 00:12:47 UTC
Impress, for Thorsten?
Comment 2 Rainer Bielefeld Retired 2011-06-24 01:40:39 UTC
[Reproducible] with Daily Build similar to "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:101)]". Also Overlining is affected as expected.

The problem also is visible for a WRITER text object in Presentation. 

I modified Status to Assigned due to facts.
Comment 3 Cyril 2011-07-09 15:17:52 UTC
Confirmed with LibreOffice 3.3.3 Impress on Win XP & Linux Mandriva 2010 x86.
Comment 4 Björn Michaelsen 2011-12-23 13:25:49 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 5 Anastasius 2012-02-28 11:26:44 UTC
Still present in LibreOffice 3.5.0rc3 (Mac OS X 10.6.8 Intel Core i5)
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

On well-designed slides the black underlining can look quite ugly.

Also I use underline colors to provide a visual link to different elements in a drawing having the same color; but I have to use color lines instead (which have to be modified each time the text is edited and thus shifted) - annoying.
I'd give it a higher priority.
Comment 6 vulcain 2013-01-15 17:17:16 UTC
Created attachment 73108 [details]
View on Slide Show mode: all text are black

Same problem with LibreOffice Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0) on Ubuntu 12.04 x86_64
Comment 7 vulcain 2013-01-15 17:19:53 UTC
Created attachment 73109 [details]
Noramal view with LibreOffice 4.0: text with color
Comment 8 Björn Michaelsen 2013-02-24 10:52:28 UTC
This bug seems to be a bit confused:
status ASSIGNED with no assignee is unhelpful, back to new, CC Thorsten.
Comment 9 ign_christian 2013-09-18 04:26:44 UTC
*** Bug 69475 has been marked as a duplicate of this bug. ***
Comment 10 vulcain 2013-12-16 21:15:30 UTC
Bug are still here T_T
Tested on Ubuntu 12.04 x86_64:
LibreOffice 4.2.0.0.beta2 (Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d ) and LibreOffice 4.1.4.2 (Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72)
Comment 11 vulcain 2014-03-19 17:00:16 UTC
Still here in LibreOffice 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13 on Ubuntu 12.04.4
Comment 12 vulcain 2014-07-31 06:31:25 UTC
Bug still inside on Ubuntu 12.04.4 x86_64 with LibreOffice 4.3.0.3 Build ID: 08ebe52789a201dd7d38ef653ef7a48925e7f9f7
Comment 13 ifanlo 2015-02-05 10:51:56 UTC
Created attachment 113142 [details]
sample with multi-color text

It really does not show the black color, but the automatic color. The example had applied the black underlined.
Comment 14 tommy27 2016-04-16 07:27:11 UTC Comment hidden (obsolete)
Comment 15 obnru.h 2016-10-13 19:28:57 UTC
libreoffice 5.2.2.2 still has the bug
Comment 16 Nick T 2016-11-10 11:51:47 UTC
Created attachment 128640 [details]
Illustrating the colour underline bug in Impress 5.1.4.2

This bug is still present in Impress in LO 5.1.4.2 (as distributed with Ubuntu 16.04 LTS).

Setting the text underscore colour looks ok in slide design view and in the thumbnail preview in Presenter Console but it gets rendered black on the projected slide.
Comment 17 Nick T 2016-11-10 12:04:55 UTC
Further comment. (Impress in LO 5.1.4.2)

If you set a text colour for the underlined text and a different colour for the underline, the underline gets rendered in the text colour.  So perhaps the bug is that the text colour is overriding any underscore colour setting for the characters when rendered.
Comment 18 Marcel Waldvogel 2017-04-25 12:07:53 UTC
BTW: Export to PDF works as expected; it is only in the slide view that it is broken. As the design rules for our university demand colored underlines, this is a show-stopper for having LibreOffice deployed instead of proprietary tools.
Comment 19 p10 2017-05-09 09:20:08 UTC
The bug is still there in LO 5.2.6.2
Comment 20 QA Administrators 2018-08-20 02:32:23 UTC Comment hidden (obsolete)
Comment 21 sam tygier 2018-08-20 08:10:28 UTC
I can still reproduce the bug in LO 6.0

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 4; OS: Linux 4.17; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.utf8); Calc: group
Comment 22 Commit Notification 2018-11-05 11:21:37 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9709061a570a4867a4c5898ffed936b4b47ce90f%5E%21

tdf#37636 take care of MetaOverlineColorAction in mtfrenderer.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2018-11-05 11:21:45 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b0da1ca2d7a426ff13f39b21362fbcd5c0580c24%5E%21

tdf#37636 create underlines, overlines, strikeout separately

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2018-11-05 11:34:31 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8abe2d0ff1d87f1db406ab9367a6ee7edb6d234d%5E%21

tdf#37636: pass bNormalText to cppcanvas::internal::TextRenderer.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2018-11-05 12:17:00 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/13b4c191cb251e9218bb9c99140cff7c52fd04db%5E%21

tdf#37636 Render textlines with colors.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Anastasius 2019-11-27 19:15:50 UTC
Yes, it works, thank you!
(LO 6.2.8.2)