Bug 37668 - Math crashed after put some elements
Summary: Math crashed after put some elements
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
: 36306 37736 38578 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-27 09:17 UTC by Mateusz
Modified: 2011-10-29 07:38 UTC (History)
5 users (show)

See Also:


Attachments
backtrace (14.08 KB, text/x-log)
2011-05-27 09:32 UTC, clio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2011-05-27 09:17:53 UTC
Hi

From "Elements" window choose "Formats"

If you click on "vertical stack (2 elements)", "vertical stack", "matrix stack" and "new line", Math will be broken.

I have the newest 3.4 RC2 and Ubuntu 10.04.
Comment 1 clio 2011-05-27 09:32:36 UTC
Created attachment 47233 [details]
backtrace

I can confirm this on Linux with LibO 3.4 rc2 (Crash)
Comment 2 Jean-Baptiste Faure 2011-05-29 03:17:43 UTC
I do not reproduce the crash on Ubuntu 10.04 x86_64 : probably x86 only bug.
Comment 3 Petr Mladek 2011-05-30 03:06:22 UTC
I am able to reproduce this on SLED10-SP3-i586. I do not see it on SLED11-SP1-x86_64. It really seems to be 32-bit specific.
Comment 4 Mateusz 2011-06-05 02:13:29 UTC
Program still works well if you insert these elements from Writer.
Comment 5 Caolán McNamara 2011-06-08 05:00:00 UTC
*** Bug 36306 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2011-06-08 08:23:28 UTC
starmath unit test on master apparently crashes in the same place for some people as well, this must be glyph substitution going wrong somehow
Comment 7 Caolán McNamara 2011-06-09 01:18:09 UTC
Fixed (in theory, I can't reproduce it) as http://cgit.freedesktop.org/libreoffice/libs-gui/commit/?id=0adcbfa45f1c387d35acdc34c4a945dc88fecead in master
Comment 8 Caolán McNamara 2011-06-09 02:41:36 UTC
*** Bug 36306 has been marked as a duplicate of this bug. ***
Comment 9 Caolán McNamara 2011-06-09 02:59:47 UTC
got cherry-picked to 3.4 branch now
Comment 10 Rainer Bielefeld Retired 2011-06-10 02:57:55 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 11 LeMoyne Castle 2011-06-12 19:27:12 UTC
*** Bug 37736 has been marked as a duplicate of this bug. ***
Comment 12 Caolán McNamara 2011-06-28 01:45:37 UTC
*** Bug 38578 has been marked as a duplicate of this bug. ***