Bug Hunting Session
Bug 37754 - In edit mode formula preview window is shifted in Draw
Summary: In edit mode formula preview window is shifted in Draw
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86 (IA32) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 117360 (view as bug list)
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2011-05-30 08:38 UTC by Regina Henschel
Modified: 2019-05-27 09:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of shifted preview area of formula (6.26 KB, image/png)
2011-05-30 08:38 UTC, Regina Henschel
Details
Sample document (159.59 KB, application/vnd.oasis.opendocument.graphics)
2012-08-14 17:56 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2011-05-30 08:38:55 UTC
Created attachment 47321 [details]
Screenshot of shifted preview area of formula

Open Draw document.
Insert formula or edit existing one.
Notice that there are green handles at the position where the formula will be placed. Those handles should not be there, but the preview area. The preview area of the formula is shifted left, down.
Comment 1 Rainer Bielefeld Retired 2011-06-10 02:57:42 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 2 Björn Michaelsen 2011-12-23 12:06:01 UTC Comment hidden (obsolete)
Comment 3 Regina Henschel 2011-12-28 14:14:57 UTC
Armin has improved the graphic properties of OLE objects for ApacheOpenOffice. When this improvements will be integrated in LibreOffice the part with the green handles will no longer exist in edit mode and the preview rectangle will be at the correct place.
I think, that we should not work on this bug now but wait till ApacheOpenOffice is available.
Comment 4 Florian Reisinger 2012-08-14 14:03:44 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:04:40 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:09:09 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:11:10 UTC Comment hidden (obsolete)
Comment 8 Rainer Bielefeld Retired 2012-08-14 14:49:20 UTC
[Reproducible] with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit), Formula appears within green handles, not within preview area.

Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7d8cd0a]" (tinderbox: 2008R2@20, pull time 2012-08-10 23:27:17)
Comment 9 Rainer Bielefeld Retired 2012-08-14 15:03:23 UTC
I already see such divergence with LibO 3.3.3, Bight have been broken from the beginning.

AOOo does not show any control points as long as Formula edit mode is active, only preview area. And The place of the preview area is the place where the formula will be.



@Radek:
No Idea whether this is more a DRAW or more a Formula Editor problem
Can you please check?
Comment 10 Rainer Bielefeld Retired 2012-08-14 17:56:11 UTC
Created attachment 65559 [details]
Sample document

With screenshots and example for your own tests
Comment 11 QA Administrators 2015-01-05 17:52:12 UTC Comment hidden (obsolete)
Comment 12 Regina Henschel 2015-01-05 23:59:52 UTC
The bug is partly there in Version: 4.5.0.0.alpha0+
Build ID: 5b829710d65310c6082c2c65ec1239515e319a8e
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-02_06:39:26
Locale: de_DE
The initial view is still wrong, when switching to edit mode. But when you move the scrollbar of the document, the object jumps to the correct place.
Comment 13 QA Administrators 2016-01-17 20:04:30 UTC Comment hidden (obsolete)
Comment 14 Regina Henschel 2016-01-17 21:09:37 UTC
My comment 12 is still true for Version: 5.2.0.0.alpha0+
Build ID: e413549dc8b5669a806eeabc30c7d6f92723a882
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-28_23:26:49
Locale: de-DE (de_DE)
Comment 15 Regina Henschel 2017-04-19 16:58:51 UTC
Bug still there in Version: 5.4.0.0.alpha0+
Build ID: e175f9f4393eb3badd763fa5b1cdc5b3aabab0e4
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-19_01:06:49
Locale: de-DE (de_DE); Calc: group
Comment 16 Regina Henschel 2018-05-23 22:30:18 UTC
*** Bug 117360 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2018-05-23 22:44:05 UTC
@Armin, Caolán - seems this might not have been picked up back in the day when comment 3 was made. Any chance the OLE handling of sm Formulas in Draw/Impress can be tweaked to "register" the views so the formula occupies the same position when being edited?
Comment 18 QA Administrators 2019-05-25 02:56:59 UTC Comment hidden (obsolete)
Comment 19 muso 2019-05-27 09:38:33 UTC
> If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.

Tested with
https://bugs.documentfoundation.org/attachment.cgi?id=141934
the bug is still in
Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: CL