Bug Hunting Session
Bug 37867 - Page border printed over the content when there is an image in the document
Summary: Page border printed over the content when there is an image in the document
Status: CLOSED DUPLICATE of bug 37488
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-06-02 14:43 UTC by Guilherme
Modified: 2012-05-08 06:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document to reproduce the problem (15.61 KB, application/vnd.oasis.opendocument.text)
2011-06-02 14:43 UTC, Guilherme
Details
Example document printed as PDF with PDFCreator (9.84 KB, application/pdf)
2011-06-02 14:44 UTC, Guilherme
Details
Printing problem with paragraph borders (59.02 KB, application/pdf)
2011-07-15 04:58 UTC, MVPRC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guilherme 2011-06-02 14:43:00 UTC
Created attachment 47462 [details]
Document to reproduce the problem

This is a regression problem. It works on LO 3.3.1.

To reproduce (on LO 3.4.0 RC2):

1- Create a new document on Writer (- or try with the document attached)
2- On the menu: Format > Page > Border and insert a simple "four border" on the document
3- Paste any image on this page
4- Print the document, or check the pdf attached (printed with PDFCreator)

On all printers in my company and printing with PDFCreator the results are the same. Page border is printed with wrong coordinates, over the content, messing it up... this does not happens in LO 3.3.1.

The export as PDF function works fine. The problem happens only when printing.

It is a blocker to me, as I will only be able to upgrade to 3.4 when this is fixed.
Comment 1 Guilherme 2011-06-02 14:44:12 UTC
Created attachment 47463 [details]
Example document printed as PDF with PDFCreator
Comment 2 Andras Timar 2011-06-06 05:54:25 UTC
I lowered severity a bit, because workaround exists (export to PDF then print) and it is working well in 3.3.x. I set regression keyword.
Comment 3 Nicolas R 2011-06-08 13:06:00 UTC
(In reply to comment #2)
> I lowered severity a bit, because workaround exists (export to PDF then print)
> and it is working well in 3.3.x. I set regression keyword.

Duplicate with bug 38041 and bug 37488 , I think.

But imho it's a real stopper/ blocker for migration to 3.4.0. There is a workaround but it's not really obvious.
You must think before printing : 'Oh there are borders in my doc, and there is also a picture, so I must export to pdf , then print the pdf ....'. For a professional use with many 'end users' , it's not usable...

It MUST be fixed in 3.4.1 ( sorry, 'must' is a little bit rude, even more in uppercase), so I think 'severity' should be 'high' or 'highest' and importance as least 'major' ....

Sorry for my rudeness, but in our company, the migration from Microsoft Office to Ooo / LibO has been difficult, so this kind of regression is almost impossible to explain to 'end-users'.

But related bug 37488 is classified 'critical' ... so no problem.
Comment 4 Rainer Bielefeld Retired 2011-06-10 02:57:20 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 5 MVPRC 2011-07-15 04:57:06 UTC
Problem persists with LibreOffice 3.4.1 OOO340m1 (Build:103)

A paragraph border prints over 2 pages and other paragraph borders don't print. Please see attachment.
Comment 6 MVPRC 2011-07-15 04:58:13 UTC
Created attachment 49131 [details]
Printing problem with paragraph borders
Comment 7 manj_k 2011-07-16 13:25:43 UTC
Printing 'pageBorderPrintProblem.odt' works well with LibO 3.4.2 RC1.

*** This bug has been marked as a duplicate of bug 37488 ***
Comment 8 manj_k 2012-05-08 06:20:22 UTC
Closed