Bug Hunting Session
Bug 37880 - FILEOPEN .xlsx: defined names are not recognized
Summary: FILEOPEN .xlsx: defined names are not recognized
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.5 target:3.4.2
Keywords:
: 38763 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-03 08:22 UTC by Marius
Modified: 2012-11-30 05:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (11.76 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2011-06-07 18:35 UTC, Marius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius 2011-06-03 08:22:15 UTC
After opening al xlsx file the defined names are not recognized and the references to them  are substituted with "=#NAME?". It's worth to mention that the same file is perfectly recognized by version 3.3.2 .
Comment 1 Markus Mohrhard 2011-06-06 20:44:20 UTC
Can you provide a test document that shows the problem?
Comment 2 Marius 2011-06-07 18:35:54 UTC
Created attachment 47698 [details]
test file

In the ver. 2.0 sheet you can see the bug.
Comment 3 Rainer Bielefeld Retired 2011-06-10 02:58:08 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 4 Markus Mohrhard 2011-06-16 10:20:53 UTC
thanks for your test file.

we have a similar bug report for xls: https://bugs.freedesktop.org/show_bug.cgi?id=38204

Let's see if they have point to the same problem.

I have a look at both.
Comment 5 Markus Mohrhard 2011-06-22 10:22:00 UTC
Ok I have a fix and I think I will add it to master in some days.

I think we will add it to 3.4.2 too.
Comment 6 Markus Mohrhard 2011-06-23 06:37:37 UTC
pushed to master, before it will pushed to 3-4 Kohei should have a look at it
Comment 7 Katarina Behrens 2011-06-29 05:08:14 UTC
*** Bug 38763 has been marked as a duplicate of this bug. ***
Comment 8 Kohei Yoshida 2011-07-07 22:44:48 UTC
Pushed to the -3-4 branch as well for 3.4.2.