Download it now!
Bug 37883 - LO 3.4 (final) Writer, Calc, Impress crash at startup
Summary: LO 3.4 (final) Writer, Calc, Impress crash at startup
Status: RESOLVED DUPLICATE of bug 38913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 44747 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-03 08:56 UTC by Roman Polach
Modified: 2012-07-21 10:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot in the time of the crash (62.21 KB, image/png)
2011-06-03 08:56 UTC, Roman Polach
Details
crash at start again (now installed only Czech and English dictionaries) (59.41 KB, image/png)
2011-06-10 07:22 UTC, Roman Polach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Polach 2011-06-03 08:56:03 UTC
Created attachment 47482 [details]
screenshot in the time of the crash

LibreOffice applications (tried Calc, Writer, Impress) crash at start -
when splash-screen shows message "Povolit: Hungarian spelling disctionary, hyphenation patterns, and thesaurus".

It crashes only in 3.4.0. LibreOffice 3.3.1 and 3.3.2 were fine.

I chose typical installation, for all users. Tried twice - first as upgrade from 3.3.2 and second one with previous clean uninstall of LibreOffice. In both cases the same result: crash at app start.

Windows-7 64bit, Czech locale

Installed from LibO_3.4.0_Win_x86_install_multi.exe

Note: I did not chose or used Hungarian dictionary, locale or such - so the message seems strange for me.

Note 2: I never have installed Java. In previous versions of LO there were warning messages at start due to this but they could have been ignored and LO runs with no problems. Now in 3.4 there were no such messages (maybe they would appear if it would not have crashed?) - I do not know if this is relevant..
Comment 1 Andras Timar 2011-06-09 02:21:14 UTC
Unfortunately I could not reproduce the problem. I tried it on English Windows 7, not Czech by the way. 

Try Custom Install, and de-select Hungarian dictionaries. Let us know if it crashes, too.
Comment 2 Roman Polach 2011-06-10 07:21:16 UTC
I did uninstall and then clean install of 3.4 again,
with deselecting all languages but Czech and English
in the dictionary subtree...

After installation, applications still crashes, but
now splash-screen displays different text
(see attached screenshot)

Btw. I wonder, why dictionaries for all languages
are checked for installation by default... while
"language tools" have checked only Czech and English
by default.
Comment 3 Roman Polach 2011-06-10 07:22:08 UTC
Created attachment 47811 [details]
crash at start again (now installed only Czech and English dictionaries)
Comment 4 Don't use this account, use tml@iki.fi 2011-06-10 07:25:45 UTC
> I wonder, why dictionaries for all languages are checked for 
> installation by default..

Because there is no way to guess what language dictionaries are useful to the user. Trying to be clever will just piss some people off. Nationalism is a disease. Better to be totally neutral.
Comment 5 Roman Polach 2011-06-16 15:58:56 UTC
This bug has keyword NEEDINFO.
Should I provide some more info?
E.g. can be some debug log taken?
Comment 6 hechacker1 2011-07-02 12:09:02 UTC
I'm also experiencing this bug using LibO_3.4.1_Win_x86_install_multi.exe

Default custom options only have English checked.

I also tried manually installing Hungarian support, because that is where it visibly crashes on startup. No change.

Windows 7 x64 Sp1 (fully patched).
English US

Has any progress been made on this?
Comment 7 hechacker1 2011-07-02 12:16:24 UTC
(In reply to comment #6)
> I'm also experiencing this bug using LibO_3.4.1_Win_x86_install_multi.exe
> 
> Default custom options only have English checked.
> 
> I also tried manually installing Hungarian support, because that is where it
> visibly crashes on startup. No change.
> 
> Windows 7 x64 Sp1 (fully patched).
> English US
> 
> Has any progress been made on this?

I did my own checking. I deleted all references to Hungarian support in C:\Program Files (x86)\LibreOffice 3.4\share\extensions.

Then it crashed at "enabling beanshell" or something like that.

So I went back and deleted script-provider-for-beanshell, and now it starts up.
Comment 8 Don't use this account, use tml@iki.fi 2011-07-02 23:52:59 UTC
When you say "Hungarian support", what do you mean exactly? User interface translated to Hungarian, or spell checking and dictionaries for Hungarian? And how exactly did you "delete" the beanshell thing?
Comment 9 Roman Polach 2011-07-11 04:33:27 UTC
Seems to be fixed in 3.4.1 for me.
Comment 10 tareris-temle 2011-07-12 10:18:01 UTC
I had a crash that was identical to this one. The cause was I only had the 64 bit java runtime installed. It seemed that Libre Office was trying to use it and crashing rather than detecting it as x64 and dismissing it. I installed the 32 bit jre and office worked as expected.
Comment 11 Roman Polach 2011-07-12 14:26:30 UTC
...it is different from me: I have had no jre installed - 32bit nor 64bit
Comment 12 Randy Orrison 2011-07-24 23:49:38 UTC
This is also happening to me on Windows 7 Pro (64 bit).  I upgraded a working install of 3.3 by installing LibO_3.4.1_Win_x86_install_multi and LibO_3.4.1_Win_x86_helppack_en-GB.  I have 64-bit Java 6.0.260 installed.  I'm getting a crash at startup with the splash screen displaying "Enabling: Hungarian spelling dictionary, hyphenation patters, and thesaurus".  Right now, LibreOffice is unusable on this PC.
Comment 13 Joe T. 2011-08-12 21:49:17 UTC
Win7 x64 Ultimate
LibreOffice 3.4.2 (upgraded to the same directory without problem or option changes since the original LO release).

i am having the exact same problem described above.

When i run the Custom install path, the 3 English language pack entries (US, UK, South African) are selected. All others are deselected. Even after a complete uninstall. i go into the LibreOffice folder and delete any folders not removed by the uninstaller. i search the registry for references to LibreOffice that might connect to the Hungarian dictionary... Looks like all clear. But it still crashed on launch.

i'm not changing any other selections in the Custom options, except the install path, where i remove the version number from the install path (a separate rant: that should really go away).

As for Java, i have the 64 & 32 bit versions (v6 update 26) installed. At one point i also had both JDKs installed. i can't remember which of these 4 possible Java runtimes i selected inside LibreOffice, but shouldn't LO be able to disengage itself from a selected runtime if it fails to link up during launch? And where do i find this magic configuration to point it elsewhere?
Comment 14 Joe T. 2011-08-12 22:10:47 UTC
(In reply to comment #13)
> Win7 x64 Ultimate
> LibreOffice 3.4.2 (upgraded to the same directory without problem or option
> changes since the original LO release).
> 
> i am having the exact same problem described above.
> 
> When i run the Custom install path, the 3 English language pack entries (US,
> UK, South African) are selected. All others are deselected. Even after a
> complete uninstall. i go into the LibreOffice folder and delete any folders not
> removed by the uninstaller. i search the registry for references to LibreOffice
> that might connect to the Hungarian dictionary... Looks like all clear. But it
> still crashed on launch.
> 
> i'm not changing any other selections in the Custom options, except the install
> path, where i remove the version number from the install path (a separate rant:
> that should really go away).
> 
> As for Java, i have the 64 & 32 bit versions (v6 update 26) installed. At one
> point i also had both JDKs installed. i can't remember which of these 4
> possible Java runtimes i selected inside LibreOffice, but shouldn't LO be able
> to disengage itself from a selected runtime if it fails to link up during
> launch? And where do i find this magic configuration to point it elsewhere?


And not 5 minutes after posting this:
%APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml


DELETE THAT FILE. LibreOffice will re-create it on the next launch, and LibreOffice will launch successfully.
Comment 15 hechacker1 2011-08-19 16:29:08 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Win7 x64 Ultimate
> > LibreOffice 3.4.2 (upgraded to the same directory without problem or option
> > changes since the original LO release).
> > 
> > i am having the exact same problem described above.
> > 
> > When i run the Custom install path, the 3 English language pack entries (US,
> > UK, South African) are selected. All others are deselected. Even after a
> > complete uninstall. i go into the LibreOffice folder and delete any folders not
> > removed by the uninstaller. i search the registry for references to LibreOffice
> > that might connect to the Hungarian dictionary... Looks like all clear. But it
> > still crashed on launch.
> > 
> > i'm not changing any other selections in the Custom options, except the install
> > path, where i remove the version number from the install path (a separate rant:
> > that should really go away).
> > 
> > As for Java, i have the 64 & 32 bit versions (v6 update 26) installed. At one
> > point i also had both JDKs installed. i can't remember which of these 4
> > possible Java runtimes i selected inside LibreOffice, but shouldn't LO be able
> > to disengage itself from a selected runtime if it fails to link up during
> > launch? And where do i find this magic configuration to point it elsewhere?
> 
> 
> And not 5 minutes after posting this:
> %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml
> 
> 
> DELETE THAT FILE. LibreOffice will re-create it on the next launch, and
> LibreOffice will launch successfully.

I got this error again with 3.4.2. And deleting the file you mentioned seems to have solved the problem.

Thanks.
Comment 16 Hendy Irawan 2011-09-02 00:37:51 UTC
(In reply to comment #14)

> And not 5 minutes after posting this:
> %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml
> 
> 
> DELETE THAT FILE. LibreOffice will re-create it on the next launch, and
> LibreOffice will launch successfully.

@ Joe T. : You're a GOD !

After deleting that will, LibreOffice starts up and displays the following message : (7 times)

- JRE is Defective

LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Java.

I'm using Windows 7 SP 1 64-bit Home Premium + Oracle JDK 64-bit.

But now it starts! :-)
Comment 17 Hendy Irawan 2011-09-02 00:39:30 UTC
(In reply to comment #16)
> (In reply to comment #14)
> 
> > And not 5 minutes after posting this:
> > %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml
> > 
> > 
> > DELETE THAT FILE. LibreOffice will re-create it on the next launch, and
> > LibreOffice will launch successfully.
> 
> @ Joe T. : You're a GOD !
> 
> After deleting that will, LibreOffice starts up and displays the following
> message : (7 times)
> 
> - JRE is Defective
> 
> LibreOffice requires a Java runtime environment (JRE) to perform this task. The
> selected JRE is defective. Please select another version or install a new JRE
> and select it under Tools - Options - LibreOffice - Java.
> 
> I'm using Windows 7 SP 1 64-bit Home Premium + Oracle JDK 64-bit.
> 
> But now it starts! :-)

Note: Problem still happens as of LibreOffice 3.4.3 (without the workaround above).
Comment 18 digital ant 2011-09-06 14:11:56 UTC
3.4.3 English install on Windows XP sp3 (32bit) with JRE 6u26 opens all applications with no issues. I did removed my App Data\LibO profile before installation.
Comment 19 mlc 2011-09-09 01:35:11 UTC
I confirm that, in my XPpro 32bit SP3 italian install, LO 3.4.3 crashed until I deleted the %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml.
After the deletion, LO started and stopped many times saying that JRE is needed, but I have a JRE 7.0 version installed on my pc.
After this messages, LO started normally and in all new launches starts correctly without any error message.
Comment 20 Boris Unckel 2011-10-02 02:10:32 UTC
I confirm that, in my Win 7 64bit SP1 German install, LO 3.4.3 crashed until I
deleted the %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml.
After the deletion, LO started and stopped many times saying that JRE is
needed, but I have a JRE 7.0 version installed on my pc.
After this messages, LO started normally and in all new launches starts
correctly without any error message.

LibreOffice 3.4.3 
OOO340m1 (Build:302)

Both 32bit and 64bit installed
c:\Program Files\Java\jre7\bin>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

c:\Program Files (x86)\Java\jre7\bin>java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)
Comment 21 Scott M. Sanders 2011-11-09 08:02:26 UTC
I am now getting this exact issue in 3.4.4. It did not occur for me in 3.4.3.
Comment 22 Scott M. Sanders 2011-11-09 08:09:16 UTC
Removing javasettings_Windows_x86.xml still works. :)
Comment 23 Scott M. Sanders 2011-11-25 13:54:04 UTC
One kinda big drawback though -- Java 7 and LibO do not mix:

https://bugs.freedesktop.org/show_bug.cgi?id=39659

So things that depend on it, like the LanguageTool extension, do not work.
Comment 24 Scott M. Sanders 2011-12-14 09:56:08 UTC
It is an issue with 3.5.0 beta0 too.
Comment 25 Björn Michaelsen 2011-12-23 12:01:24 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 26 Björn Michaelsen 2011-12-23 16:59:59 UTC
needinfo keyword redundant by needinfo status.
Comment 27 Rainer Bielefeld Retired 2012-01-19 22:30:42 UTC
*** Bug 44747 has been marked as a duplicate of this bug. ***
Comment 28 narayanaras 2012-01-19 23:28:38 UTC
I faced this issue with two different PCs, one running Windows XP, SP-3 and the other running Win 7. The crash happened regardless of JRE (no java, JRE 6u30, JRE 7u2)

But the Libo 3.4.5 starts fine. However, I am assuming no one has yet consciously changed the code to avoid the crash. Therefore it is safe to assume that in future, Libo may start crashing again.

A comparison of the code between 3.4.4 and 3.4.5 could provide a clue.
Comment 29 Cor Nouws 2012-01-22 12:08:39 UTC
pls don't change the version number. indicates the version against which it initially is reported.
I see what happened up to comment #20 as a useful attempt to find out what happened.
Comment 30 Cor Nouws 2012-01-22 12:11:46 UTC
(In reply to comment #28)

> A comparison of the code between 3.4.4 and 3.4.5 could provide a clue.
In which if the million lines you would suggest start searching ;-)

anyone on Linux having the issue? If so, pls try to get a backtrace or strage log
  http://wiki.documentfoundation.org/BugReport
(maybe it's possible to on windows ...?
Thanks
Comment 31 threexk 2012-01-24 02:47:29 UTC
First occurred for me after installing 3.4.5.  Crashed on loading Hungarian files.  Deleting %APPDATA%\LibreOffice\3\user\config\javasettings_Windows_x86.xml caused errors on the subsequent start-up, but on LibreOffice program launches thereafter there were no errors.  Using JRE 7 Update 2.
Comment 32 Urmas 2012-07-21 10:50:05 UTC

*** This bug has been marked as a duplicate of bug 38913 ***