Bug 37964 - Formula's copies become no italic after editing.
Summary: Formula's copies become no italic after editing.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: PowerPC Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 16:46 UTC by Víctor Hugo Suárez Candal
Modified: 2018-02-26 11:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing how the formulas look after step 13 in my comment #10 (47.71 KB, image/png)
2012-08-19 07:40 UTC, Roman Eisele
Details
Screenshot after step 12 in the conflicting environment related to comment #12 (37.91 KB, image/png)
2012-08-19 21:11 UTC, Víctor Hugo Suárez Candal
Details
Screenshot after step 13 in the conflicting environment related to comment #12 (53.75 KB, image/png)
2012-08-19 21:13 UTC, Víctor Hugo Suárez Candal
Details
File saved after following all 13 steps suggested in comment #10 (13.74 KB, application/vnd.oasis.opendocument.text)
2012-08-19 21:19 UTC, Víctor Hugo Suárez Candal
Details
registrymodifications.xcu from a clean User Profile in answer to comment #17 (deleted)
2012-08-24 14:22 UTC, Víctor Hugo Suárez Candal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Víctor Hugo Suárez Candal 2011-06-05 16:46:22 UTC
LibreOffice 3.4.0 
OOO340m1 (Build:12)

Platform: Mac OS X 10.4.11
Processor: PPC G4 1.5GHz 
RAM: 1,25GHz

Steps to reproduce:
1. Insert a formula (for example, f(x)). It should be italic.
2. Try to edit that formula. You should see it is working as expected
3. Copy&paste the formula.
4. Try to edit the new copy. The formula should stop being italic.
Comment 1 Björn Michaelsen 2011-12-23 12:07:10 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:00:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:01:32 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:06:15 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:08:17 UTC Comment hidden (obsolete)
Comment 6 Víctor Hugo Suárez Candal 2012-08-14 15:25:54 UTC
The bug is still present in 3.6.0.4 (build id: 932b512)
Comment 7 Florian Reisinger 2012-08-15 17:24:55 UTC
I need a tester with Mac OS to confirm that...
Comment 8 Roman Eisele 2012-08-17 15:00:16 UTC
(In reply to comment #6)
> The bug is still present in 3.6.0.4 (build id: 932b512)

(In reply to comment #7)
> I need a tester with Mac OS to confirm that...


Hello Víctor Hugo Suárez Candal,

I have tried to reproduce this bug on MacOS X in order to confirm it, but I have got a little problem to follow your description exactly. In step 3, you say "Copy&paste the formula." How do you copy the formula (pressing command + C?), and how and where do you paste it -- into the same formula editor window (and if so, then: just after the present formula, or on a new line?), into a new formula editor window, or ... somewhere else?

I know that this seems a very very stupid question, but obviously the exact way of copy and paste makes a difference -- on my first attempts, I could NOT reproduce the issue with LibO 3.6.0.4, probably due to some misunderstanding regarding the copy and paste ...

Thank you very much in advance for your answer!
Comment 9 Florian Reisinger 2012-08-18 19:24:43 UTC
Hi!

You should insert a formula in a document IA writer
Comment 10 Roman Eisele 2012-08-19 07:37:34 UTC
(In reply to comment #9)
> You should insert a formula in a document IA writer

OK, so I have tried it again with LibreOffice 3.5.6.2 (Build ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0) and with LibreOffice 3.6.1.1 (Build ID: 4db6344), both on MacOS X 10.6.8 (Intel).

My steps:
 1) Start LibreOffice
 2) Create a new Writer document
 3) Type "Text A"
 4) Choose "Insert > Object > Formula"
 5) Type "f(x)"
 6) Click after the formula; the formula is italic (correct)
 7) Double-click the formula and change it, e.g. to "y = f(x)"
 8) Click after the formula; the formula is italic (correct)
 9) Type "Text B"
10) Click on the formula and press Command + C
11) Click after "Text B" and press Command + V, to get a copy of the formula
12) Double-click the formula and edit it, e.g. to "y = x^2 + 2 x + 1"
13) Click after the formula; the formula is still italic (correct)

So I can’t confirm this issue, sorry; for me, everything works as expected. (Of course, only the variables are italic, like 'x' and 'y', but this is correct; constants like the numbers (figures: '1', '2', etc.) and operators ('+', '=' etc.) and functions ('sin' 'cos' 'tan') should never be italic.)


@ Víctor Hugo Suárez Candal:

I really like to help you via confirming this issue, but as said above I can’t. Can you please try to explain if you do something different; i.e., where is the difference between my steps listed above and what you do until the formula is no more italic?

Thank you very much again!
Comment 11 Roman Eisele 2012-08-19 07:40:06 UTC
Created attachment 65761 [details]
Screenshot showing how the formulas look after step 13 in my comment #10


Screenshot showing how the formulas look after step 13 in my comment #10 -- everything is correct (the variables in both formulas are italic).
Comment 12 Víctor Hugo Suárez Candal 2012-08-19 21:06:39 UTC
First of all, sorry for the delay.

(In reply to comment #10)
> (In reply to comment #9)
> > You should insert a formula in a document IA writer
> 
> OK, so I have tried it again with LibreOffice 3.5.6.2 (Build ID:
> e0fbe70-dcba98b-297ab39-994e618-0f858f0) and with LibreOffice 3.6.1.1 (Build
> ID: 4db6344), both on MacOS X 10.6.8 (Intel).
> 
> My steps:
>  1) Start LibreOffice
>  2) Create a new Writer document
>  3) Type "Text A"
>  4) Choose "Insert > Object > Formula"
>  5) Type "f(x)"
>  6) Click after the formula; the formula is italic (correct)
>  7) Double-click the formula and change it, e.g. to "y = f(x)"
>  8) Click after the formula; the formula is italic (correct)
>  9) Type "Text B"
> 10) Click on the formula and press Command + C
> 11) Click after "Text B" and press Command + V, to get a copy of the formula
> 12) Double-click the formula and edit it, e.g. to "y = x^2 + 2 x + 1"
> 13) Click after the formula; the formula is still italic (correct)
> 
> So I can’t confirm this issue, sorry; for me, everything works as expected. (Of
> course, only the variables are italic, like 'x' and 'y', but this is correct;
> constants like the numbers (figures: '1', '2', etc.) and operators ('+', '='
> etc.) and functions ('sin' 'cos' 'tan') should never be italic.)
> 
> 
> @ Víctor Hugo Suárez Candal:
> 
> I really like to help you via confirming this issue, but as said above I can’t.
> Can you please try to explain if you do something different; i.e., where is the
> difference between my steps listed above and what you do until the formula is
> no more italic?
> 
> Thank you very much again!

I've repeated **exactly** your steps, and everything is ok until step 12, after which the formula loses italics.

My configuration differs from yours in this aspects:
  - I'm running LibreOffice 3.6.0.4 (Build ID 932b512), which I've downloaded from the LibreOffice homepage, and I've installed the spanish language pack. These are the md5sums of the dmg images I've downloaded:
    371ef734a6dc6e13569d3f703b8ec749  LibO_3.6.0_MacOS_PPC_install_en-US.dmg
    cb068c3f5b21be3751e62944335a98f3  LibO_3.6.0_MacOS_PPC_langpack_es.dmg
  - I'm running the PowerPC version of LibreOffice. Since it works ok in you Intel machine, that makes me think about an endianness-related issue.
  - I'm running LibreOffice on Mac OS 10.4.11, what is perhaps another possible source for this problem.

Since the formulas remain no italic after saving and opening the file again, there must be some difference between the original formula and its copy, so I went further and took a look inside the odt file, and this is what I got:

Contents of "Object 1/content.xml" (original formula)
<?xml version="1.0" encoding="UTF-8"?>
<math xmlns="http://www.w3.org/1998/Math/MathML"><semantics><mrow><mrow><mi>y</mi><mo stretchy="false">=</mo><mi>f</mi></mrow><mrow><mo stretchy="false">(</mo><mrow><mi>x</mi></mrow><mo stretchy="false">)</mo></mrow></mrow><annotation encoding="StarMath 5.0">y = f(x)</annotation></semantics></math>

Contents of "Object 2/content.xml" (copied formula)
<?xml version="1.0" encoding="UTF-8"?>
<math xmlns="http://www.w3.org/1998/Math/MathML"><semantics><mrow><mrow><mi mathvariant="normal">y</mi><mo stretchy="false">=</mo><mi mathvariant="normal">f</mi></mrow><mrow><mo stretchy="false">(</mo><mrow><mi mathvariant="normal">x</mi></mrow><mo stretchy="false">)</mo></mrow></mrow><annotation encoding="StarMath 5.0">y = f(x)</annotation></semantics></math>

You can see the mathvariant="normal" attribute in the second case, which isn't present in the first case.
Comment 13 Víctor Hugo Suárez Candal 2012-08-19 21:11:33 UTC
Created attachment 65810 [details]
Screenshot after step 12 in the conflicting environment related to comment #12

As you can see, after double-clicking, the formula loses italics
Comment 14 Víctor Hugo Suárez Candal 2012-08-19 21:13:44 UTC
Created attachment 65811 [details]
Screenshot after step 13 in the conflicting environment related to comment #12

After finishing editing the copy, the formula do not recover italics.
Comment 15 Víctor Hugo Suárez Candal 2012-08-19 21:19:40 UTC
Created attachment 65812 [details]
File saved after following all 13 steps suggested in comment #10

Unzip it and see what's wrong inside. Both objects differ despite being copies (as stated in comment #12), but perhaps there're more useful info inside this file.
Comment 16 Roman Eisele 2012-08-24 09:14:56 UTC
@ Víctor Hugo Suárez Candal:

Thank you very much for all your additional comments, and your analysis of the problem! Especially the hint to
   mathvariant="normal"
in comment #12 is very interesting.

However, we still need someone to confirm this issue (independently), and I am still not lucky in doing so -- maybe MacOS version, platform etc. have some influence on this issue, as you said in comment #12.

Waiting for some other MacOS user to confirm, I am still thinking about what else could explain the difference (you can reproduce the problem, I can’t). For today, one idea which we should try:

There is a chance that some special LibreOffice settings are involved in this issue. To try this, could you please search for your LibreOffice User Profile folder at
   ~/Library/Application Support/LibreOffice/3/user/
(~ is your user/home directory, somewhere at Mac OS X/Users/...)
and especially for the file
   registrymodifications.xcu
(it should be inside of the "LibreOffice/3/user" folder mentioned above),
and attach this file "registrymodifications.xcu" to the current bug report?

There is a chance that some special setting or corruption inside of "registrymodifications.xcu" influences the formula setting, therefore it is possible that we can reproduce the problem with the help of that file.

Thank you very much!
Comment 17 Roman Eisele 2012-08-24 10:32:42 UTC
Oh, and even simpler -- please try this _before_ attaching the file "registrymodifications.xcu" here (as suggested in my previous comment):

In the previous comment, I wrote about your User Profile folder at:
   ~/Library/Application Support/LibreOffice/3/user/
(~ is your user/home directory, somewhere at Mac OS X/Users/...)

Could you please try to
* quit LibreOffice
* rename the folder "user" at the place mentioned above to something else,
  e.g. to "user-old"
* re-start LibreOffice
* and try again the steps given in comment #10,
* and report here if the results are different in any way from your results
  mentioned in comment #12?

If there is any difference about italic/no italic in formulas, this would be a big progress ...

Thank you very much in advance!
Comment 18 Víctor Hugo Suárez Candal 2012-08-24 14:22:00 UTC
Created attachment 66066 [details]
registrymodifications.xcu from a clean User Profile in answer to comment #17

At this point, I'd like to add that I completely removed my old User Profile just after upgrading to 3.6.0.4 directly from 3.4.0 to get rid of some kind of corruption which didn't let LibreOffice fully start. However, the bug persisted.

Despite of that, I followed the steps you have suggested, and here you have the file you request, from a clean environment. Needless to say, the bug is still there.
Comment 19 Roman Eisele 2012-08-24 15:21:03 UTC
(In reply to comment #18)
> At this point, I'd like to add that I completely removed my old User Profile
> just after upgrading to 3.6.0.4 directly from 3.4.0 to get rid of some kind of
> corruption which didn't let LibreOffice fully start. However, the bug
> persisted.

Ah, sorry, I did not know that. Most users don’t remove their old User Profile, and while upgrading with an existing User Profile should work, it is known to cause some problems (cf. bug 43489).

> Despite of that, I followed the steps you have suggested, and here you have the
> file you request, from a clean environment. Needless to say, the bug is still
> there.

Yes, and I can confirm that I still can’t reproduce the bug even when I install your registrymodifications.xcu into my own User Profile folder. So registrymodifications.xcu seems to be innocent for this problem.

I am sorry for all the work this caused for you, without success. Well, it was worth trying.

I have to confess that I am at my wit’s end for now; we really need someone who tries to reproduce this on a PPC Mac with MacOS X 10.4, to test if processor/MacOS version is the reason for this problem.
Comment 20 Roman Eisele 2012-08-24 16:20:57 UTC
> My configuration differs from yours in this aspects:
>   - I'm running LibreOffice 3.6.0.4 (Build ID 932b512), which I've downloaded
> from the LibreOffice homepage, and I've installed the spanish language pack.

I have tried installing the Spanish language pack, and setting everything (UI language, document language, locale settings) to Spanish/Spain, but it does not make a difference (the formula is still italic after copy and edit). So really a PPC problem? Strange ...
Comment 21 Víctor Hugo Suárez Candal 2012-08-25 01:41:12 UTC
I've just tried LibreOffice 3.3.4 (OOO330m19 Build:401), and everything works as expected, so the bug was introduced somewhere between 3.3.4 and 3.4.0.

I'm really tempted to clone the git repo and start bisecting. However, I suspect my machine (1.5GHz PPC G4 w/ 1.25GiB of RAM) could have a really hard time by trying to build LibreOffice from source so many times, which discourages me from going that way.

Nevertheless, perhaps that would be a great way to warm my room in winter if no one could solve this issue before.
Comment 22 Joel Madero 2013-05-15 02:25:44 UTC
@Joren - another one for you to test hopefully. 

@Victor - bibisect is only Linux so OSX wouldn't work. Also it's prior to the earliest bibisect version :)

Thanks for all the input, hopefully we can get confirmation
Comment 23 Jorendc 2013-05-15 12:53:11 UTC
(In reply to comment #22)
> @Joren - another one for you to test hopefully. 

I have the same results as Roman (Comment 10). Can't reproduce this issue using Mac OSX 10.8.3 with LibreOffice 4.0.3.3.

Kind regards,
Joren
Comment 24 Joel Madero 2013-06-21 16:23:22 UTC
As it's been 10 months since original poster has added info I'm going to mark this as WORKSFORME just because we have several people who are saying it's working fine. 

@Victor - if you still see this problem with 4.0.4 please set bug back to UNCONFIRMED and let's try to get this one confirmed, else I'm going to assume that it's an environment factor or some steps are missing.

*Hopefully* with 4 you don't see the problem any more and then all is good :)
Comment 25 Xisco Faulí 2018-02-26 11:17:54 UTC
The content of attachment 66066 [details] has been deleted