Bug Hunting Session
Bug 43489 - [Task] Incorrect behavior using existing User Profile for upgrade
Summary: [Task] Incorrect behavior using existing User Profile for upgrade
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 43491 45298 46071 46155 46225 47052 50552 50603 50798 51323 51685 52022 52294 52395 53006 53246 53303 53337 53587 53652 53869 54374 55019 55486 55839 62155 64962 74332
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-03 10:45 UTC by Rainer Bielefeld Retired
Modified: 2016-01-27 07:54 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-03 10:45:38 UTC
This is the Meta issue to track Bugs concerning problems continuing use of the existing LibO 3 User Profile after the upgrade from 3.3 or 3.4 to 3.5

If anyone finds a Bug in 3.5 Master or 3.5 Beta / RC  where the suspect exists that problems are caused because the update still uses the existing user Profile, please add the Bug ID as
dependent Bug here to the Meta Bug in field "Depends on". Additionally please
leave a comment here containing the bug Subject line.

Example for WIN:
Existing User Profile: C:\Users\user\AppData\Roaming\LibreOffice\3\
(Modified) User Profile referece in C:\<LibO_Installation\program\bootstrap.ini:
 UserInstallation=$SYSUSERCONFIG/Libreoffice/3

Please backup your User Profile before a test and also mention hints on <https://wiki.documentfoundation.org/Installing_in_parallel>
Comment 1 Rainer Bielefeld Retired 2011-12-03 11:07:59 UTC
Bug 43491 - CONFIGURATION: Using existing User Profile existing WRITER documents open "semi read only"
Comment 2 Rainer Bielefeld Retired 2012-03-01 05:17:20 UTC
Bug 45298 - VIEWING Picture linked from WEB impossible, only placeholder shown.
Bug 46225 - Update on 3.4.3 - defect user profile
Comment 3 Julien Nabet 2012-05-16 16:21:55 UTC
Bug 46071 - EDITING: Math formula editor frezees after upgrading to 3.5 - PLEASE HELP
Comment 4 Roman Eisele 2012-05-26 06:53:06 UTC
(IMHO Status field should be set to 'NEW', just like in other Meta issues ...)
Comment 5 Rainer Bielefeld Retired 2012-05-30 01:10:32 UTC
Add "Bug 46155 - Errors using templates with an vanilla 3.4 profile in 3.5 "
Comment 6 Rainer Bielefeld Retired 2012-06-03 13:29:04 UTC
Add "Bug 50552 - SPELL check does not mark wrong text and capitalization rules" (what might be a DUP) for now
Comment 7 Rainer Bielefeld Retired 2012-06-10 03:58:59 UTC
Add: "Bug 45360 - FILESAVE: Saving and loading a presentation results in formatting changes" due to workaround results
Comment 8 Roman Eisele 2012-06-13 01:37:49 UTC
Add bug 50603 - "Unable to update LibreOffice without resetting user profile"
Comment 9 Julien Nabet 2012-06-14 15:01:51 UTC
*** Bug 50798 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2012-06-21 15:26:57 UTC
Rainer: should fdo#46155 be a dup of this tracker or should  this tracker depend on fdo#46155 ? (or both !?)
I searched in these links :
- http://wiki.documentfoundation.org/BugReport
- http://wiki.documentfoundation.org/BugReport_Details
- https://wiki.documentfoundation.org/QA-FAQ#How_to_assign_a_bug_.28QA_team_only.29
even the thread http://nabble.documentfoundation.org/Cleaning-bug-list-tp3988836.html
Perhaps I missed it.
Comment 11 Roman Eisele 2012-07-07 23:07:45 UTC
Added bug 51323 - "Constant crashes on MacOS X 10.7".
Comment 12 Julien Nabet 2012-07-11 09:30:49 UTC
*** Bug 51323 has been marked as a duplicate of this bug. ***
Comment 13 Julien Nabet 2012-07-24 11:10:30 UTC
*** Bug 52294 has been marked as a duplicate of this bug. ***
Comment 14 Roman Eisele 2012-07-26 15:03:03 UTC
Added Bug 52395 - "UI: Can not open the "Styles and Formatting" window after upgrade with existing User Profile"
Comment 15 Rainer Bielefeld Retired 2012-07-31 16:56:13 UTC
Add "Bug 53006 - Autocorrection TWo INitial CApitals does not work because of bundled extensions problem"
Comment 16 Rainer Bielefeld Retired 2012-08-09 14:32:43 UTC
@Stephan: Might be interesting for your work
Comment 17 Julien Nabet 2012-08-10 06:45:13 UTC
*** Bug 53266 has been marked as a duplicate of this bug. ***
Comment 18 Roman Eisele 2012-08-11 16:15:29 UTC
Moved bug 53303 from "Blocks" to "Depends on" -- this is the way it should be, isn’t it?
Comment 19 Rainer Bielefeld Retired 2012-08-12 07:31:05 UTC
Add "Bug 43491 - CONFIGURATION: Using existing User Profile after update existing WRITER documents VIEWING settings are modified", I am pretty sure that that one is related.
Comment 20 Rainer Bielefeld Retired 2012-08-12 15:34:45 UTC
I am pretty sure that "Bug 52022 - CONFIGURATION: 'My Macros' lost after update from 3.5.5.3" also is correct here, although some of the circumstances are not so typical.
Comment 21 Rainer Bielefeld Retired 2012-08-12 17:40:47 UTC
Add "Bug 51323 - Constant crashes on MacOS X 10.7 after using existing User Profile folder for upgrade". A user profile is available there as attachment.
Comment 22 Roman Eisele 2012-08-16 09:09:29 UTC
Supplement: Julien Nabet has added bug 53288: "Unable to use spellchecking as a regular user on Windows 7 and Windows 2008R2".
Comment 23 Rainer Bielefeld Retired 2012-08-16 11:51:13 UTC
Add "Bug 53587 - UI: default measure unit after update "cm" instead of "mm""
Comment 24 Roman Eisele 2012-08-16 15:06:37 UTC
Added all bugs marked as duplicates of this bug to the "Depends on" field; cf.
  https://bugs.freedesktop.org/show_bug.cgi?id=51323#c13
Comment 25 Michael Meeks 2012-08-20 10:47:32 UTC
repair help crasher on upgrade linkage to duplicate bug#53337
Comment 26 Roman Eisele 2012-08-21 17:13:45 UTC
Added bug 53869 - "CRASH on startup". Reported for MacOS X 10.6.8 (Intel). Immediate crash on startup of LibreOffice 3.6.0.4 after upgrade from 3.5.5. Renaming the user profile solved the issue.

Important: the faulty user profile is attached to the bug report, therefore this report may be especially helpful for further investigation.
Comment 27 Roman Eisele 2012-09-09 07:19:11 UTC
Supplement:
Julien Nabet has added Bug 54374 - "Crash when sliding the File-menu down".
Comment 28 Rainer Bielefeld Retired 2012-09-10 08:55:30 UTC
Current knowledge seems to say that "Bug 54621 - EDITING: CRASH in .ods documents with lots of (conditional) formatting" is related to this one
Comment 29 Korrawit Pruegsanusak 2012-10-17 11:23:33 UTC
Adding bug 55839. This bug occurred after upgrading from 3.5.6 to 3.6.2, causing all applications to crash when do File > Print or Ctrl + P. Crashing user profile could be downloaded from the bug.
Comment 30 tommy27 2013-08-11 17:12:17 UTC
hi there. is anybody experiencing upgrade issue from 3.6.x to 4.0.x ?
Comment 31 tschloesser 2013-08-11 17:17:46 UTC
Sehr geehrte Damen und Herren,

Vielen Dank für Ihre Nachricht. Ich werde bis einschließlich 01.09.2013 nicht im Büro anwesend sein. Ab dem 02.09.2013 bin ich ab 08.30 Uhr wieder für Sie zu erreichen. In der Zwischenzeit zögern Sie bitte nicht, unsere Zentrale unter +49 (0)6051 – 8326-0 zu kontaktieren. Die zuständigen Kollegen werden Sie an die entsprechend richtige Stelle weitervermitteln.

Alle projektbezogenen NetIQ IDM Anfragen können Sie während dieser Zeit auch an Herrn Uwe Krause richten. Bitte nehmen Sie mich in diesem Fall bitte ins cc. 

Außerdem werde ich Ihre Email natürlich schnellstmöglich nach meiner Rückkehr beantworten. Ich bedanke mich und verbleibe

mit freundlichen Grüßen,



---------------------------------------------------------------------------------------------------------------------------------------------------------------------------



Dear Sir or Madam,

thank you very much for your Email. I'll be absent until the September, 1st 2013 (including) and I'll return on September, 2nd 2013  at 08.30 hrs. 
For urgent matters, please do not hesitate to contact our central phone number +49 (0)6051 – 8326-0. The responsible colleagues will be pleased to connect you with an appropriate person.

Of course I'll respond to your Email as soon as possible upon my return.

Thank you very much and best regards,
Comment 32 Julien Nabet 2013-08-11 19:13:59 UTC
tschloesser: could you translate your message in English?
Comment 33 retired 2013-08-12 06:19:37 UTC
Julian, tschloessers msg is just an auto-reply because he on vacation.

Can anybody elaborate on tommy27's question if they have issues updating from LO 3.6 to 4.x
Comment 34 retired 2013-08-12 06:28:24 UTC
Is it even worth keeping this meta ticket for 3 bugs which we are not sure if they still happen on 4.0?

Imo close this meta tickets and look into the three remaining bugs and be done.

If you agree please proceed accordingly.
Comment 35 tommy27 2013-08-12 07:56:23 UTC
@James
I agree. removed mab3.6 block.
let's focus on the remaining 3 open bugs.
Comment 36 V Stuart Foote 2016-01-27 07:54:06 UTC
Should have been closed. No reason to remain open.