Bug 45360 - FILESAVE: Saving and loading a presentation results in formatting changes
Summary: FILESAVE: Saving and loading a presentation results in formatting changes
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Slide-Layout
  Show dependency treegraph
 
Reported: 2012-01-29 01:00 UTC by Cluracan
Modified: 2017-06-13 11:46 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example odp file, with 2 pdfs: one exported RIGHT AFTER THE SAVE, and one exported RIGHT AFTER RELOAD (226.40 KB, image/zipped pdf)
2012-01-29 08:57 UTC, Cluracan
Details
the "bad" user file + examples (482.82 KB, application/x-zip)
2012-10-03 21:12 UTC, Cluracan
Details
Before (bug 45360) (184.44 KB, image/png)
2013-02-26 02:42 UTC, Adam Smith
Details
After (bug 45360) (200.69 KB, image/png)
2013-02-26 02:43 UTC, Adam Smith
Details
Diff on config directories (10.74 KB, text/plain)
2013-07-17 09:11 UTC, Robert Sharp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cluracan 2012-01-29 01:00:13 UTC
Problem description: 
When I create a presentation, and specifically one from the "slide designs", add content, save it, close impress and then reopen the file - the formatting (font, bullet shape) of the slides change.

Specifically, the sub item formatting in the list ("title, content" layout) changes.

Steps to reproduce:
1. open impress, "next" on empty presentation
2. choose "noise paper" presentation background and "create"
3. add a "title, content" type slide
4. add some items and sub-items (with "tab")
5. notice font and bullet shape of sub-items (bullet is a brown dash)
6. save, close impress
7. reopen impress, open file.
8. notice sub-item formatting (bullet now black dot, font changed)

I have attached a sample file, with 2 pdfs: one exported RIGHT AFTER THE SAVE, and one exported RIGHT AFTER RELOAD. Notice differences in slide 2 sub-items

Current behavior:
the reopened presentation is different than the saved one

Expected behavior:
the reopened presentation is the identical to the saved one

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 Cluracan 2012-01-29 08:57:26 UTC
Created attachment 56294 [details]
Example odp file, with 2 pdfs: one exported RIGHT AFTER THE SAVE, and one exported RIGHT AFTER RELOAD

2 PDFs showcasing the bug, created as in bug description
testing123_before_exit.pdf: exported RIGHT AFTER THE SAVE;
testing123_after_reopen.pdf: exported RIGHT AFTER RELOAD

Notice the differences in slide 2 (sub-list bullet shape + font)
Comment 2 sasha.libreoffice 2012-03-23 03:36:09 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 3 Cluracan 2012-03-23 15:43:14 UTC
I just downloaded and checked on libreoffice 3.5.1

The bug is still reproducible exactly as described: the second level item font (and bullet color) changes after quitting and reloading.

Note that this only happens when I create an "empty presentation" with a "slide design" using the new presentation wizard.
Comment 4 sasha.libreoffice 2012-03-24 00:51:20 UTC
Thanks for additional testing
Sorry, I can not reproduce this problem in 3.5.1 on Fedora 64 bit
Please, move LibreOffice user profile to another place and try again
Comment 5 Cluracan 2012-03-24 16:52:12 UTC
Thanks, moving the user profile fixed it.

This thing has been driving me crazy for more than a month... bah :)
Comment 6 Rainer Bielefeld Retired 2012-06-10 03:56:31 UTC
This is not fixed
Comment 7 bfoman (inactive) 2012-07-13 10:14:14 UTC
Checked with:
LO 3.5.5.3 
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Could not reproduce.
Comment 8 Joel Madero 2012-10-03 19:10:15 UTC
@Rainer -- how isn't it fixed, seems like it was a user config issue. Only way it's still a problem is if we can actually get our hands on the config folder so we can diagnose what went wrong.

@Cluracan -- do you still happen to have your backed up user folder that shows the problem? If so can you zip it and submit it here so one of our devs can check it out to see if it's an issue we can add a check for?

Marking as WORKSFORME based on Cluracan's comment and bfoman's comment, please reopen as UNCONFIRMED if it's still a problem and/or if you can provide that zipped user configuration so we can take a look at it
Comment 9 Cluracan 2012-10-03 21:12:11 UTC
Created attachment 68057 [details]
the "bad" user file + examples

@Joel Madero

I do have the old user directory! I have attached it with a new reproduction of the bug. 

This time I've reproduced it on lobreoffice 3.5.4.2 - the bug changed slightly: now the dash doesn't change shape (but still changes color, and the font still changes as well)

There is a README file in the zip describing the bug and the latest reproduction, as well as the two pdf files (before saving and after realoading) and of cource the "bad" user directory.

The odp file wasn't added as it is more than 4MB in size - which is more than the 3MB limit here

Cheers!
Comment 10 Adam Smith 2013-02-26 02:42:48 UTC
Created attachment 75541 [details]
Before (bug 45360)

Before exiting and reloading, showing the text area where I set it.
Comment 11 Adam Smith 2013-02-26 02:43:23 UTC
Created attachment 75542 [details]
After (bug 45360)

After reload, showing the text area back to the default size.
Comment 12 Adam Smith 2013-02-26 02:45:53 UTC
(Sorry for the multiple posts--I had trouble figuring out the UI.)

I think this bug may be very similar to one I'm struggling with. I changed the size of the default text area in Impress (3.5.4.2 Build ID: 350m1(Build:2)), but whenever I reopen the file, I find that it's discarded my changes and reset everything back to the default values. The images I uploaded show the before and after of this.
Comment 13 sasha.libreoffice 2013-02-26 05:47:32 UTC
Thanks for additional information
May be it is different bug. In last comment is about master slide.
It resembles bugs:
Bug 34987 - Impress disregards Master Slide settings saving to .odp
Bug 57152 - EDITING: Master page is not storing
Comment 14 tommy27 2013-07-16 19:57:57 UTC
@Cluracan
do you still experience that bug with any version of the 4.x branch?
Comment 15 Cluracan 2013-07-17 05:50:20 UTC
I don't know. Haven't installed the 4.x libreoffice.

But since the bug depended on my config folder (which I attached in a
previous post), and doesn't happen with the "default" (clean) folder, it
seems that the workaround of removing the folder is good enough.

Cheers
  Cluracan


On Tue, Jul 16, 2013 at 10:57 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  tommy27 <barta@quipo.it> changed bug 45360<https://bugs.freedesktop.org/show_bug.cgi?id=45360>
>  What Removed Added  CC   barta@quipo.it
>
>  *Comment # 14 <https://bugs.freedesktop.org/show_bug.cgi?id=45360#c14>on bug
> 45360 <https://bugs.freedesktop.org/show_bug.cgi?id=45360> from tommy27<barta@quipo.it>
> *
>
> @Cluracan
> do you still experience that bug with any version of the 4.x branch?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>    - You are the assignee for the bug.
>    - You reported the bug.
>
>
Comment 16 Robert Sharp 2013-07-17 09:05:12 UTC
I have just started to suffer from this bug with 4.1.0.2 (and 4.1.0.1). If I create a new plain presentation, enter something in the first page, save it and reload the font changes from the default Arial to Times.

I have moved my config file (~/.config/libreoffice/4) and the problem goes away, but so do all my macros, custom toolbars etc, so that is no good to anyone.
Comment 17 Robert Sharp 2013-07-17 09:11:21 UTC
Created attachment 82533 [details]
Diff on config directories

I did a diff on the two config directories: 4.new works and 4.old has the bug. Hope this might help someone who better understands these things.
Comment 18 retired 2013-07-17 09:52:48 UTC
Interesting bug.

Can confirm comment 16: If I create a new plain presentation, enter something in the first page, save it and reload the font changes from the default Arial to Times.

LO 4.1.0.2.0, OS X 10.8.4.

Setting to NEW.
Comment 19 tommy27 2013-07-17 10:06:03 UTC
setting status to NEW since other users seems to reproduce that issue,

thanks Cluracan and Robert for the attached files... I think that will help the developers finding which file is causing that issue.
Comment 20 Robert Sharp 2013-07-18 13:42:48 UTC
I had a poke through the diff file but gave up. Resorting to brute force I copied the whole directory and started deleting things. Struck lucky on the first attempt - deleting: ~/.config/libreoffice/4/user/uno_packages seems to have done the trick. Looking inside the backup suggests, well it suggests nothing at all. Still need some expert help here.
Comment 21 Robert Sharp 2013-07-18 13:48:17 UTC
Sorry - I should have given it more time. Seems some of the changes are being kept but my basic test (new preso in Arial) still fails (comes back in Times).
Comment 22 retired 2013-08-12 06:24:37 UTC
removing 43489 as block. not sure how this would be related.
Comment 23 QA Administrators 2015-04-19 03:23:13 UTC Comment hidden (obsolete)
Comment 24 QA Administrators 2016-09-20 09:24:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920