Download it now!
Bug 43491 - CONFIGURATION: Using existing User Profile after update existing WRITER documents VIEWING settings are modified
Summary: CONFIGURATION: Using existing User Profile after update existing WRITER docum...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2011-12-03 10:58 UTC by Rainer Bielefeld Retired
Modified: 2018-02-26 11:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test kit (deleted)
2011-12-08 10:28 UTC, Rainer Bielefeld Retired
Details
Test Kit New (deleted)
2012-06-09 12:02 UTC, Rainer Bielefeld Retired
Details
Different Behavior (deleted)
2012-06-09 22:08 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-03 10:58:10 UTC
Steps how to reproduce with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35):
1. Do a Server installation of that build
2. Modify bootsrtap.ini so that Master will use Existing user profile, that
   IMHO should be the situation for an upgrade (Mention hints on 
   <https://wiki.documentfoundation.org/Installing_in_parallel>, Last line for
   WIN installation in bootsrtap.ini should be modified to 
   "UserInstallation=$SYSUSERCONFIG/Libreoffice/3"
3. close bootsrtap.ini
4. Start Libo Master with double click on soffice.exe
5. Open an existing WRITER  document with Table of contents and Variables
   Expected: TOC and variables should have black background as they have in 3.4
   Actual: Document looks like "read only", TOC and variables are white, 
           additionally margin marks and similar are not shown. But "(read only)
           hint in window heading does not exist.

TOC can be updated, texts can be edited, but paragraph and page formatting are greyed out in Menu 'Format'.

My suspect: that might be a problem for upgrades.
Comment 1 Rainer Bielefeld Retired 2011-12-08 10:21:36 UTC
Still [Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 485138f-e92bf75-4c1bcb5]" Win-x86@6 – 2011-12-06_21:37:02). 

Steps to reproduce:
0. Close all LibOs
1. Check User Profile folder. My Build created a new 
   "C:\Users\user\AppData\Roaming\LOdev\3" 
2. rename subfolder "3" to "3_bak"
3. Copy / Paste folder "3" from 3.4.4 user profile
4. Start Libo Master! Everything seems to work fine, but I see the 
   reported effect

My conclusion:
a) I do something forbidden, if yes this Bug should be closed with some hints. But on <http://wiki.documentfoundation.org/UserProfile> I can't see an explicit prohibition.
b) The situation is the same as the new 3.5.0 will find when it tries to use the
   existing User Profile from 3.4

If b) we might have a fatal bug causing update problems

But the problem does not appear when I create a fresh new profile with 3.4.4 and copy / Paste it to the profile folder of 3.5. 

Further investigations shows that it's something within "registrymodifications.xcu". I attach a "registrymodifications.zip", using registrymodifications.xcu.bak (after renameing, of course" everything works fine, using "registrymodifications.xcu" from my old 3.4.4 profile causes the problem. 

Simply copying that "registrymodifications.xcu" into user profile of an other 
master build reproduces the reported problem.
Comment 2 Rainer Bielefeld Retired 2011-12-08 10:28:36 UTC
Created attachment 54247 [details]
Test kit

Please see comment before how to use!
Comment 3 Rainer Bielefeld Retired 2011-12-08 10:56:52 UTC
@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Rainer Bielefeld Retired 2011-12-08 21:56:14 UTC
I had the opportunity to test with 2 other PC, Problem did not appear. So it might be a problem with that particular "registrymodifications.xcu", no longer "most annoying".
Comment 5 Rainer Bielefeld Retired 2011-12-21 22:36:46 UTC
I only se that with 1 particular Master + Profile configuration, nowhere else reproducible, so I close this one.
Comment 6 Rainer Bielefeld Retired 2012-06-09 12:01:28 UTC
I again see this problem using  "LibreOffice 3.5.4.2  German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) 
and
Server Installation of  "LibreOffice 3.6.0beta1  English UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit) 
alternating with the same old user profilel

Attached new test kit contains a text document
- Read only with registrymodifications_readonlyeffect.xcu
- Works fine with
  -- registrymodifications_worksfine_new.xcu from newly created user profile
  -- registrymodifications_lastwhatworkedfine.xcu from User Profile
     backup before I started 3.6.0 the first time
Comment 7 Rainer Bielefeld Retired 2012-06-09 12:02:14 UTC
Created attachment 62849 [details]
Test Kit New
Comment 8 Rainer Bielefeld Retired 2012-06-09 22:08:32 UTC
Created attachment 62852 [details]
Different Behavior

"Different Behavior" contains a registrymodifications.xcu with what (on MY PC) documents will open correctly with 3.4.5, but read only with Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit)
Comment 9 manj_k 2012-06-10 12:16:44 UTC
I have opened 'sample.odt' (Test Kit New) w/ LibO 3.6.0beta1, and my customized user profile.
Works largely as expected.

Questions:

(1) Your step 5.
"Document looks like "read only", TOC and variables are white"

That may depend on Tools > Options > Appearance > Custom Colors > Text Document
☐ / ☑ Index and table shadings (and selected colors).

(2) Your step 5.
"additionally margin marks and similar are not shown"

That may depend on menu View > Text boundaries.

(3)
"TOC can be updated, texts can be edited, but paragraph and page formatting are
greyed out in Menu 'Format'."

- That may depend on the cursor position 
(only in TOC: grayed out; because: '☑ Protected against manual changes').

BTW: Replacing my LibO 3.6.0beta1 user profile with a copy of my pretty customized LibO 3.5.4 user profile (upgrade simulation) caused loss of user settings (e.g.: Options...User Data[!], Appearance) / files (e.g.: autotext, basic) with a *first* (not verfied) test. But that might be another bug report.
Comment 10 Rainer Bielefeld Retired 2012-06-10 21:30:19 UTC
@manj_k:
So it is! 
 
My latest results are that the documents are again "pseudo write protected" using the affected registrymodifications.xcu, reasons are as you expect.

Details
-------
a) Index and table shadings: was unchecked
   Checking brings grey background back
b) View Text Boundaries: was unchecked
   Checking brings them back
c) My report might have been unclear, only "TOC can be updated" was TOC related,
   rest related to normal text on page. I am no 100% sure that I really
   moved caret out of toc before I checked, Caret in TOC shows the greyed out 
   menu Format icons, what would be quite normal.

So the Question remains why these settings are modified after update.
Comment 11 Rainer Bielefeld Retired 2012-08-12 07:27:43 UTC
I even saw this problem after an pseudo-update 

from

- Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit)

to

-Server Installation of  "LibreOffice 3.6.1.0+  English UI/ German Locale [Build-ID:  b0aac2a] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time 2012-08-11 00:16:39}

I still have the 3.6.0.4 server installation and added 3.6.1.0+, what uses the same user profile like 3.6.0.4

My observations:

Opening the same WRITER document with
- 3.6.0.4: Tools > Options > Appearance > Custom Colors > Text Document
  ☑ Index and table shadings 
- 3.6.1.0+: Tools > Options > Appearance > Custom Colors > Text Document
  ☐ Index and table shadings
Comment 12 retired 2013-08-12 06:21:23 UTC
The question is, is this still happening with the LO 4.x versions?
Comment 13 tommy27 2013-08-12 07:53:19 UTC
I change status to NEEDINFO.
we need to now if this issue is still present during 3.6.x to 4.0.x upgrade.
Comment 14 QA Administrators 2014-05-17 00:33:50 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 15 QA Administrators 2014-06-01 20:29:48 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2018-02-26 11:21:18 UTC
The content of attachment 62852 [details] has been deleted
Comment 17 Xisco Faulí 2018-02-26 11:21:23 UTC
The content of attachment 62849 [details] has been deleted
Comment 18 Xisco Faulí 2018-02-26 11:21:29 UTC
The content of attachment 54247 [details] has been deleted