Download it now!
Bug 45298 - VIEWING Picture linked from WEB impossible, only placeholder shown.
Summary: VIEWING Picture linked from WEB impossible, only placeholder shown.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-01-27 01:55 UTC by Rainer Bielefeld Retired
Modified: 2013-12-17 12:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with linked picture (9.21 KB, application/vnd.oasis.opendocument.text)
2012-01-27 01:55 UTC, Rainer Bielefeld Retired
Details
Document with linked pictures (31.62 KB, application/vnd.oasis.opendocument.text)
2013-03-18 15:59 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-01-27 01:55:29 UTC
Created attachment 56216 [details]
Sample document with linked picture

Steps to reproduce with "LibreOffice 3.5.0 RC2 German UI/Locale [Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258] on German WIN7 Home Premium (64bit):

1. Open attached "mysample.ods"
   Expected: picture 
             <http://www.libreoffice.org/assets/Shared/mimeiconsbanner.png> 
             shown
   Actual: only placeholder

The document has been created by "Copy Picture" from Seamonkey 2.6.1., what will copy a linked picture (FF only copies a bitmap).

Works fine with a.m. Version on WIN XP 32 Bit (Virtualbox) - 64bit problem or damaged installation? 

Also no problem with Server Installation of  "LibreOffice 3.5.0 Beta0  - WIN7 Home Premium (64bit) English UI [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]"
Comment 1 Rainer Bielefeld Retired 2012-01-27 03:07:28 UTC
Definitively related to User Profile in AppData. Deleting Default User Profile heals the problem. Restoring Default User Profile lets reappear the problem

Not only linked pictures are affected, also Lorem Ipsum Generator extension does not work with my default User Profile.

The versions mentioned in original report not showing the problem used separate user profiles.

WireShark does not show any Internet activity with Default User Profile, but it does with clean new Profile.

I will do further investigations, with low priority as long as no one else suffers from the problem
Comment 2 Rainer Bielefeld Retired 2012-01-27 04:19:11 UTC
Unexpectedly CALC (Insert) External Data is not affected, works fine!
Comment 3 Rainer Bielefeld Retired 2012-03-12 08:35:29 UTC
Second attahcment in "Bug 47052 - Recovery fails because no access to AppData Temp folder"  <https://bugs.freedesktop.org/attachment.cgi?id=58323> dontains an old, "somehow" damaged "registrymodifications.xcu" responsible for the bug here. Replacing the "registrymodifications.xcu" in a fresh new Profile by "registrymodifications_OldDefect.xcu" makes the problem reappear.
Comment 4 jfgfrangar 2012-05-07 10:43:18 UTC
My, Insert, pictures don`t work on Macbookpro with leopard, tree versions no one is working.
but it is correc for win. there are my pictures.
Comment 5 Rainer Bielefeld Retired 2012-06-18 21:16:15 UTC
No longer reproducible, also not for 3.5.0 RC2

The problem also vanished for "Bug 47931 - Intermittent problem loading images from web sites". Seems to be some progress in WWW ;-)
Comment 6 Timur 2013-03-18 15:59:50 UTC
Created attachment 76687 [details]
Document with linked pictures

I have problems with opening this document, because pictures are not shown, just links. Except the first picture, which is shown. 
Document was created by pasting the source from HTML mail (Gmail) to LibreOffice. Links in the pictures are fine.
Similar behavior is with Microsoft Office Starter, it also can't shown pictures when text is pasted.
I can't see why the pictures are not shown. It doesn't depend on whether the profile is old or brand new.