Download it now!
Bug 47052 - Recovery fails because no access to AppData Temp folder
Summary: Recovery fails because no access to AppData Temp folder
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery mab3.5 43489
  Show dependency treegraph
 
Reported: 2012-03-07 06:21 UTC by Rainer Bielefeld Retired
Modified: 2018-02-26 11:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (833.06 KB, image/png)
2012-03-07 06:21 UTC, Rainer Bielefeld Retired
Details
Registrymodifications from User Profile (deleted)
2012-03-12 08:32 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-03-07 06:21:37 UTC
Created attachment 58117 [details]
Screenshot

"LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) sometimes fails to recover documents after a crash with message
"C:\Users\user\AppData\Local\Temp\lua5okz.tmp\filename does not exist"

lua5okz.tmp
- might be different for each crash (I will check)
- did not exist after crash
Comment 1 Rainer Bielefeld Retired 2012-03-07 06:31:25 UTC
I reproduced the problem by Proceeding as per
"Bug 43869 - Paste special as RTF inserted at wrong position, undo stack damaged"
to get crash as reported in
"Bug 43882 - EDITING: CRASH when undo copy paste"

Only new spreadsheet and new Writer document open, crash appeared, recovery failed with similar message as in original report, but different folder name instead of "lua5okz"
Comment 2 Rainer Bielefeld Retired 2012-03-12 04:37:47 UTC
@Petr:
I tried due to you hint, result: Problem seems to be related to my (damaged?) User Profile, with a new one I still can reproduce "Bug 43882 - EDITING: CRASH when undo copy paste", but recovery works fine. After switch back to my old profile problem is back (I did only 1 test with fresh and old profile).
Comment 3 Michael Meeks 2012-03-12 05:33:30 UTC
sounds bad; is this a new regression ? is it possible you have rather low space on your disk - possibly something is going wrong there - either in the autosave, or in the recovery ? Thanks !
Comment 4 Rainer Bielefeld Retired 2012-03-12 06:03:06 UTC
I see this WONTFIX for now, I doubt that it's of common interest to do further research. With new Profile everything works fine. Althouth the problem started exactly with my RC1->RC2 update, I doubt that anydy else will have exactly this profile damage like me. We can reopen the Bug if someone else will see the same problem; I did a backup of my old profile if it seems useful to do further research.
Comment 5 Petr Mladek 2012-03-12 06:29:19 UTC
Just for record. I am unable to reproduce this with 3.5.1-rc2. I have tried it on both SLED11-SP1-x86_64 and Windows XP SP3. So, it will hopefully not affect other users.
Comment 6 Michael Meeks 2012-03-12 07:28:38 UTC
It'd be great to get the registrymodifications.xcu file from both the old and new settings directories, to see if we can compare them & see what's up there.

Thanks ! :-)
Comment 7 Rainer Bielefeld Retired 2012-03-12 08:32:38 UTC
Created attachment 58323 [details]
Registrymodifications from User Profile

Attachment contains "registrymodifications_NwqWorksfine.xcu" (works fine) and "registrymodifications_OldDefect.xcu" that might cause the problem here. The old .xcu definitively causes the problem in "Bug 45298 - VIEWING Picture linked from WEB impossible, only placeholder shown", replacing registrimodifications.xcu in my fresh new User Profile by the damaged old one makes the problem theree reappear: Lorem Ipsum extension will not work with that .xcu and picture from web will not be updated.
Comment 8 Xisco Faulí 2018-02-26 11:02:28 UTC
The content of attachment 58323 [details] has been deleted