Download it now!
Bug 51323 - Constant crashes on MacOS X 10.7 after using existing User Profile folder for upgrade
Summary: Constant crashes on MacOS X 10.7 after using existing User Profile folder for...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-06-21 23:30 UTC by tschloesser
Modified: 2013-03-26 17:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
profile folder (245.69 KB, application/zip)
2012-06-25 01:58 UTC, tschloesser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tschloesser 2012-06-21 23:30:30 UTC
Dear Dev Team,

since I have upgraded LibreOffice to:
LibreOffice 3.5.4.2 
Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18

I expirience constant crashes especially using impress.
Sometimes the application crashes while editing a slide, sometimes is dies simply running in the back. 

The version before was much more stable,

I am using Libre Office on MacOS 10.7

Let me know if I can run some tests for you or please tell me how to produce debug information.

I hope the next release will be more stable, again and available soon.

Thanks,

Thorsten
Comment 1 Rainer Bielefeld Retired 2012-06-21 23:57:08 UTC
@Roman:
Can you help?
Comment 2 Roman Eisele 2012-06-22 10:06:29 UTC
@ Thorsten:
Thank you very much for your bug report!

I'm very sorry that LibreOffice 3.5.4 causes so much pain to you. It's a pity but it is not easy to help, because the situation is difficult: on many MacOS computers, LibreOffice 3.5.4 runs fine (e.g. on my own ;-), so we have to find out what makes the difference -- why does it crash for you so often (and not, e.g., for me).

To find out about the difference I have some questions for you. It would be very helpful if you could answer to them.

1) The first question is near to completely answered: you use LibreOffice on MacOS X 10.7 (I use MacOS X 10.6.8, and this may make a difference -- we will see). Which user interface languages do you use for MacOS and LibreOffice -- I suppose, German in both cases?

2) You say that you experience constant crashes "since I have upgraded LibreOffice" to version 3.5.4. This seems to indicate that you have used LibreOffice before without crashes, and is very interesting for us. Which version did you use before you upgraded to LibreOffice 3.5.4? Did it run without crashes (at least, without so many crahes) at the same tasks which cause a crash now?

3) An important point: Do you have any accessibility utilities enabled? This is to say, have you enabled any of the options in the section "Universal Access" (German "Bedienungshilfen" of the MacOS X System Prefererences? E.g., "VoiceOver" or "Zoom" or "Zugriff für Hilfsgeräte aktivieren"? Or do you have installed any other special utilities like a screenreader for people with visual impairment (Sehbehinderung), or some window management application like "Moom", or anything similar? This point is important because many accessibility utilities are known to cause crashes with LibreOffice ...

4) Do you have any special extensions for LibreOffice installed? If you are not sure, please select "Tools > Extensions Manager ..." (in German: "Extras > Extensions Manager ..." from the menu bar in LibreOffice 3.5.4. In the window which appears now please UNcheck (deselect) the checkbox "Installation" at the bottom, but make sure that both "Shared" ("Gemeinsam") and "User" ("Nutzer") are checked. Is the list above the checkboxes now empty (then there are no special extensions installed), or does it contain some entries? If the latter, please report all extensions which are listed there now.

5) Does Impress crash even when you create a new (empty) presentation and just begin to edit it? Or does it crash (more often) with existing presentations which contain quite some text and images?

6) Could you please attach any Impress file (presentation) which causes crashes to you to this bug report, and describe some typical actions with this file that often cause crashes to you? Then I can try to play around with the file and see if I find something special about it which may explain the crashes (this is not very probable, I know, but at least there is a chance).

7) It may be also helpful if you could attach some MacOS log files created on the crashes to this bug report. I don't know if Apple has changed this in MacOS X 10.7, but with MacOS X 10.6 this is simple:

* When LibreOffice (or any other application) crashes, MacOS will present to you a dialog window saying something like "LibreOffice wurde unerwartet beended." Either this dialog window already contains a big text field labelled "Problemdetails und Systemkonfiguration", or you may have to click on "Details einblenden" first to show this text field.

* Just click in this large text field, press Command+A to select all the text, then press Command+C to copy it.

* Then please switch to any text editor (like Apple's TextEdit), create a new empty text file and insert the complete copied text via pressing Command+V.

* Now please save the new text file under a new name.

* Then come back to this bug report at
https://bugs.freedesktop.org/show_bug.cgi?id=51323
and click on "Add an attachment". Select your new text file to attach it. In the comments field, please describe in short words what you did (or wanted do do) when this crash occured.

You may repeat this for some times, e.g. attach two or three or ... files of this kind to this bug report, which were created on crashes under different circumstances, i.e. when you did different things. Comparing the log files may allow us to infer if LibreOffice always crashes for the same reason(s) or if there seem to be different bugs involved here.


I know answering this questions and following these instructions will be laborious for you, but it may help us to track down the problem and to solve it. If anything is unclear, feel free to ask here again -- or contact me directly via an e-mail to bugs@eikota.de, especially if you prefer to talk about the issue in German -- this may make it easier for both of us ;-). Thank you very much in advance for your help!
Comment 3 Julien Nabet 2012-06-22 10:57:01 UTC
As I asked for most of bugs referring a crash, could you also first try to reproduce with a brand new LO profile ? (see http://wiki.documentfoundation.org/UserProfile)
A lot of bugs were due to the profile. A meta bug exists about profile problems fdo#43489 (NB : this one doesn't include crash but anyway...)
Comment 4 Roman Eisele 2012-06-25 01:10:58 UTC
(In reply to comment #3)
> As I asked for most of bugs referring a crash, could you also first try to
> reproduce with a brand new LO profile ? (see
> http://wiki.documentfoundation.org/UserProfile)

Yes, Julien is right -- in enumerating all these possible steps (comment #2) I completely forgot this one, which is probably the most important idea. Sorry for that! So, please try this first -- thank you very much! (And thank you, Julien, too!)
Comment 5 tschloesser 2012-06-25 01:23:05 UTC
Hi all,

I did reset the user profile and now LibreOffice seams to rum much better.
I do not had the time now to test everything, but I promise to to so today and tomorrow.

If I do not post anything here consider the problem solved ;-)

Thanks,

Thorsten
Comment 6 Julien Nabet 2012-06-25 01:45:24 UTC
Roman: no problem :-) (I see so often problems linked to profile)

Thorsten: it could be useful you zip your buggy LO profile and attach to this bugtracker.
Then I'll link to fdo#43489
Comment 7 tschloesser 2012-06-25 01:58:06 UTC
Created attachment 63425 [details]
profile folder
Comment 8 Roman Eisele 2012-07-07 23:06:36 UTC
(In reply to comment #6)
> Then I'll link to fdo#43489

Done.
Comment 9 Roman Eisele 2012-07-11 09:03:04 UTC
Changed Status to "NEW", because even if the bug is solved for the original reporter (see comment #5) by our workaround (a new user profile), this workaround is still a workaround and no fix. Also this report is of some importance for the handling of our meta-bug 43489, because this present bug report has got the attachment of the problematic profile folder. So don't close this one, but leave it as "NEW", linked to the meta bug.

Also adapted the summary to reflect our increased knowledge (and to make it easier to find this bug when searching for User Profile-related problems).
Comment 10 Julien Nabet 2012-07-11 09:30:49 UTC
Since there's a task about this, I put it as a dup.

*** This bug has been marked as a duplicate of bug 43489 ***
Comment 11 Roman Eisele 2012-07-11 09:44:29 UTC
(In reply to comment #10)
> Since there's a task about this, I put it as a dup.

I agree, but I'm not sure if this is the correct way to proceed. Should we
(a) mark bug reports of this kind as a duplicate of the task bug report,
or should we 
(b) just add them to the "Depends on" list of the task bug report?

Julien, you have asked the same question in some other, very similar bug report. Did you get/find an answer?

I just want to get a consensus about this question to ensure that we all handle such bugs in a consistent way. At the moment we use a mix of both ways ...
Comment 12 Julien Nabet 2012-07-11 10:05:51 UTC
Roman: you're entirely right, we must be coherent and I'm not sure now :-(
Rainer: Any idea ? Perhaps you had already answered about this but I don't remember right now.
Comment 13 Rainer Bielefeld Retired 2012-08-12 17:39:49 UTC
A real Bug can't be a DUP of a TASK bug, because there will no be any bugfix for the task bugs, that's the proceeding we do. At least this one is not not a DUP of Bug 43489, so I reopen it to show that currently there is no fix.

@tschloesser@maintainet.de 
The attachment " profile folder" contains the profile causing the crashes?
Comment 14 Julien Nabet 2013-01-19 14:42:23 UTC
Roman/tschloesser: do you reproduce the problem with the buggy profile folder attached and last LO version (3.6.4)?
Comment 15 Michael Meeks 2013-03-26 17:25:51 UTC
It's good to have this profile archived here; looking at it quickly - I see only bundled extensions - so nothing much exotic there. A bibliography database ( but that won't affect impress ), and quite a large registrymodifications.xcu

That has a number of templates listed in it - really quite a lot in fact in elements like:

  <item oor:path="/org.openoffice.ucb.Store/ContentProperties">
    <node oor:name="vnd.sun.star.hier://com.sun.star.ucb.DefaultHierarchyDataSource/templates/-/Pr%C3%A4sentationshintergr%C3%BCnde/Wine" oor:op=
"replace">

It's not entirely clear what those paths are for, they do look unusual.

Given the lack of more feedback and/or interest in testing with this old profile to get stack traces, the lack of more recent duplicates, and a number of other fixes around profile migration, I guess we can close this for now :-)

Please re-open if you can reproduce any of this / get a stack trace.