Download it now!
Bug 50552 - SPELL check does not mark wrong text and capitalization rules.
Summary: SPELL check does not mark wrong text and capitalization rules.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All Windows (All)
: high major
Assignee: Andras Timar
URL:
Whiteboard: (target:3.5.5)
Keywords:
: 48390 50410 50557 50588 50602 50608 50635 50822 50825 50887 51302 51348 51395 (view as bug list)
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-05-31 12:05 UTC by starmatz71
Modified: 2012-11-19 23:10 UTC (History)
20 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description starmatz71 2012-05-31 12:05:18 UTC
In LibreOffice 3.5.4.2 (german version) it seems the spellchecker does not work anymore.

I wrote the following into Writer:

Bratwurst
   die Bratwurst
   die bratwurst
   die braaatwurst
   die Bralaaatwurst

Nothing of these words are marked as wrong. The spellchecker does nothing.
Autokorrektion seems to work, because if you write bratwurst LibO change it to capitalized "Bratwurst".

Can someone confirm this behavior?
Comment 1 Rainer Bielefeld Retired 2012-05-31 22:54:46 UTC
NOT Reproducible with "LibreOffice 3.5.4.2 (RC2) German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) 

I am sure that this one is a DUP of an other one (may be lost dict.), but for decision more info is required

Not a valid bug report!

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list.
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a sample document related 
  step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected 
    --- only auto spell check related or also after <f7>?
    --- did you check text language, is it German?
    --- what available dicts. for what languages do you see in 'Tools ->
        Options -> Language settings - Default language'?
    --- what in 'Tools ->  Options -> Language settings -> Writing aids'
        might help to understand the problem 
    --- Really only WRITER related or also in CALC / DRAW / IMPRESS?
    --- bratwurst -> Bratwurst auto conversion only at beginning of a 
        sentence (for that no dict. is necessary) or also in middle of a 
        sentence?
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO  Locale setting
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts

Even if you can not provide all demanded information, every little new information might bring the breakthrough.

May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting bug reports? You reach that Bug Submission Assistant via LibO menu 'Help -> Feedback / Bug Report'
Comment 2 kayak182 2012-06-01 07:39:57 UTC
(In reply to comment #1)
> NOT Reproducible with "LibreOffice 3.5.4.2 (RC2) German UI/Locale [Build-ID:
> 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) 
> 
> I am sure that this one is a DUP of an other one (may be lost dict.), but for
> decision more info is required
> 
> Not a valid bug report!
> 
> @reporter:
> Thank you for your report – unfortunately important information is missing.
> May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to
> find out what information will be useful to reproduce your problem? If you
> believe that that  is really sophisticated please as for Help on a user mailing
> list.
> Please:
> - Write a meaningful Summary describing exactly what the problem is
> - Attach a sample document (not only screenshot) or refer to an existing 
>   sample document in an other Bug with a link.
> - Attach screenshots with comments if you believe that that might explain the 
>   problem better than a text comment. Best way is to insert your screenshots
>   into a DRAW document and to add comments that explain what you want to show
> - Contribute a sample document related 
>   step by step instruction containing every key press and every 
>   mouse click how to reproduce your problem (due to example in Bug 43431)
> – if possible contribute an instruction how to create a sample document 
>   from the scratch
> - add information 
>   -- what EXACTLY is unexpected 
>     --- only auto spell check related or also after <f7>?
>     --- did you check text language, is it German?
>     --- what available dicts. for what languages do you see in 'Tools ->
>         Options -> Language settings - Default language'?
>     --- what in 'Tools ->  Options -> Language settings -> Writing aids'
>         might help to understand the problem 
>     --- Really only WRITER related or also in CALC / DRAW / IMPRESS?
>     --- bratwurst -> Bratwurst auto conversion only at beginning of a 
>         sentence (for that no dict. is necessary) or also in middle of a 
>         sentence?
>   -- and WHY do you believe it's unexpected (cite Help or Documentation!)
>   -- concerning your PC (video card, ...)
>   -- concerning your OS (Version, Distribution, Language)
>   -- concerning your LibO  Locale setting
>   –- Libo settings that might be related to your problems 
>   -- how you launch LibO and how you opened the sample document
>   -- everything else crossing your mind after you read linked texts
> 
> Even if you can not provide all demanded information, every little new
> information might bring the breakthrough.
> 
> May be you can test <https://www.libreoffice.org/get-help/bug/> for submitting
> bug reports? You reach that Bug Submission Assistant via LibO menu 'Help ->
> Feedback / Bug Report'

I have the same problem with this release. I am using Windows 7 and writer does not correct misspelled English words
Comment 3 Rainer Bielefeld Retired 2012-06-01 09:07:24 UTC
*** Bug 50557 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2012-06-01 09:12:38 UTC
@kayak182@hotmail.com:
Please learn what's to do before you do. Your action here in this bug is without any benefit for finding out reasons of @starmatz71@yahoo.de.
Comment 5 Rainer Bielefeld Retired 2012-06-01 23:04:46 UTC
*** Bug 50588 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2012-06-01 23:12:52 UTC
@all:
I am pretty sure that your problem will disappear when you rename your user profile 

before you start LibreOffice. Can you confirm that?
May be a developer can find out the reasons for the problems with your old user profile (if my suspect is correct), so please keep you old user profile.
Comment 7 js_lcs 2012-06-01 23:40:14 UTC
I've installed the german 3.5.4 version on several different XP-32bit (4GB) computers.

The german spell checking don't work anymore. If I reinstall 3.5.3, it works again.

I've found an annoying behaviour on fresh 3.5.4 installs. I think, it could be
one cause of the spell checker failure.

At the first start 3.5.4 quits without any error message on every of my XP systems.

You will see the LO splash screen with some inits and when it quits.
 
After a second start LO works normally with the selection window (Writer, Calc etc.).

I think, the init processes aren't complete at the first start.
Comment 8 manj_k 2012-06-02 06:28:37 UTC
I could reproduce a test case where only the bundled French dictionary (dict-fr) has been enabled (instead of all selected/installed bundled dictionaries: dict-de, dict-en, dict-es, dict-fr, dict-it, dict-pt, dict-pt). 

Test case (on WinXP 32b):

- First start of LibO 3.5.4.2 with the LibreOffice user profile of LibO 3.5.3.2  (the same selected/installed bundled dictionaries as above; works fine with v3.5.3.2).

- LibO Splash screen quits quite early. 

- A second or third start will not enable the missing dictionaries (although they are shown in Extension Manager).


That has been resolved by synchronizing/enabling the bundled extensions once again:

- Close LibreOffice (+ Quickstarter, if enabled).
- Select the folder 'bundled' in LibreOffice user profile; path: ...\LibreOffice\3\user\extensions\bundled.
- Rename the folder 'bundled' to 'bundled_old'.
- Restart LibreOffice (maybe you need to start it twice due to bug 43989).

Please could you try this workaround in order to distinguish between different causes.
Comment 9 YK Loh 2012-06-02 07:16:12 UTC
This bug is also affecting English(USA) text by not marking wrong text in LibO Writer. Practically does nothing for Spellcheck even with manual activation of AutoSpellcheck button on Menu bar after having set and configured Tools, Options, Language Setting, Languages and Writing Aids. Have purposely type in wrong English spelling to see if it works (eg. wqrd instead of word) and it doesn't mark or highlight the mistake....
Thank You.
Comment 10 Rainer Bielefeld Retired 2012-06-02 10:27:56 UTC
@manj_k:
Your description sounds similar to problems I also had some time ago with a Master build using an existing LibODev Profile (2012-April)
The problem still is reproducible for me with that old User Profile and with "LibreOffice 3.6.0alpha1  German UI/Locale [Build-ID: 66f01b5] on German WIN7 Home Premium (64bit). This problem disappears for me with workaround as per your Comment 8. 
What ever that might tell concerning the roots of the problem.
Comment 11 starmatz71 2012-06-02 10:59:13 UTC
(In reply to comment #8)
> - Close LibreOffice (+ Quickstarter, if enabled).
> - Select the folder 'bundled' in LibreOffice user profile; path:
> ...\LibreOffice\3\user\extensions\bundled.
> - Rename the folder 'bundled' to 'bundled_old'.
> - Restart LibreOffice (maybe you need to start it twice due to bug 43989).
> 
> Please could you try this workaround in order to distinguish between different
> causes.

I have tried the workaround from comment 8 and the spellcheck works again, now.
After rename of the folder "bundled" to "bundled.old" i had to restart LibreOffice twice (at the first start the LibreOffice Splashscreen appears, the last text i could read was something like "Enabling WikiPublisher", after this the Splash disappear and nothing happens. I start LO a second time and then it starts up and i chose writer. The spellchecker in german works out-of-the-box!

The workaround solves the issue with the spellchecker for me, thanks a lot manj_k !

The cause seems indeed to be a regression while the first start of LO after an upgrade.

Hopefully it will be fixed in Libo 3.5.5 soon.
Comment 12 manj_k 2012-06-02 17:46:52 UTC
*** Bug 50608 has been marked as a duplicate of this bug. ***
Comment 13 YK Loh 2012-06-03 02:56:30 UTC
Have been trying to get to the workaround as detailed in Comment 8 by manj_k,
"- Close LibreOffice (+ Quickstarter, if enabled).
- Select the folder 'bundled' in LibreOffice user profile; path:
...\LibreOffice\3\user\extensions\bundled.
- Rename the folder 'bundled' to 'bundled_old'.
- Restart LibreOffice (maybe you need to start it twice due to bug 43989)."
but still couldn't find the folder to rename.

I've hunt all over the directories  and sub-dir of LibO 3.5 as per path below:-
C:\Program Files\LibreOffice 3.5\....
but couldn't find the user profile and the its folder????
Full path leading to this folder is highly appreciated.
Thanks and regards.
Comment 14 Rainer Bielefeld Retired 2012-06-03 03:01:57 UTC
(In reply to comment #13)
> I've hunt all over the directories  and sub-dir of LibO 3.5 as per path below:-
> C:\Program Files\LibreOffice 3.5\....

Wrong place!
<https://wiki.documentfoundation.org/UserProfile>
Comment 15 YK Loh 2012-06-03 13:18:28 UTC
Thank you all very much, especially manj_k, and rainer bielefeld for pointing me in the right direction of renaming the bundled folder. I forgot that the C:\... AppData\Roaming Folders are hidden folders.
Now LibO writer works perfectly with spellcheck working great.
Maybe you great guys can have this bug fixed in the next version.
Cheers and regards to all.
Comment 16 manj_k 2012-06-03 13:45:04 UTC
*** Bug 50602 has been marked as a duplicate of this bug. ***
Comment 17 manj_k 2012-06-03 14:26:19 UTC
Changed status to 'NEW'
(problem is reproducible, a workaround repeatedly tested and confirmed).

Changed component to 'Installation'
(seems to be a problem with synchronizing/enabling the bundled dictionaries).

Added Caolán McNamara to CC List
(somehow similar to bug 37195).
Comment 18 Andras Timar 2012-06-06 00:20:41 UTC
I think that problem may go away, when fix for bug #43989 lands in 3.5.5. It will be worth to test it in RC1.
Comment 19 manj_k 2012-06-07 09:55:45 UTC
*** Bug 50822 has been marked as a duplicate of this bug. ***
Comment 20 manj_k 2012-06-07 10:08:11 UTC
*** Bug 50825 has been marked as a duplicate of this bug. ***
Comment 21 manj_k 2012-06-09 02:51:22 UTC
*** Bug 48390 has been marked as a duplicate of this bug. ***
Comment 22 manj_k 2012-06-09 03:25:43 UTC
(In reply to comment #18)
> I think that problem may go away, when fix for bug #43989 lands in 3.5.5. It
> will be worth to test it in RC1.

That seems to be true.

The bug is no longer reproducible (different user profiles applied)
with LibO 3.6.0beta1 (Build ID: 1f1cdd8) on WinXP 32b.

Waiting to check 3.5.5 RC1.
Comment 23 MandiATO 2012-06-09 04:53:08 UTC
OK. When only 3.5.5 RC1 will be available for tests, I'll test it on some different machines with different configurations, and I'll let know about results of all that tests.
Comment 24 Erik Devriendt 2012-06-09 13:35:14 UTC
*** Bug 50887 has been marked as a duplicate of this bug. ***
Comment 25 manj_k 2012-06-15 07:53:03 UTC
This bug is no longer reproducible (for me; on WinXP 32b)
with LibO 3.5.5 RC1 
[LibreOffice 3.5.5.1 · Build ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8].

Installed as 'server image' (msiexec /a), with all bundled dictionaries.
Created [bootstrap.ini]: UserInstallation=$SYSUSERCONFIG/LibO-35-5/3.
Verified with pasted backup copies of customized LO user profiles v3.4.6/v3.5.3/v3.5.4 (upgrade simulation).
Started via soffice.exe (bug 43989 did not occur).
All bundled dictionaries available (tested languages: ~25).
Comment 26 Andras Timar 2012-06-15 08:05:43 UTC
Thanks for testing. It works for me, too. The fix for bug #43989 fixed this, too.
Comment 27 manj_k 2012-06-22 01:08:54 UTC
*** Bug 51302 has been marked as a duplicate of this bug. ***
Comment 28 manj_k 2012-06-22 20:59:42 UTC
*** Bug 51348 has been marked as a duplicate of this bug. ***
Comment 29 Urmas 2012-06-24 10:00:33 UTC
*** Bug 50635 has been marked as a duplicate of this bug. ***
Comment 30 manj_k 2012-06-25 08:29:09 UTC
*** Bug 51395 has been marked as a duplicate of this bug. ***
Comment 31 Ulrich Windl 2012-06-25 23:30:36 UTC
May I suggest to change the summary of this bug? The problem is not that spelling errors are not marked; instead the problem is that required linguistic components are not installed or found (as described in bug 51395).
Comment 32 manj_k 2012-08-06 18:48:23 UTC
*** Bug 50410 has been marked as a duplicate of this bug. ***
Comment 33 Rainer Bielefeld Retired 2012-10-25 04:10:52 UTC
Target due to "Bug 43989 - After installation first launch terminates after splash screen", because it seems that fix for that Bug seems to have fixed this one