Bug Hunting Session
Bug 50822 - : Spanish installation install french dictionary.
Summary: : Spanish installation install french dictionary.
Status: RESOLVED DUPLICATE of bug 50552
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 02:25 UTC by Javier Paños
Modified: 2012-06-12 13:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Javier Paños 2012-06-07 02:25:07 UTC
Problem description: 

Steps to reproduce:
1. Install "LibO_3.5.4_Win_x86_install_multi.msi".
2. Try to use documents in Spanish, don't find Spanish dictionary.
3. If you check the dictionary installed is in French.

Current behavior:
- Install manually Spanish dictionary like an extension.
Expected behavior:
- Dictionary will be buid-in in the installation.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 manj_k 2012-06-07 06:12:01 UTC
Please check the folder 'extensions'
[Path-to-installation\LibreOffice 3.5\share\extensions]:

Do you find 'dict-es' installed in that folder?
Comment 2 Javier Paños 2012-06-07 09:06:12 UTC
Yes, is installed, but until I have installed the dictionary manually was not possible to select in 'Tools/Spelling and Grammar'.

Before the manual installation is no possible select spanish in 'Options/Language Settings/Languages/Default Languages for documents', the 'Spanish' option have not check to do selectable, The only selectable option is French!!

After the manual installation, close and open LibreOffice and works Spanish, and French of course.

I think is a possible bug in the installation packet.
Comment 3 manj_k 2012-06-07 09:55:45 UTC
Thanks for your speedy reply.

That's obviously a duplicate of 'Bug 50552 - SPELL check does not mark wrong text and capitalization rules'.

Available workaround → https://bugs.freedesktop.org/show_bug.cgi?id=50552#c8 .

Bug 50552 may be a duplicate of 'Bug 43989 - After installation first launch terminates after splash screen' (bugfix will be available in v3.5.5).

*** This bug has been marked as a duplicate of bug 50552 ***
Comment 4 Not Assigned 2012-06-12 13:36:34 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=033cce3e0fbb72a9400836923be96c5036aaacb0

fdo#50822 add function XOR to calc as in ODFF1.2
Comment 5 Not Assigned 2012-06-12 13:36:59 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9ae96127e5b363e6eea14a0e9459b22f0f7307ca

changes to patch "fdo#50822 add function XOR to calc as in ODFF1.2"
Comment 6 Eike Rathke 2012-06-12 13:42:12 UTC
grmbl.. patch had wrong bug number in summary. The commits are for bug 50882 instead.