Download it now!
Bug 65997 - LO4 installer fails to migrate user customization from LO3
Summary: LO4 installer fails to migrate user customization from LO3
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 07:33 UTC by Kumāra
Modified: 2014-12-18 10:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kumāra 2013-06-21 07:33:10 UTC
I've just installed 4.0.4.2 over 3.6.6.2. Here's what I notice:

* User folders "autocorr" and "template" with their content didn't get transfered. The folders are absent in the version 4 user folder. So, understandably all user-added AutoCorrection entries aren't working, and user-created templates are missing.

* Folder "wordbook" is created but only contains the preset "standard.dic". All user dictionary (dic) files are not there. (So, essentially the problems is the same as the above.) Therefore, all user-added entries into "standard.dic" and all user-created dictionaries aren't available.

* User-installed extensions are all not transfer.

I'm able to manually fix these myself, but wonder about the average user. Presently, I would advice informing potential users of this issue at the download page, AND provide step-by-step workaround until the matter is resolved.
Comment 1 Kumāra 2013-06-21 07:54:54 UTC
Adding Windows Installer expert, Andras Timar.
Comment 2 Andras Timar 2013-06-21 15:03:17 UTC
Petr Mladek deals with config migration issues.
Comment 3 tommy27 2013-11-24 20:58:40 UTC
@Kumāra
do you still have this issue with recent upgrade to the 4.1.3.2 ?
Comment 4 Kumāra 2013-11-25 03:16:00 UTC
(In reply to comment #3)
> @Kumāra
> do you still have this issue with recent upgrade to the 4.1.3.2 ?

I don't know. I've only migrated once from 3 to 4. If no one has done anything to this, the bug remains.

Maybe we can leave this as it is. Maybe not. I'm thinking: What will happen when the number goes to 5? I presume that a new user folder, 5, will be created. Will ALL the folders from 4 be migrated? It will frustrate non-power users (the majority).

The installer needs to check if it's installing over a version of different number and copy over everything (or perhaps not everything) from the old folder.
Comment 5 tommy27 2013-11-25 03:34:36 UTC
I see. The only way to know if bug is still present would be to install a 3.6.6 version, do some customization in the autocorrection, dictionaries and templates sections, then install current 4.1.3 on top of it and see if the user profile migration fails are still reproducible.

I agree with you that it would be important to know that for the future release of the next major release (LibO 5.0.0)
Comment 6 retired 2014-06-27 20:53:18 UTC
Does this behavior persist with LO 4.3RC1?
http://www.libreoffice.org/download/pre-releases/

If so, please back to unconfirmed.
Comment 7 retired 2014-06-27 20:53:40 UTC
Also I have not experience this issue under OS X so might this be Windows or Linux only?
Comment 8 Kumāra 2014-06-29 02:53:03 UTC
(In reply to comment #6)
> Does this behavior persist with LO 4.3RC1?
> http://www.libreoffice.org/download/pre-releases/
> 
> If so, please back to unconfirmed.

I don't know. Don't have the resources now to test it. Need to do sth as suggested by tommy27 in Comment 5.

Anyway, I've changed some tags as suggested. But I still see this as important to look into. It would look pretty bad on LO5 if user customizations are not migrated from LO4.
Comment 9 Kumāra 2014-12-18 09:06:35 UTC
Recently, I installed
libo-43~2014-12-11_02.18.45_LibreOfficeDev_4.3.6.0.0_Win_x86
on a computer with LibO 3.6.5.2

The old version remains (which I suppose is expected) and the new version has the user settings and extensions properly migrated.

So, the matter is resolved.
Comment 10 retired 2014-12-18 10:14:36 UTC
Thanks for the update! Since we do not have a commit fixing this it is WORKSFORME.