Download it now!
Bug 52294 - LibreOffice setup fails on windows XP
Summary: LibreOffice setup fails on windows XP
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-07-20 09:18 UTC by bureautiquelibre
Modified: 2012-09-11 20:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1 (322.05 KB, image/bmp)
2012-07-20 09:18 UTC, bureautiquelibre
Details
Screenshot 2 (284.57 KB, image/bmp)
2012-07-20 09:19 UTC, bureautiquelibre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2012-07-20 09:18:55 UTC
Created attachment 64418 [details]
Screenshot 1

Setup runs OK, options chosen: all office formats associated to LibreOffice + load on startup

1/ Files aren't associated with LibreOffice
2/ LibreOffice crashes on startup, cf. screencaps
Comment 1 bureautiquelibre 2012-07-20 09:19:15 UTC
Created attachment 64419 [details]
Screenshot 2
Comment 2 Julien Nabet 2012-07-20 20:08:16 UTC
We need extra information here:
- What's your Java version ?
- Did you upgrade Java recently ?
- Do you use specific LO extension ? (if yes, which ones)

You can try the raw method:
- uninstall LO
- remove/backup your LO profile (see http://wiki.documentfoundation.org/UserProfile)
- clean Windows registry (you can use a free tool like ccleaner)
- install again LO
- reinstall your specific LO extension 1 by 1 (I mean test LO launching before installing new one) if any.
Comment 3 bureautiquelibre 2012-07-23 14:58:34 UTC
Java version 1.6.0_31
Didn't update recently

Installed extension: Oracle Alfresco connector, but not used recently.

Will try removing it.

The bug is still there in RC2
Comment 4 bureautiquelibre 2012-07-24 08:52:09 UTC
Problem gone after profile data removal, thanks for your help!
Comment 5 Julien Nabet 2012-07-24 11:10:30 UTC
If you have the faulty profile, you can attach it

*** This bug has been marked as a duplicate of bug 43489 ***
Comment 6 Roman Eisele 2012-08-16 15:10:21 UTC
This is not a real duplicate of bug 43489, cf.
  https://bugs.freedesktop.org/show_bug.cgi?id=51323#c13
; therefore set the Status of this bug to REOPENED (NEW is not possible): even if the issue is resolved for the original reporter (see comment #4), this is only just due to a workaround (profile data removal).
Comment 7 Petr Mladek 2012-08-21 09:22:01 UTC
bureautiquelibre@, could you please compress (zip) the old broken user configuration and attach it here? I am afraid that we could not fix anything if we are not able to reproduce the problem.

It is somehow specific to your user configuration => it should not block the release for others => lowering the severity a bit.
Comment 8 bureautiquelibre 2012-09-11 14:10:56 UTC
Hi, unfortunately, I had to removre the directory to reinstall LibreOffice.

I'll save it next time if the problem occurs again in any future release.
Comment 9 Julien Nabet 2012-09-11 20:36:58 UTC
Ok since you can't send LO directory profile, i'll update to WFM.
Thank you for your feedback.