Bug 53869 - CRASH on startup
Summary: CRASH on startup
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-08-21 07:14 UTC by damm
Modified: 2012-08-22 10:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
OSX crashlog (29.67 KB, text/plain)
2012-08-21 07:14 UTC, damm
Details
User Profile (old) (1.30 MB, application/zip)
2012-08-21 16:32 UTC, damm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description damm 2012-08-21 07:14:32 UTC
Created attachment 65867 [details]
OSX crashlog

LibO crashes on startup
allways
Comment 1 Rainer Bielefeld Retired 2012-08-21 08:31:50 UTC
Seems user uses French Localization, so might be DUP of "Bug 53416 - Systematic crash"? Or generally related to "Bug 51323 - Constant crashes on MacOS X 10.7 after using existing User Profile folder for upgrade"?

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- add information 
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO 
  -- Whether problem persists after you renamed your user profile
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>
  -- Whether you already used other versions without that bug
    -- If yes how you updated
  -- everything else crossing your mind after you read linked texts
Comment 2 Roman Eisele 2012-08-21 08:53:12 UTC
Hello damm@e-lektro.de,

thank you very much for your bug report! However, Rainer Bielefeld is right: we need more information to be able to help you and to track down the bug.

Maybe the most important thing to check is if there is a problem with the existing user profile. So please try this first:
  Search for the folder "LibreOffice" at
    <your user folder>/Library/Application Support/LibreOffice/
  and rename that folder to something else, e.g. "LibreOffice-old".
  Then please try to start LibreOffice 3.6 again
  and report the results here:
  does it start now, or does it still crash?

Another idea:
It is possible that there are problems with the folder name: according to the crash log, your LibreOffice installation is at
  Applications/¥ BŸro/LibreOffice.app
and the folder "¥ BŸro" (or however it reads) contains some special characters. So please try to move "LibreOffice.app" directly into your Applications folder (out of the "¥ BŸro" folder), then, to be on the save side, rename your user profile folder again (see above), and then try again to start LibreOffice.

Thank you very much in advance!


(We can extract from the crashlog the following important data:
* Mac OS X 10.6.8
* on a Intel machine (MacBookPro8, 4 processors, Intel Core);
* the crash happens early in the startup process.)
Comment 3 damm 2012-08-21 16:05:41 UTC
(In reply to comment #1)
> Seems user uses French Localization, so might be DUP of "Bug 53416 - Systematic
> crash"? Or generally related to "Bug 51323 - Constant crashes on MacOS X 10.7
> after using existing User Profile folder for upgrade"?
> 
> @reporter:
> Thank you for your report – unfortunately important information is missing.
> May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to
> find out what information will be useful to reproduce your problem? If you
> believe that that  is really sophisticated please as for Help on a user mailing
> list
> Please:
> - Write a meaningful Summary describing exactly what the problem is
> - add information 
>   -- concerning your PC (video card, ...)
>   -- concerning your OS (Version, Distribution, Language)

see the attached OSX Crashlog

>   -- concerning your LibO localization (UI language, Locale setting)

UI: german
Locale setting: see attached User profile

>   –- Libo settings that might be related to your problems 
>     (video hardware acceleration ...)
>   -- how you launch LibO
doubleclick on application icon

>   -- Whether problem persists after you renamed your user profile
>      <https://wiki.documentfoundation.org/UserProfile#User_profile_location>

no, it works after rename the user profile

>   -- Whether you already used other versions without that bug
yes, 3.4.5 an 3.5.5
>     -- If yes how you updated
I copied the app from the image to the application subfolder

>   -- everything else crossing your mind after you read linked texts
Comment 4 Alex Thurgood 2012-08-21 16:15:49 UTC
I can not reproduce the problem on OSX 10.8

Additionally, you state that in Comment 3 that it works after you deleted the user profile and restarted, so that would correspond to the problem already indicated of the release notes on the wiki/website page.


I'm inclined to close this as WFM, worksforme, since you say it is now working. If you feel that this is incorrect, please re-open and provide more detailed information.

Alex
Comment 5 Alex Thurgood 2012-08-21 16:21:43 UTC
I would add that :

http://wiki.documentfoundation.org/ReleaseNotes/3.6

does not appear to have been fully translated into German to include the list of MABs and the workarounds known at release date (like removing the bundled extensions from your user profile via the Terminal.app before starting LO.


Alex
Comment 6 damm 2012-08-21 16:32:28 UTC
Created attachment 65899 [details]
User Profile (old)
Comment 7 Roman Eisele 2012-08-21 17:17:04 UTC
(In reply to comment #3)
> > -- Whether problem persists after you renamed your user profile
> no, it works after rename the user profile

Good news!

> > -- Whether you already used other versions without that bug
> yes, 3.4.5 an 3.5.5

Therefore I think this is yet another "Incorrect behavior using existing User Profile for upgrade"; so I add this bug to our task bug 43489.


(In reply to comment #6)
> Created attachment 65899 [details]
> User Profile (old)

Thank you very much for attaching the faulty old user profile! This could be helpful to track down the exact reasons for these crashes.
Comment 8 Roman Eisele 2012-08-21 17:22:07 UTC
(In reply to comment #4)
> I'm inclined to close this as WFM, worksforme, since you say it is now working.
> If you feel that this is incorrect, please re-open and provide more detailed
> information.


@Alex,
@Rainer:
I wonder what is the right way to proceed with this kind of bug. LibreOffice 3.6 is now working for the user, of course, but not because the bug just went away or was fixed, but because of a mere workaround (renaming the user profile). Under these circumstances, should we really mark the bug as RESOLVED|CLOSED WORKSFORME, or should we leave it open (at least for now) to make clear that the bug was not really fixed, but might need further investigation as part of our task bug 43489?

No offence -- I just want to make sure that we handle this kind of bug in a consistent and useful way!
Comment 9 Michael Meeks 2012-08-22 10:38:01 UTC
Any chance you can delete the new profile, copy your old profile back, and install the latest pre-release:

http://www.libreoffice.org/download/pre-releases/

And check that it works ok with the old profile ?

If that is the case - the bug is truly fixed in 3.6.1 - testing very much appreciated :-)

Thanks !

If that is not the case, it's even more interesting - we need to re-open, and get a copy of the profile :-)