Bug 54374 - JRE path isn't updated
Summary: JRE path isn't updated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-09-02 06:46 UTC by Joop Lanting
Modified: 2012-09-16 13:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document as mentioned above. (10.86 KB, application/vnd.oasis.opendocument.text)
2012-09-02 06:46 UTC, Joop Lanting
Details
Screen shot of the crash event (115.77 KB, image/jpeg)
2012-09-08 09:21 UTC, Joop Lanting
Details
File differences with TotalCommander (147.75 KB, image/jpeg)
2012-09-09 05:47 UTC, Joop Lanting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joop Lanting 2012-09-02 06:46:03 UTC
Created attachment 66482 [details]
Document as mentioned above.

After opening a specific document (document was reduced in size for your convenience) an attempt was made to print it.
However every time, after opening the FILE menu, when moving the cursor down, WRITER crashes when 'passing by' the entry SEND.
Every time WRITER sends a bug report but the document must be recovered and opened again and again.

This problem has been there for several releases, I had hoped it would go away at release 3.6

The only thing that's special about the document is that it uses the Times font
in the UNICODE extended area.

Document attached.

;JOOP!
Comment 1 Julien Nabet 2012-09-04 20:57:04 UTC
On pc Debian x86-64 with 3.6 or 3.5 sources both updated today, I don't reproduce the problem.

Did you install any specific LO extensions?
Did you install any specific LO fonts?
Could you try to reproduce this by renaming your LO directory profile? (see http://wiki.documentfoundation.org/UserProfile)
Comment 2 Joop Lanting 2012-09-08 08:56:24 UTC
I must re-write this bug (I never noticed a problem like this before):

It seems that I never ever used the "Send" submenu under "File".
Presently I find that when I open "File" and go QUICKLY down to
(e.g.) PrintPreview, all is well.

However, if I only hesitate for a split second on "Send", Writer crashes
and sends a bug report to (assumed) you.

There are NO installed extensions to LO (it's a fresh installation of 3.6.1),
there are no fonts involved, as the crash will happen with a blank document
while the default font is Times New Roman.
The crash happens on both XP and Windows 7, although the messages are not equal
(7 pretends to send a report to Microsoft).

;JOOP!
Comment 3 Joop Lanting 2012-09-08 09:21:21 UTC
Created attachment 66829 [details]
Screen shot of the crash event
Comment 4 Joop Lanting 2012-09-08 09:22:24 UTC
Further information:

As Send has something to do with the Internet (I presume) I opened:

Tools-Options and stepped down, opening the entire tree.
Al went well until I hit the last entry "MediaWiki" as you will see on the screen shot.
Crash!

Now I'm beginning to wonder if Writer ever succeeded to send you a bug report
if something is wrong with the connection LO-Internet.
My Internet works fine and my email is OK.

The installation wizard of LO never asked me anything about Internet connections
and it seems to be able to detect new releases of LO, so ......

;JOOP!
Comment 5 Julien Nabet 2012-09-08 11:43:32 UTC
To keep QA work not to difficult, please don't mix 2 bugs. 1 bugtracker = 1 bug.
Check fdo#52122 (see https://bugs.freedesktop.org/show_bug.cgi?id=52122) and don't hesitate to comment it if you have new info.
Comment 6 Joop Lanting 2012-09-08 13:22:26 UTC
Sorry I thought I had the same bug by the tail.
I added comment over there.

Anyway, here it's about 'touching' Send ............

;JOOP!
Comment 7 Julien Nabet 2012-09-08 13:46:50 UTC
Did you try to reproduce this after having renamed your LO directory profile? (see
http://wiki.documentfoundation.org/UserProfile)
Comment 8 Joop Lanting 2012-09-08 15:27:43 UTC
For the moment: that solves the problem, but I lost all my preferences,
like toolbars.
Gonna work in back to my own profile.

;JOOP!
Comment 9 Julien Nabet 2012-09-08 15:48:17 UTC
Since you renamed your LO profile, you should find your preferences again in this backup.
With several tests between the backup and the brand new LO profile, you should find the guilty part which causes your problem.
(again, this may help http://wiki.documentfoundation.org/UserProfile)

BTW, I linked the tracker to the fdo#43489 (see https://bugs.freedesktop.org/show_bug.cgi?id=43489).
Comment 10 Joop Lanting 2012-09-08 16:03:43 UTC
I found it: it was the JAVA-settings referring to a non-existing JAVA runtime.

I seem unable to attach a picture: I get a SERVER error.

;JOOP!
Comment 11 Joop Lanting 2012-09-08 16:22:26 UTC
It seems that, like with Eclipse, with every JAVA update the setting in
Tools-Options-JAVA must be corrected also.
I wonder why LO (and Eclipse) can't find the JRE in a standard location.

;JOOP!
Comment 12 Joop Lanting 2012-09-09 05:47:26 UTC
Created attachment 66867 [details]
File differences with TotalCommander

You suffered server problems.
Finally I could upload this picture.

I think: case closed.
;JOOP!
Comment 13 Julien Nabet 2012-09-09 07:51:42 UTC
Joop: I updated the title. It seems that finall, the cause of this bug can be considered like a dup of fdo#52122 (see https://bugs.freedesktop.org/show_bug.cgi?id=52122)

Rainer: what should we do with this bug?
- dup?
- New and link it to a task about Java problems (and not a metabug) ?

Stephan: I'm pretty sure having read on dev mailing list something about a fix for updating jre path when not found, does it ring a bell with you?
Comment 14 Joop Lanting 2012-09-09 08:30:11 UTC
Thanks for all your efforts.
LibreOffice is surely the way to go, at least because of this kind of support.

In the mean time I found that, although my XP system is fine now,
my Windows7 system seems to need a 32-bit JRE as the 64-bit JRE is not
accepted, still causing crashes on "Send".
Renaming the user directory reveals that on W7 LO does NOT create a new
file "javasettings*.xml

As I'm planning to buy a MacBook Pro which is 64-bits by nature, I wonder
how I will cope with this problem on that machine as Oracle doesn't
provide a 32-bit JAVA7 any more.

;JOOP!
Comment 15 Joop Lanting 2012-09-09 13:03:53 UTC
......... but, installing a 32-bit JRE7 on Windows7 did not help:
Tools-Options-JAVA 'sees' 3 JRE's (JDK-64, JRE-64 AND JRE-32),
but whatever you choose (.) it remains crashing on 'Send'.

;JOOP!
Comment 16 Stephan Bergmann 2012-09-10 07:52:51 UTC
(In reply to comment #15)
> ......... but, installing a 32-bit JRE7 on Windows7 did not help:
> Tools-Options-JAVA 'sees' 3 JRE's (JDK-64, JRE-64 AND JRE-32),
> but whatever you choose (.) it remains crashing on 'Send'.

The descriptions about crashing upon "File - Send..." make this bug surely a duplicate of bug 36149, to be fixed in LO 3.5.7 and LO 3.6.2.  (The crash is due to LO trying to display an error dialog while opening a menu, which can happen for both a "no JRE installed" message, as in bug 36149, as well as for a "JRE is defective" message, which would more likely be the case here.)

That LO does not even work with a 32bit JRE for you is probably due to bug 50584, currently only targeted to be fixed in LO 3.7.

(And re Mac, at least for Mac OS X 10.7 there is still a 32 bit JRE provided by Apple, and I'm not aware this has changed for 10.8.)
Comment 17 Joop Lanting 2012-09-10 08:26:52 UTC
Thanks.
Looking forward to new releases.

;JOOP!
Comment 18 Jean-Baptiste Faure 2012-09-15 09:00:57 UTC
Hi Joop,

Could you test again with LO 3.6.2.1 (RC1 only, not the final version) which has just been released ?

Thank you very much.
Comment 19 Joop Lanting 2012-09-15 13:10:47 UTC
Hi Jean,
I just down loaded 3.6.2.1 / GB for Windows.
Didn't see anything else than this (no RC1).
Will try tomorrow, because I'm gonna backup first.
(had a bad experience with AVG the other week)

;JOOP!
Comment 20 Jean-Baptiste Faure 2012-09-15 14:06:35 UTC
(In reply to comment #19)
> Hi Jean,
> I just down loaded 3.6.2.1 / GB for Windows.
> Didn't see anything else than this (no RC1).

The last number in 3.6.2.x is de RC number. So LO 3.6.2.1 is the RC1 for LO 3.6.2
Comment 21 Joop Lanting 2012-09-16 09:57:38 UTC
Hi Jean, good news on my 16th Wedding anniversary day: it works well.

Both on Windows-XP (32) and Windows7 (64) I:
- made a backup of the '3/user' tree,
- restored from a Norton Backup at least 3 months old,
- un-installed LO 3.6.1
- installed LO 3.6.2.1
- observed the updating of the file 'javasettings_Windows_x86.xml',
- tested File->Send

All OK.
For the time being I will continue on this release.

Questions to you (as I planned to buy a MacBook next week):
- how intensively is LO developed and tested for OSX?
- does LO follow the OSX-proprietary issues like Full Screen and Retina Screen?

It's important to me as I want to switch completely to Apple and keep testing
all new releases of LibreOffice.

Thanks,

;JOOP!
Comment 22 Jean-Baptiste Faure 2012-09-16 10:45:50 UTC
Ok, so closing as WorkForMe

For MacOS question: I do not know and bugzilla is not the right tool to discuss that. Please ask on Ask-Libo : http://ask.libreoffice.org

Do not forget to upgrade to 3.6.2.2 when the RC2 will be released: http://wiki.documentfoundation.org/ReleasePlan/3.6#3.6.2_release

Best regards. JBF
Comment 23 Julien Nabet 2012-09-16 10:56:31 UTC
Joop: there's also user mailing list here:http://nabble.documentfoundation.org/Users-f1639498.html
Comment 24 Joop Lanting 2012-09-16 13:28:32 UTC
Well, Ask-Libo is not very positive about LO on OSX.
But may be the forthcoming 3.6.2.2 will be acceptable.
Otherwise you'll me again here ..............

Thanks for your help so far.
;JOOP!