Download it now!
Bug 36149 - CRASH hovering over Menu "File > Send" if no JRE is available and MediaWiki Publisher installed
Summary: CRASH hovering over Menu "File > Send" if no JRE is available and MediaWiki P...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Stephan Bergmann
URL:
Whiteboard: target:3.7.0 target:3.5.7 target:3.6.2
Keywords:
: 44658 54201 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-04-12 00:57 UTC by s.a.moeller
Modified: 2012-10-30 18:43 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description s.a.moeller 2011-04-12 00:57:26 UTC
LibO Writer crashes when hovering the mouse over the menu entry "File > Send", if there is no JRE available (either not installed or disabled in LibO's options).

Steps to reproduce:
1. You need a large screen (see below).
2. Disable the JRE in the options menu.
3. Close LibO and re-open Writer.
4. Maximize the window.
5. Open Menu "File" and move the mouse down to "Send".
6. The "Activate JRE" dialog comes up. (BTW, this is annoying. I have disabled Java on purpose. No need to remind me every time.) To trigger this bug the window has to be rather large - the dialog must not overlap the menu.
7. Move the mouse towards the dialog.
8. Once the mouse pointer leaves the menu, LibO crashes (and the document recovery window comes up).
Comment 1 Rainer Bielefeld Retired 2011-04-12 02:34:47 UTC
[Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:202 / tag 3.3.2.2)]". As long as  'Tools > Options > Java > Use a JRE is checked everything will work fine, even if none of the listed JREs is selected. But as soon as option is unchecked, crash will happen as reported.

Calc and DRAW are not affected.

No problem with a few weeks old OOo-dev 3.4

@Cédric:
Your area?
Comment 2 Rainer Bielefeld Retired 2011-09-28 04:32:33 UTC
It seems the problem is back after I did several tests for Bug 41179 - UI: CRASH when mouseover menu 'File -> Send' for what I replaced my own user profile by a damaged one temporarily. 
After I ha switched back to my normal profile WRITER behaves as following with disabled JRE:
- Dialog "Java required" when mouseover 'File -> Send'
  a) Message "Java required" appears
    aa) Crash as soon as I leave menu area     or
    ab) when I move mousepointer carefully to the message box LibO does not
        crash. When I click Exit dialog box disappears, and from now on no 
        Message box will appear with mouse pointer above 'Send', and no crash

Success "ab" vanishes after I have terminated LibO and restarted

Is Java really required?
Comment 3 Olivier R. 2012-01-05 08:18:38 UTC
Seems solved with
LOdev 3.5.0beta2+ 
Build ID: 2650c80-7ef74e0-dee380a
Comment 4 Olivier R. 2012-01-05 08:33:45 UTC
Java is disactivated, but there is no dialog asking to activate JRE. And no crash.
Comment 5 Andras Timar 2012-01-05 09:50:18 UTC
(In reply to comment #4)
> Java is disactivated, but there is no dialog asking to activate JRE. And no
> crash.

For me it crashes (3.5.0 beta2 on Windows XP). I think it is related to registration of the Wiki publisher extension. When it crashes, the "To MediaWiki" menu item is active, while the extension itself is not runnable, because it requires Java. After invoking the Extension Manager dialog, somehow the system learns that Java Extensions should be disabled, and then the "To MediaWiki" menu item is grayed out and crash does not happen.
Comment 6 Olivier R. 2012-01-05 11:00:39 UTC
There is no Wiki publisher extension in the LO 3.5 version I installed. So I downloaded it and installed it. Then, the bug occurs as described.
Comment 7 Rainer Bielefeld Retired 2012-01-11 04:03:15 UTC
*** Bug 41179 has been marked as a duplicate of this bug. ***
Comment 8 Rainer Bielefeld Retired 2012-01-11 04:03:54 UTC
*** Bug 44658 has been marked as a duplicate of this bug. ***
Comment 9 Florian Reisinger 2012-03-25 07:09:48 UTC
Changed Version to LibO 3.5b2. Personally, I had such problems, but now not.

Regards

Florian
Comment 10 Rainer Bielefeld Retired 2012-03-25 07:31:42 UTC
> Changed Version to LibO 3.5b2. 

Why?
Comment 11 Florian Reisinger 2012-03-25 09:08:44 UTC
(In reply to comment #10)
> > Changed Version to LibO 3.5b2. 
> 
> Why?

Because of comment 5
Comment 12 Rainer Bielefeld Retired 2012-03-25 09:11:23 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 13 Marc Kaulisch 2012-03-30 02:02:56 UTC
installed LibO 3.5.1 on Win 7 64bit:
with user interface language German: I experience the described bug
with user interface language Englisch (UK): I do not experience the bug

after activating Java - also it does not crash with user interface German...
Comment 14 vanyasmart 2012-04-05 12:47:51 UTC
Whole LibreOffice crashes when I do all this stuff in latest (3.5.2) version if Java enabled in settings but there is no on PC. I've tested it in LO with Russian localisation.
Comment 15 Florian Reisinger 2012-04-06 01:20:40 UTC
Changed back to 3.3.2, because it is the earliest release affected...
(Referring to comment 12)
Comment 16 Dix Huit 2012-07-04 17:54:05 UTC
Please see https://www.libreoffice.org/bugzilla/show_bug.cgi?id=50254
Comment 17 Rainer Bielefeld Retired 2012-07-04 21:28:30 UTC
CRASH [Reproducible] with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) and
[Reproducible] with Server Installation of  "LibreOffice 3.6.0.0.beta2  German UI/Locale [Build-ID: f010139] on German WIN7 Home Premium (64bit) 

When I disable JRE, I get the "JRE required" when hovering 'Send', when I click 'Send' both versions crash.

Assign back to list due to facts, add to MAB to attract some more attention.

We can not ignore a Crash bug for more than a year.

@Michael, Stephan:
Can you please have a look?
Comment 18 Michael Meeks 2012-07-06 02:42:25 UTC
Looks / sounds bad - prolly an un-caught / handled exception lurking somewhere.

Andras/Fridrich - can we get a stack-trace ?
Comment 19 Rainer Bielefeld Retired 2012-08-17 21:26:46 UTC
No longer reproducible with parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 6900781]" (tinderbox: 2008R2@20, pull time 2012-08-14 09:27:23)?
Comment 20 Rainer Bielefeld Retired 2012-08-18 06:23:40 UTC
No longer reproducible with unzipped Master Build  "LOdev " 3.7.0.0.alpha0+  ENGLISH UI  [Build ID: 03d64b7]" (tinderbox:W2008R2@20, pull time 2012-08-18 00:16:52) // WIN7 Home Premium (64bit)
No longer reproducible with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) 

But I was able to reproduce with 3.6.0.1

So WFM!

@reporter:
Please feel free to reopen this bug if you find out that the problem reappears  after 3.6.1.1 or still is visible for you with 3.6.1.1 with other OS!
Comment 21 Dix Huit 2012-08-24 19:38:57 UTC
This still occurs for me with LibreOffice Version 3.6.1.1 (Build ID: 4db6344) and Java build 1.7.0_06-b24 on French Windows XP Home Edition SP3.

For the crash to occur, you have to move the mouse pointer out of the "File" menu (without clicking "OK" in the dialog box), return the mouse pointer to the "File" menu, and leave the "File" menu once again.

Note that this behavior is very similar to Bug 50254, but was not fixed by installing Microsoft Visual C++ 2010 SP1 Redistributable.
Comment 22 Not Assigned 2012-08-28 15:17:06 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9cfc64c66ff9e0f0251a006f039bf4e26a63147a

fdo#36149: Do not display error dialogs while showing a menu
Comment 23 Stephan Bergmann 2012-08-29 07:44:18 UTC
Backporting requests for LO 3.5 (<https://gerrit.libreoffice.org/#/c/505/>, seen happen with LO 3.5.6) and LO 3.6 (<https://gerrit.libreoffice.org/#/c/504/>, seen happen with LO 3.6.1.2) pending.
Comment 24 Not Assigned 2012-08-29 08:36:58 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88c8616270c2157d1a54ba54ddc4bdfae1cd1825&g=libreoffice-3-5

fdo#36149: Do not display error dialogs while showing a menu


It will be available in LibreOffice 3.5.7.
Comment 25 Not Assigned 2012-08-29 08:37:19 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba08ba5b30f906b795360ce4579721b25e316ae7&g=libreoffice-3-6

fdo#36149: Do not display error dialogs while showing a menu


It will be available in LibreOffice 3.6.2.
Comment 26 Rainer Bielefeld Retired 2012-09-24 16:52:38 UTC
*** Bug 54201 has been marked as a duplicate of this bug. ***
Comment 27 Dix Huit 2012-10-30 18:43:54 UTC
On French Windows XP Home Edition SP3 with LibreOffice Version 3.6.2.2 (Build ID: da8c1e6), this appears to be fixed.