Download it now!
Bug 41179 - UI: CRASH when mouseover menu 'File -> Send'
Summary: UI: CRASH when mouseover menu 'File -> Send'
Status: RESOLVED DUPLICATE of bug 38913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-25 00:48 UTC by Florian Reisinger
Modified: 2012-09-05 08:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
My user folder (1.15 MB, application/x-zip-compressed)
2011-09-25 00:48 UTC, Florian Reisinger
Details
In the second half, you can see the crash (~20seconds) (534.04 KB, video/webm)
2011-09-25 07:14 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2011-09-25 00:48:44 UTC
Created attachment 51583 [details]
My user folder

If I try to open the Send menu, LibreOffice hangs up....

Here the German error message of Windows 64-Bit:


Problemsignatur:
  Problemereignisname:	BEX
  Anwendungsname:	soffice.bin
  Anwendungsversion:	3.4.302.500
  Anwendungszeitstempel:	4e54357a
  Fehlermodulname:	MSVCR90.dll
  Fehlermodulversion:	9.0.30729.6161
  Fehlermodulzeitstempel:	4dace5b9
  Ausnahmeoffset:	0002e9f4
  Ausnahmecode:	c0000417
  Ausnahmedaten:	00000000
  Betriebsystemversion:	6.1.7601.2.1.0.768.3
  Gebietsschema-ID:	3079
  Zusatzinformation 1:	5c3f
  Zusatzinformation 2:	5c3f97c0120684940946f3d4f7dfb1e3
  Zusatzinformation 3:	ee6f
  Zusatzinformation 4:	ee6f383769dbe8d944db1baf8dfc303b

Lesen Sie unsere Datenschutzbestimmungen online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
  C:\Windows\system32\de-DE\erofflps.txt

As an attachment my user-folder
Comment 1 Rainer Bielefeld Retired 2011-09-25 04:07:53 UTC
@reporter:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots into a
  DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read a.m. URL

"... open the send menu ..." is very rare. What document type? In what moment does the crash happen? Immediately when you click "send"?
Comment 2 Florian Reisinger 2011-09-25 07:14:39 UTC
Created attachment 51588 [details]
In the second half, you can see the crash (~20seconds)
Comment 3 Florian Reisinger 2011-09-25 07:24:09 UTC
(In reply to comment #1)
> @reporter:
> May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>
> carefully?

> Then please:
> - Attach a sample document (not only screenshot)

No need (bottom)

> - Attach screenshots with comments if you believe that that might explain the 
>   problem better than a text comment. Best way is to insert your screenshots
> into a
>   DRAW document and to add comments that explain what you want to show
> - Contribute a step by step instruction containing every key press and every 
>   mouse click how to reproduce your problem (and if possible how to created a 
>   sample document from the scratch)
> - add information 
>   -- what exactly is unexpected
>   -- and why do you believe it's unexpected (cite Help or Documentation!)
>   -- concerning your PC 
>   -- concerning your LibO version and localization (UI language)
>   –- Libo settings that might be related to your problems 
>   -- how you launch LibO and how you opened the sample document
>   –- If you can contribute an OOo Issue that might be useful
>   -- everything else crossing your mind after you read a.m. URL
> 
> "... open the send menu ..." is very rare. What document type? In what moment
> does the crash happen? Immediately when you click "send"?

What is unexpected?? LibreOffice crashes, if I choose File --> Send to.
My PC: Win7 SP1 64-Bit, Laptop, German and English UI
New info:
-It does not matter which document, feel free to open a new document (it does not matter how).
-Just Writer crashes
-Freezes at mouseover and crahes within 3-5 seconds

That should be everything you need (Sorry for the bad video-quality...)
Comment 4 Rainer Bielefeld Retired 2011-09-25 08:09:44 UTC
@Florian:
I am not sure whether I understand correct:
a) only WRITER crashes?

I can't reproduce the problem with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

Additional questions:
c) problem remains when you rename your user profile aver exit from LibO? 
d) is it possible that an extension causes the problem?
Comment 5 Florian Reisinger 2011-09-25 08:16:41 UTC
(In reply to comment #4)
> @Florian:
> I am not sure whether I understand correct:
> a) only WRITER crashes?

All application crash, if they are opened in background, but just Writer causes the problem.

> 
> I can't reproduce the problem with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium
> (64bit) German UI [OOO340m1 (Build:302)]" 
> 
> Additional questions:
> c) problem remains when you rename your user profile aver exit from LibO?

No - the old user folder is attached
 
> d) is it possible that an extension causes the problem?

I don't think so - it might be a extension delivered with LibreOffice.
Comment 6 manj_k 2011-09-25 10:55:17 UTC
Crash not reproducible (on WinXP 32b) 
with LibO 3.4.3 release [LibreOffice 3.4.3 OOO340m1 (Build:302),
and with my customized user profile (or a default user profile).

The crash is reproducible with a new server image of LibO 3.4.3 release, and with the attached--incomplete(!)--user profile 'My user folder' (id=51583):

[UI: de]
1. soffice.exe > Text document > 'bt <F3>' > Save as *.odt
2. File > Send

Unexpected: Mouseover 'Send' let Writer crash.
I could reproduce the crash about ten times with the attached user profile.

3. Then I have enabled 'Tools > Options > Java' with the installed jre 1.6.0_26.
4. I retried the steps 1. to 2.
- File > Send... didn't crash anymore
- File > Send > Document as E-mail worked fine.

Maybe related to 'Bug 36149 - Hovering over Menu "File > Send" crashes LibO, if no JRE is available' ?
Comment 7 Rainer Bielefeld Retired 2011-09-28 02:42:47 UTC
@manj_k
Good Catch! I can reproduce the crash with reporter's user profile and unselected Java. 

For the JRE-Crash we have Bug 36149, and that seemed to work since 3.4.3, but after my experiments I also get crashes with my normal profile and 3.4.3, something damaged or was my test there too quick? We will have to check that. Can you do a test there?

The thrilling question remains why the reporter has such an incomplete user profile. 

@Reporter:
Any idea why your profile is damaged? it's much bigger and contains more files than mine, but several folders (autocorrect, autotext, ...) and important files (registrymodifications.xcu, ...) are missing?
Comment 8 Florian Reisinger 2011-09-28 07:33:54 UTC
(In reply to comment #7)

> @Reporter:
> Any idea why your profile is damaged? it's much bigger and contains more files
> than mine, but several folders (autocorrect, autotext, ...) and important files
> (registrymodifications.xcu, ...) are missing?

No....Except:  I have installed LibreOffice 3.4.3 over 3.4.2 and I have to type every time my First and last name, it's annoying.
Comment 9 manj_k 2011-09-28 14:33:00 UTC
(In reply to comment #7)
> [...]
> For the JRE-Crash we have Bug 36149, and that seemed to work since 3.4.3, but
> after my experiments I also get crashes with my normal profile and 3.4.3,
> something damaged or was my test there too quick? We will have to check that.
> Can you do a test there?

I tried some tests (File > Send) with Writer and disabled JRE
- empty page [no crash]
- 'dt <F3>' (unsaved/saved) [no crash]
- File > Open > 'plain' *.odt [no crash]
- File > Open > 'old' *.odt (2010-09-28 ;)) [no crash]
- File > Open > 'very old tricky OOo' *.odt (with macros, 2006-04-28) [no crash]
- File > Open > 'more tricky' *.odt (211 pages) [no crash]

Tested twice (on WinXP 32b) with
a. LibO 3.4.3 release · LibreOffice 3.4.3 OOO340m1 (Build:302)
('registrymodifications.xcu': 619 KB)
b. LibO Master · LibO-dev 3.5.0 Build ID: 8cc839d-3dca5fd-4525197 [2011-09-12_16.09.34]
('registrymodifications.xcu': 256 KB)
Comment 10 Björn Michaelsen 2011-12-23 12:32:36 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 11 Björn Michaelsen 2011-12-23 17:00:14 UTC
needinfo keyword redundant by needinfo status.
Comment 12 Rainer Bielefeld Retired 2012-01-11 04:03:15 UTC
DUP for now!

@Florian Reisinger:
Please watch "Bug 36149 - Hovering over Menu "File > Send" crashes LibO, if no JRE is available" and feel free to reopen this report if Fix for Bug 36149 will not work for you.

*** This bug has been marked as a duplicate of bug 36149 ***
Comment 13 Stephan Bergmann 2012-09-05 08:44:50 UTC
Windows exception code c0000417 and offset 0002e9f4 in msvcr90.dll indicate this is rather a duplicate of Bug 38913.

*** This bug has been marked as a duplicate of bug 38913 ***