Bug Hunting Session
Bug 50254 - CRASH on File->Send when Java7 Upt 4.
Summary: CRASH on File->Send when Java7 Upt 4.
Status: RESOLVED DUPLICATE of bug 50584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 50371
  Show dependency treegraph
 
Reported: 2012-05-22 17:53 UTC by stephenwidmer
Modified: 2012-12-12 21:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stephenwidmer 2012-05-22 17:53:39 UTC
When attempting to send a document and the user clicks File and then hovers over or attempt to click Send, Writer crashes complaining about about an issue with Java either not being install or damaged.

I have reinstall Java7 upt 4 several times from Oracles site both via IE's broswer and via Firefox each installation act the same way with LibreOffice Writer. The exact version is LibreOffice 3.5.3.2 
Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
Comment 1 Dix Huit 2012-07-04 17:40:04 UTC
I am experiencing the same bug.  Installing Java 6 and using it for LibreOffice fixes the problem.  Conclusion: Java 7 breaks LibreOffice.
Comment 2 Dix Huit 2012-07-04 17:42:13 UTC
I am using LibreOffice 3.5.4.2 
Version ID : 165a79a-7059095-e13bb37-fef39a4-9503d18
Comment 3 Rainer Bielefeld Retired 2012-07-04 21:32:26 UTC
@reporter/all
a) does LibO recognize JRE 7 (You can click the radio button in 'Tools -> Options ->  LibO -> Java)?
b) are there indications that LibO "really" recognized JRE? Please open Database
   VIEW in Writer,' rightclick "Bibligraphy" -> Edit -> Report -> Create with
   Assistant'. If that works, LibO "really" recognized your JRE.
An other indicator for not recognized JRE would be "Bug 36149 - CRASH hovering over Menu "File > Send" if no JRE is available and MediaWiki Publisher installed"
Comment 4 Dix Huit 2012-07-06 17:04:56 UTC
(In reply to comment #3)
> @reporter/all
> a) does LibO recognize JRE 7 (You can click the radio button in 'Tools ->
> Options ->  LibO -> Java)?

Yes, you can click the radio button for either Java 6 or Java 7.

> b) are there indications that LibO "really" recognized JRE? Please open
> Database
>    VIEW in Writer,' rightclick "Bibligraphy" -> Edit -> Report -> Create with
>    Assistant'. If that works, LibO "really" recognized your JRE.

With Java 6 this gives the error message "No valid report template was found."  However, with Java 7 this gives the error message "The selected JRE is defective" (without crashing LibreOffice).  This is the same message that is displayed when LibreOffice crashes after File -> Send.

Note that the crash does not occur if the user interface is in "English (USA)".

Also note that the crash does not occur if you go through the routine described above for testing Java (open Database VIEW in Writer, right-click "Bibliography" -> Edit -> Report -> Create with Assistant), get "The selected JRE is defective" error message, and THEN hover over File -> Send.
Comment 5 Rainer Bielefeld Retired 2012-07-06 22:18:15 UTC
I think the core of the problem is a really defective or not correctly recognized JRE 7. I will do my own tests during Weekend.

After some more research it might be useful to add Stephan, Caolán to CC

@Dix Huit
Please
- add information 
  -- concerning your PC
  -- concerning your OS (Version, Distribution, Language)
  -- Detailed Java Version 
  -- concerning your LibO UI language, Locale setting
Comment 6 Rainer Bielefeld Retired 2012-07-06 22:54:35 UTC
Related to or even DUP of "Bug 50371 - CONFIGURATION: JRE 7.x incompatibility not resolved"?
Comment 7 Dix Huit 2012-07-07 11:35:24 UTC
(In reply to comment #5)
> I think the core of the problem is a really defective or not correctly
> recognized JRE 7. I will do my own tests during Weekend.

I believe so.  After doing the whole uninstall/reinstall procedure described in https://www.libreoffice.org/bugzilla/show_bug.cgi?id=50371#c15, File -> Send in Writer works normally.  In particular, it is indispensable to define the JAVA_HOME variable, which the Java installer does not define but which LibreOffice apparently makes use of, even on a 32-bit system.  However, Bug 36149 still occurs if I disable the JRE in Tools -> Options.

> @Dix Huit
> Please
> - add information 
>   -- concerning your PC

An old Pentium 4 "Prescott" processor, 32 bits only, 1GB of RAM

>   -- concerning your OS (Version, Distribution, Language)

Windows XP Home Edition, SP3, French

>   -- Detailed Java Version 

build 1.7.0_05-b05

>   -- concerning your LibO UI language, Locale setting

French (France) for both, but I also tested English (USA)
Comment 8 Michael Stahl (CIB) 2012-07-19 12:56:34 UTC
stephenwidmer:

"Writer crashes complaining about about an issue
with Java either not being install or damaged."

what does that mean?  the dialog box about the JRE being defective
does not indicate a crash, at least in my testing.
did LibreOffice actually crash for anybody here?

if not, this is a duplicate of bug 50584.
Comment 9 Dix Huit 2012-07-19 20:09:38 UTC
(In reply to comment #8)
> stephenwidmer:
> 
> "Writer crashes complaining about about an issue
> with Java either not being install or damaged."
> 
> what does that mean?  the dialog box about the JRE being defective
> does not indicate a crash, at least in my testing.
> did LibreOffice actually crash for anybody here?
> 
> if not, this is a duplicate of bug 50584.

Yes, it actually crashed.  I was able to fix it by tweaking the Java installation as described in https://www.libreoffice.org/bugzilla/show_bug.cgi?id=50371#c15, but please note that Oracle's Java installer does not do this by itself - user intervention is required.  If you like, I can uninstall Java and test it again.

Also, Bug 36149 no longer occurs for me.
Comment 10 Dix Huit 2012-08-24 19:25:18 UTC
I was also able to fix LibreOffice by installing Microsoft Visual C++ 2010 SP1 Redistributable, which is easier than tweaking Java.  See https://www.libreoffice.org/bugzilla/show_bug.cgi?id=50371#c25 and previous for more information.
Comment 11 Julien Nabet 2012-12-12 21:24:12 UTC
It seems a duplicated of fdo#50584

However, don't hesitate to reopen this if you can reproduce the problem with a newer LO version (3.5.7/3.6.2 minimum).

*** This bug has been marked as a duplicate of bug 50584 ***