Download it now!
Bug 46155 - Errors using templates with an vanilla 3.4 profile in 3.5
Summary: Errors using templates with an vanilla 3.4 profile in 3.5
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 46134 46572 (view as bug list)
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-02-16 02:43 UTC by GAJ
Modified: 2012-10-26 22:18 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GAJ 2012-02-16 02:43:19 UTC
Problem description: 
when trying to access a template in LibO components, an error message appears: 'templates already exists'. This happens when trying to manage templates in writer, but also in the 'create new file from template' in Impress

Steps to reproduce:
1. new file (impress)
2. from template
3. error message: templates already exists

Current behavior:
as described above

Expected behavior:
option to select a template

Platform (if different from the browser):
Occurs in both WinXP (32-bit) and Win7 (32bit)
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Comment 1 John 2012-02-17 10:59:40 UTC
I get the same problem with Writer. 
It happens whenever I try to anything that touches on templates, 
1. create a new document using a template - error is "Error creating a new document: templates already exist"
If I click on "OK", the "Templates and Documents- My Documents" dialog opens and the original message is repeated, however clicking on "OK" dismisses it.
Within the "Templates and Documents- My Documents" click on "Organise ..." prodices the original error twice, followed by a empty "Template Management" dialog.
2. File -> 
Templates-> 
"previous error" -> OK ->
Templates dialog -> added new template name = "xxx" -> OK -> 
"Error writing document xxx as template: template already exists" -> OK -> 
"Error writing document xxx as template: General Error. General input/output Eerror." -> OK ->

Another thing, in the Template Management Dialog the "Commands" button only opens two(2) items "Printer Settings ..." and "Update" clicking on update gives the same error as above.
Comment 2 V字龍(Vdragon) 2012-02-20 21:31:21 UTC
Reproducible in Ubuntu 11.10 x86
Comment 3 Rpnpif 2012-03-04 03:27:57 UTC
I put this issue as major because documents are as lost (templates and others settings).
Comment 4 dallaw1948 2012-03-05 19:49:38 UTC
This can be duplicated on Win7 64 bit. By deleting/renaming the file "C:\Users\username\AppData\Roaming\LibreOffice\3\user\registrymodifications.xcu", the problem is removed at the loss of any modifications to toolbars etc.
Comment 5 Rpnpif 2012-03-07 07:31:35 UTC
Also on Linux IA32. Ubuntu, Debian...

Workaround libreoffice 3.5 : erasing registrymodifications.xcu in .config/libreoffice/[...] folder or erasing $HOME/.libreoffice/
Old $HOME/.libreoffice is obsolete.

Before that, copy your preferences from $HOME/.libreoffice to .config/libreoffice/.
Comment 6 Björn Michaelsen 2012-03-18 17:16:09 UTC
*** Bug 46572 has been marked as a duplicate of this bug. ***
Comment 7 Björn Michaelsen 2012-03-18 17:19:22 UTC
Bug 46584, Bug 46222, Bug 46476, Bug 46097, Bug 47463 and Bug 46572 are dupes of this => high importance.
workaround exists, still severity => normal
Comment 8 sasha.libreoffice 2012-03-21 09:38:02 UTC
Thanks for bugreport
If this bug reproducible in 3.5.1 or more recent, please, attach file 
~/.config/libreoffice/3/user/registrymodifications.xcu
to this bugreport
Comment 9 Noel Power 2012-03-22 09:33:41 UTC
(In reply to comment #8)
> Thanks for bugreport
> If this bug reproducible in 3.5.1 or more recent, please, attach file 
> ~/.config/libreoffice/3/user/registrymodifications.xcu
> to this bugreport
strangely marked against the BASIC component, trying INSTALLATION ( given the profile involvement )
Comment 10 manj_k 2012-03-24 15:26:42 UTC
*** Bug 46134 has been marked as a duplicate of this bug. ***
Comment 11 Hans Deragon 2012-04-05 08:44:57 UTC
This bug is reproduceable in 3.5.1.2, Ubuntu 11.10.  The workaround of removing ~/.config/libreoffice/3/user/registrymodifications.xcu works.  However there is some sensitive data within the file that prevents me to submit it for further inspection, such as personal filenames.

Please provide a package that fix this so that non technical people can get back Impress running normally without having them touch any configuration file.
Comment 12 sasha.libreoffice 2012-04-05 09:01:20 UTC
Thanks for additional testing
> Please provide a package that fix this ...
IMHO this package will never provided. We have too few developers to do all necessary work. Sorry for such situation.
Please, move this file (but not delete meanwhile) and configure LibreOffice from scratch (anew).
Comment 13 Hans Deragon 2012-04-21 09:23:54 UTC
I understand that the resources are too scarce to provide a package to fix this automatically.  But somehow, these instructions must be shown and communicated to non technical people, maybe on https://www.libreoffice.org/get-help/ page for a month or so.  And it must be made easy.  In the "Get Help" section, there should be a section named "Common troubles" and main/major bugs such as this one with their solutions should show up.

Else, the damage to the reputation of LibreOffice can be serious.  For many non technical persons that are not aware of this bug reporting website and thus of this bug report, Impress is still broken.  And if it is broken, they have to move to another solution to get the job done.
Comment 14 sasha.libreoffice 2012-04-25 09:50:13 UTC
try to ask here: irc://chat.freenode.net/libreoffice
May be someone there can help.
Comment 15 Roman Eisele 2012-05-30 01:59:21 UTC
Yet another candidate for bug 37361 ("LibreOffice 3.5 most annoying bugs")?
Comment 16 ryan.jendoubi@gmail.com 2012-05-30 02:22:41 UTC
It would sure get my vote...
Comment 17 Julien Nabet 2012-10-26 22:18:44 UTC
Since we don't have a buggy registrymodifications.xcu to try to reproduce, we can't do anything for the moment. I put it at WFM.
However, if someone has a buggy registrymodifications.xcu to attach, don't hesitate to reopen this tracker.