Bug 38187 - ENDNOTES: when .odt is exported to PDF, links between anchors and endnotes are missing in both directions
Summary: ENDNOTES: when .odt is exported to PDF, links between anchors and endnotes ar...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.3.0 target:7.2....
Keywords: filter:pdf
: 131488 132836 (view as bug list)
Depends on:
Blocks: PDF-Export Hyperlink
  Show dependency treegraph
 
Reported: 2011-06-11 09:20 UTC by Larry Tate
Modified: 2021-06-19 15:01 UTC (History)
18 users (show)

See Also:
Crash report or crash signature:


Attachments
test case to demonstrate endnote automatic link (9.59 KB, application/vnd.oasis.opendocument.text)
2012-02-29 06:59 UTC, sasha.libreoffice
Details
Test doc for pdf export bug endnote links (16.83 KB, application/vnd.oasis.opendocument.text)
2019-01-29 09:15 UTC, Erik Wesselius
Details
Test pdf showing export bug endnote links (19.63 KB, application/pdf)
2019-01-29 09:15 UTC, Erik Wesselius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Tate 2011-06-11 09:20:27 UTC
If I take a .odt document and have Writer export it as a .pdf, the endnotes are only hyperlinked to the footnote text in one direction: from the text proper to the endnote section. However, the reverse is not true: the endnote itself does not have a "return" hyperlink which should return the reader to the place in the text proper where the footnote was inserted. Now, if one clicks on a footnote in the text, the reader must scroll all the way back through the document to find the place where they left off reading.

In the .odt text the hyperlinked endnote travels in both directions, which makes reading much easier. 

I hope that makes sense!
Comment 1 Björn Michaelsen 2011-12-23 12:21:32 UTC Comment hidden (obsolete)
Comment 2 sasha.libreoffice 2012-02-29 03:44:26 UTC Comment hidden (obsolete)
Comment 3 Larry Tate 2012-02-29 04:14:31 UTC Comment hidden (obsolete)
Comment 4 Larry Tate 2012-02-29 05:22:13 UTC Comment hidden (obsolete)
Comment 5 sasha.libreoffice 2012-02-29 06:59:39 UTC
Created attachment 57808 [details]
test case to demonstrate endnote automatic link

in 3.6.0 master in created pdf no link from text to endnote and no link from endnote to text (at lease I not found in Okular)
Comment 6 Arno Teigseth 2012-03-19 14:46:50 UTC
Me too: Now (LO writer 3.5.0) the endnote anchor isn't linking to the endnote, in the exported PDF.
Comment 7 Larry Tate 2012-04-01 14:49:42 UTC
I can confirm that this behavior exists in 3.5.2. 1. A pdf's endnotes are only hyperlinked one way. This makes reading the document extremely difficult.
Comment 8 sasha.libreoffice 2012-04-02 01:41:41 UTC Comment hidden (obsolete)
Comment 9 nissimnanach 2014-03-07 16:07:31 UTC
Links do not work either way; neither from text to endnote nor from endnote to text.
Version: 4.2.0.4
Comment 10 PBX 2014-12-03 10:00:19 UTC
Same for me:
Links do not work either way; neither from text to endnote nor from endnote to text. Version: 4.3.1.2
Comment 11 Terence Eden 2015-01-14 21:28:26 UTC
This appears to be a regression. Happy to pay to have it fixed.

At the very least, endnotes should be correctly linked to from the body text.
Comment 12 Jim Williams 2015-01-31 04:05:44 UTC
This problem still exists in LibreOffice Writer version 4.3.5.2

Because I read my Writer created documents in pdf form, I need for the footnotes or endnotes to link back to the main text anchors.

I am using manually loaded bookmarks and hyperlinks instead of the insert footnote/endnote function to get endnotes that link back to the main text in exported pdfs.

Is there any possibility of this being corrected any time soon?
Comment 13 bernard 2015-02-12 20:52:49 UTC
Still the same bug with version 4.4.0.3 !

In the pdf, there is no link from text to endnote, and no link back from endnote to text.

This is quite a problem, because i use endnote for large documents.

How can we know if and when this bug could be corrected ?

Thanks a lot !
Comment 14 bernard 2015-02-12 21:02:51 UTC
I have just checked in 4.4.0.3 that for pagenote, in the generated pdf, there is a link between main text and pagenote, but there is not the inverse link between note and main text.

Both the links are available in LibreOffice, both for PageNote en EndNote.

The bug is really more important for endnote, specially for a large document.

I have changed the title of the report, as this is a bug and not a new feature.
Comment 15 QA Administrators 2016-02-21 08:35:24 UTC Comment hidden (obsolete)
Comment 16 Miguel Angel 2016-02-21 15:02:51 UTC
Hello.

I'm using the version of LibreOffice 5.0.5 with Ubuntu 15.04 and still exists this bug when exporting a writer document to PDF. 

Thanks a lot
Comment 17 Kirstie 2017-04-14 08:28:43 UTC
Inherited from OOo and regression too?

I downloaded LO3.3 and used it in Windows 8.1.
In LO3.3 the footnotes and endnotes are linked in both ways in the text.
When exported to PDF, the links work in one way, that is from the text to the footnotes and endnotes.

In Windows 8.1, LO 5.3.0.3, there are no links in the exported PDFs at all working.

I would appreciate it very much if this feature would work.
Comment 18 Raphaël Droz 2017-06-19 17:52:43 UTC
https://bz.apache.org/ooo/show_bug.cgi?id=96257
> "pdf export loses footnote/endnote-link back to anchor"
OP
>> chrk 2008-11-16 21:21:59 
> In a pdf-document exported from this Writer-document the hyperlink from anchor
> to endnote is functional, but the endnote character has no link back to the 
> anchor.

Both a regression for the most important part (reference to endnote link), and a "enhancement" (endnote back to text body's reference link)
Comment 19 Raphaël Droz 2017-06-21 04:35:32 UTC
Affecting 5.2.7
Comment 20 Arturo Espinosa 2018-03-07 21:02:39 UTC
Confirmed for 5.4.2.2

I don't think this bug is too complicated to fix. Please, lots of people are reporting this and it has been years since it was first reported.
Comment 21 Theo von Stullefeld 2018-03-13 21:54:26 UTC
Bug confirmed for Writer Version: 5.4.5.1.

In  Writer: 
footnote and endnote: both directions ok

In exported PDF:
footnote: 	down to footnote ok, back to text broken
endnote: 	both directions broken

tested under: 
Build ID: 1:5.4.5-0ubuntu0.17.10.5    OS: Linux 4.13
Build-ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8   BS: Windows 5.1 

Is a basic feature, many people are waiting for correction.
Probably much more didn't find this bug report yet.
Especially broken endnote back jump is a problem. 
Affects also long-term filing of *.odt files with PDF/A
Comment 22 Erkki Laaneoks 2018-08-29 23:17:48 UTC
Confirmed for 6.1.0.3
Comment 23 Gernot Pokorny 2018-11-08 20:00:25 UTC
Endnote confirmed in 6.0.6.2
Comment 24 Erik Wesselius 2019-01-29 09:15:05 UTC
Created attachment 148722 [details]
Test doc for pdf export bug endnote links
Comment 25 Erik Wesselius 2019-01-29 09:15:58 UTC
Created attachment 148723 [details]
Test pdf showing export bug endnote links
Comment 26 stragu 2019-05-05 13:22:31 UTC
I can confirm this bug with the following version and setup:

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 27 Xisco Faulí 2019-11-29 13:27:21 UTC Comment hidden (obsolete)
Comment 28 Mahipal Gunawat 2020-03-04 08:37:07 UTC
when libreoffice writer file is exported to pdf,Link to Endnote is not even in one direction in PDF.
Comment 29 Timur 2020-03-04 14:33:50 UTC Comment hidden (obsolete)
Comment 30 Timur 2020-03-23 10:37:14 UTC
*** Bug 131488 has been marked as a duplicate of this bug. ***
Comment 31 Timur 2020-03-23 10:40:49 UTC
One-way link for endnotes used to work in OO 3.3 and Lo 3.3 (and Description is correct). But I see that it doesn't work all the way from LO 3.5. 
Such an old regression may be notBibisectable, so I marked bug 131488 duplicate. Repro 7.0+.
Comment 32 Greg Schofield 2020-05-17 08:37:56 UTC
Problem still exists in 6.4.1.2 May 2020 and was first reported 2011. This has become personally urgent, is there a quick fix. My thesis depends on long endnotes as feature of its electronic publishing. I am despearate at this stage.
Comment 33 RGB 2020-05-17 10:28:42 UTC Comment hidden (obsolete)
Comment 34 Buovjaga 2020-08-31 18:12:22 UTC
*** Bug 132836 has been marked as a duplicate of this bug. ***
Comment 35 R. Green 2020-12-15 11:28:09 UTC Comment hidden (obsolete)
Comment 36 steffan.steffner 2020-12-15 15:49:56 UTC
(In reply to R. Green from comment #35)
> This is a big deal for book writers. It impacts negatively on the utility of
> the document to the reader.


I’d like to chime in – if someone intends to write an academic or scientific text and to publish it (which implies the text needs to be in PDF format), this broken feature will prevent that he/she can use LibreOffice at all. And my guess would be that this is a lot of people. So this isn’t a minor problem. 

This problem was first reported almost 10 years ago. So, please change “Importance” in the bug description at least to “normal”, and please somebody take care of the fix. 

All that has to be done is to create sort of an “internal links” or bookmarks in the exported PDF 

By the way, in the ODT format the “jump” works perfectly for endnotes (i.e. a click on the endnote marker in the text produces a jump to the endnote, a click on the index in front of the respective endnote produces a jump back to the marker in the text.

And note also: for footnotes, the “jump” function in the exported PDF is actually working – even though only one-way, i.e. to the footnote on the bottom of the page, but not back to the marker in the text, which is probably acceptable for footnotes since one stays on the same text page; and, this is also the way that it is implemented in the ODT file.
Comment 37 seibold 2020-12-20 18:31:42 UTC
Problem still exists in Version: 6.4.6.2 (Build-ID: 1:6.4.6-0ubuntu0.20.04.1) in December 2020.
Comment 38 R. Green 2020-12-27 11:11:53 UTC
One of the clear advantages that pdfs should have over hard copy is the ability to INSTANTLY access endnotes. It's loss is definately a blow for non-fiction/technical authors.
Comment 39 stragu 2021-01-13 12:54:22 UTC
Still reproducible in the following version:

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.4_rc2-0ubuntu0.18.04.2
Calc: threaded

It does not link either way.

Adding regression keyword as it seems to be a double-regression, according to previous comments.
Comment 40 Justin L 2021-01-26 12:58:25 UTC
I tested with Linux's bibisect-43all, and the PDF produced by LO 3.5 did not have any endnote linking in it when opened with Document Viewer.
(Some notes: Footnote linking worked in LO3.5 from text body to footnote only - and it still works in 7.2+. Also, I had to use Document Viewer in Ubuntu 20.04 - 16.04 didn't work.)

I also tested with Word 2010.  The PDF produced by Word doesn't have any linking at all.
Comment 41 Justin L 2021-01-26 13:18:28 UTC Comment hidden (obsolete)
Comment 42 RGB 2021-01-26 13:42:55 UTC
(In reply to Justin L from comment #41)
> An internet search makes me wonder if endnotes are even a concept in PDFs.

They are if you use LaTeX + Hyperref + enotez packages. Indeed, with such setup links go both directions: click in the anchor and go to the note, click on the note and go to the anchor.
Comment 43 Zirneklītis 2021-03-28 13:18:06 UTC Comment hidden (no-value)
Comment 44 Commit Notification 2021-06-13 14:28:06 UTC
Georgy Litvinov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/51d1952cf05381a48e6b0797d5e001452181b1ec

tdf#142741 and tdf#38187 Set valid pages for footnote links PDF export.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 stragu 2021-06-15 12:08:17 UTC
Georgy Litvinov: thank you for your work, I can confirm that your commit restored working links in the direction anchor to endnote in the following version:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: de7356c2e0cb099fac396808b5a86a0393b48e5f
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-14_22:38:17
Calc: threaded

Are you planning to also make it work in the opposite direction, footnote to anchor?
Comment 46 Timur 2021-06-15 12:45:55 UTC
Already confirmed in bug 142741, which is listed in the fix.
Comment 47 Commit Notification 2021-06-16 13:08:25 UTC
Georgy Litvinov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/736a2db98bbf7222bfec3dcff89999ccb71b576e

tdf#38187 Create back link from footnote text to anchor in text

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 48 Timur 2021-06-16 13:46:02 UTC Comment hidden (obsolete)
Comment 49 Commit Notification 2021-06-17 08:31:51 UTC
Georgy Litvinov committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/38cff2a3096d7f5f4716e22a6a48ef8744e1ff19

tdf#38187 Create back link from footnote text to anchor in text

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 Timur 2021-06-17 10:03:18 UTC
(In reply to Timur from comment #48)
> This deserves to be in https://wiki.documentfoundation.org/ReleaseNotes/7.2.

I added it. I also checked, working OK, great work. 

Whoever follows this bug and have prints needs, may see author's web at litvinovg.pro and his LO extensions.
Comment 51 stragu 2021-06-19 10:38:07 UTC
Marking as RESOLVED FIXED in:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 94d552f94b427f884c004dba5d4619ecf729d605
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-18_13:30:27
Calc: threaded

Thank you so much, Georgy!
Comment 52 BogdanB 2021-06-19 15:00:48 UTC Comment hidden (obsolete)
Comment 53 BogdanB 2021-06-19 15:01:10 UTC Comment hidden (obsolete)