Bug Hunting Session
Bug 38193 - WRITER, DRAW: Media Player is missing in Tools menu
Summary: WRITER, DRAW: Media Player is missing in Tools menu
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: bibisected35 bibisected35older target...
Keywords: regression
: 38935 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-11 15:12 UTC by Steven W
Modified: 2012-11-01 14:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven W 2011-06-11 15:12:19 UTC
Today, using Writer, I opened the Gallery from the toolbar navigated to Sounds, double-click a file and the media player came up on the "side" of the program and played the file.  Under OOo 3.3.0 you can open the Tools menu and click Media Player and it will go away, with LibO you can click the Show/Hide button to move it off to the side but, you can't completely make it go away.  I may be missing something.
Comment 1 Rainer Bielefeld Retired 2011-09-25 22:03:08 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]", still visible with  Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]".

Still worked in LibO 3.3.3 Portable, so regression.

As reporter said it's simply a missing item in the menu, customize -> add heals the problem.

Menu item is available in IMPRESS, but also missing in DRAW
Comment 2 Rainer Bielefeld Retired 2011-09-25 22:03:45 UTC
*** Bug 38935 has been marked as a duplicate of this bug. ***
Comment 3 Björn Michaelsen 2011-12-23 13:26:42 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 Not Assigned 2012-10-28 08:50:05 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf0453d94b1af305ee385e9e2522bcc5e589530e

Resolves: fdo#38193 WRITER, DRAW: Media Player is missing in Tools menu



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2012-11-01 14:32:22 UTC
Following a discussion on IRC, I reverted the commit.

It's not a bug here, it was on purpuse. See http://cgit.freedesktop.org/libreoffice/core/commit/?id=5bc36d13dfa5e3a386f24446c3f794d24863e1d2 for more information.