Bug Hunting Session
Bug 38298 - Autocorrect does not respect specified font
Summary: Autocorrect does not respect specified font
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-14 06:38 UTC by Carl Witthoft
Modified: 2015-09-07 16:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
'special character' dialog called from autocorrect (68.71 KB, image/jpeg)
2011-12-11 22:56 UTC, Yury
Details
'special character' dialog called from find&replace (66.58 KB, image/jpeg)
2011-12-11 22:57 UTC, Yury
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Witthoft 2011-06-14 06:38:45 UTC
I inserted a Greek symbol in a Writer document by using Insert Special Character.
I then selected that symbol and opened the AutoCorrect Replace window to create a new entry.  I made sure the "text only" box was unchecked, but the character is stored in some default font,  NOT Symbol.  When I type the correction entry in my document, it autocorrects in the current font, again not the font I wanted.

To clarify: in the Autocorrect Replace window, I want:

"Replace"    "With"
\phi         [the Symbol font 'phi' character]


What is displayed in the window is the TimesNewRoman "phi" character, and when I
type "\phi" in my document, I get the TimesNewRoman "phi" .

While on this subject: It would be very nice if LibreOffice provided a full set of Math AutoCorrect items similar to the set in MSoft Office 2007 and later.

Carl
Comment 1 Yury 2011-12-11 22:55:58 UTC
This might be connected with what I experience on my system*s* for years. If I attempt to insert a special character in find&replace or in autocorrect, I don't get a font face selection, only the 1st (?) font in the alphabetical list (?). Screenshots attached. I can't recognise the font on those. Might be 'adobe pi std' (1st alphabetically in my fonts list; but it doesn't have glyphs in U+F000 range), might be 'open symbol'.
Comment 2 Yury 2011-12-11 22:56:46 UTC
Created attachment 54341 [details]
'special character' dialog called from autocorrect
Comment 3 Yury 2011-12-11 22:57:20 UTC
Created attachment 54342 [details]
'special character' dialog called from find&replace
Comment 4 Björn Michaelsen 2011-12-23 12:26:00 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Carl Witthoft 2011-12-23 14:11:24 UTC
I was told via e-mail to re-test this under beta  3.5x, and the autocorrect function works as desired, i.e. saves and inserts the text in the proper font.
Comment 6 Kumāra 2013-08-24 06:36:30 UTC
On my LO 4.1.0.2, it doesn't work. Should I set this back to UNCONFIRMED?
Comment 7 Kumāra 2013-08-24 06:38:54 UTC
The same behaviour is also report as bug 64699.
Comment 8 Cor Nouws 2013-08-24 07:54:48 UTC
(In reply to comment #7)
> The same behaviour is also report as bug 64699.

this 38298 issue is about the font only.
64699 about all formatting/content
Comment 9 Kumāra 2013-08-25 00:47:50 UTC
I get that. But I suspect they are all based on the same underlying issue.

Anyway, since I can confirm the issue on the LO 4.1.0.2 Windows, I'm setting this to REOPENED and platform as ALL.
Comment 10 Yury 2013-08-27 06:28:52 UTC
An extra confirmation: the problem is (still) there on Linux AMD64 with LO 4.1.1.1

I would suggest looking into calls mentioning font styles (!) or some sort of style (!) similarity -- to distinguish between the two LO installations on my system, I chose AntykwaTorunska for LO 4, and unchangeable 'Insert char' font in the Auto-Correct/Find&Replace dialogs is definitely 'EB Garamond'.
Comment 11 tommy27 2014-08-25 13:58:29 UTC
please retest under latest stable 4.2.6.2 release and give feedback
Comment 12 QA Administrators 2015-09-04 02:47:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 13 tommy27 2015-09-07 16:26:36 UTC
@Carl Witthoft
I've seen you change the status to RESOLVED WORKSFORME

can you confirm with a brief message that you don't reproduce anymore the original issue?