Download it now!
Bug 38304 - EDITING : Calc doesn't show colored borders on referenced cells when editing formula
Summary: EDITING : Calc doesn't show colored borders on referenced cells when editing ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 47507 75498 106487 (view as bug list)
Depends on:
Blocks: Cell-Border Cell-Formula
  Show dependency treegraph
 
Reported: 2011-06-14 07:49 UTC by fabien.michel
Modified: 2019-04-12 12:34 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabien.michel 2011-06-14 07:49:44 UTC
1. Write =A1+A2 in A3
 2. Select cell A3 and click on formula bar : A1 border will become blue and A2 border will become red.
 3. Now Try to add "+A4" after the formula. And the colored borders disapears.

This behaviour is really annoying in large spreadsheet.

I think it could be nice if the edges of the referenced cells are colored in real time as you type.


I refer to this feature: http://help.libreoffice.org/Common/View#Show_references_in_color
Comment 1 Björn Michaelsen 2011-12-23 12:23:30 UTC Comment hidden (obsolete)
Comment 2 Mikeyy - L10n HR 2012-07-24 20:04:47 UTC
Still here in 3.6.0.2, Win7 64bit, +1 vote on this.
Comment 3 Florian Reisinger 2012-08-14 13:59:17 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:00:29 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:05:11 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:07:14 UTC Comment hidden (obsolete)
Comment 7 Mikeyy - L10n HR 2012-08-14 14:21:23 UTC
I'm not really sure why this bug would need more info.
It's all clear and it's enhancement. Only question here is will someone implement it or not.
Comment 8 Florian Reisinger 2012-08-15 07:09:26 UTC
Hi!

You got this message, because it *was* in Needinfo status.

Can you please check the oldest affected version of that and set this version as the version above?

Thanks
Comment 9 Mikeyy - L10n HR 2012-08-15 08:31:55 UTC
Bug starter entered 3.4 as tested version.
I installed first LO 3.3.0 release and it's missing this feature.
As soon as you add new charachter in formula bar all cell loose their colored borders.

While we are at it, I reported bug/enhancement which can probably be solved in same time as this, bug 52461.
Comment 10 ign_christian 2014-07-22 09:10:03 UTC
*** Bug 47507 has been marked as a duplicate of this bug. ***
Comment 11 Roman Kuznetsov 2016-01-12 12:12:02 UTC Comment hidden (no-value)
Comment 12 Kumar Thangavel 2016-01-12 12:27:22 UTC
(In reply to kompilainenn from comment #11)
> This bug will be fixed someday?
  
       I don't know. but just started code analyzing about this bug.lets try
Comment 13 Kumar Thangavel 2016-02-02 10:19:20 UTC
The patch has been submitted for this bug -
https://gerrit.libreoffice.org/#/c/22023/
Comment 14 Roeland 2016-09-15 19:16:28 UTC
*** Bug 75498 has been marked as a duplicate of this bug. ***
Comment 15 Roeland 2016-09-22 19:12:01 UTC
Kumar, are you still working on this bug? Or are there some problems with the patch?
Comment 16 Buovjaga 2017-03-15 11:28:23 UTC
*** Bug 106487 has been marked as a duplicate of this bug. ***
Comment 17 Roman Kuznetsov 2019-04-12 12:34:35 UTC
it isn't an enhancement, it's a bug

still repro in

Version: 6.3.0.0.alpha0+
Build ID: 7327260de3c0c627e62f7c3fddbe3d71ea88e88f
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-04-05_06:26:35
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded