Bug Hunting Session
Bug 38457 - CRASH WHEN MOVING A FIELD IN DATAPILOT
Summary: CRASH WHEN MOVING A FIELD IN DATAPILOT
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other Linux (All)
: medium critical
Assignee: Katarina Behrens
URL:
Whiteboard: target:3.5 target:3.4.2
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-18 13:22 UTC by m.a.riosv
Modified: 2011-07-08 02:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Data Pilot (11.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-06-25 16:44 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2011-06-18 13:22:57 UTC
After create a data pilot, moving a field crash LibreOffice.
Comment 1 Rainer Bielefeld Retired 2011-06-18 14:46:27 UTC
[Reproducible] with "LibreOffice 3.4.0  – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:12)]"

Steps to reproduce:
1. open existing spreadsheet containing data pilot
2. right click into data pilot table, Context menu 'Edit Layout'
3. Move 1 selection button from the "Row fields" section to the "Data Fields" 
   section
   Expected: Anything else but crash
   Actual: Crash 

@Kohei:
Please feel free to reassign if it’s not your area

@Katarina:
Any idea who can take over during Kohei's absence
Comment 2 Rainer Bielefeld Retired 2011-06-19 03:11:38 UTC
@mariosv:
The problem is reproducible, also with Linux, but currently only with spreadsheets with confidential contents. Can you attach a sample document?
Comment 3 Katarina Behrens 2011-06-19 04:08:08 UTC
> @Katarina:
> Any idea who can take over during Kohei's absence

I can (I'll do my best), but please note that I'll be also absent until Thursday
Comment 4 Katarina Behrens 2011-06-23 07:55:53 UTC
So -- can someone provide me with a test file? None of the ones containing data pilots I have makes Calc crash on field move.

@Rainer: can you please try if you can strip the doc you have so that it doesn't contain anything confidential and still crashes?
Comment 5 Rainer Bielefeld Retired 2011-06-23 09:06:32 UTC
> @Rainer: can you please try ...
Please test the confidential document I sent to you by PM. It will cause a really hard crash, I have to restart the PC after the crash to get a clean new LibO start.

A sign that the document will crash might be that the "buttons" in the Row Fields area are without text.
Comment 6 Katarina Behrens 2011-06-23 09:08:06 UTC
> A sign that the document will crash might be that the "buttons" in the Row
> Fields area are without text.

Bingo! :)
Comment 7 Katarina Behrens 2011-06-23 09:09:37 UTC
Taking this, then
Comment 8 m.a.riosv 2011-06-25 16:44:19 UTC
Created attachment 48423 [details]
Data Pilot

The file was made with Libo 3.4.0 from scratch, (Winx64 7 Ultimate).
Crash moving any of the fields.
Comment 9 Rainer Bielefeld Retired 2011-06-26 02:53:12 UTC
May be we have 2 bugs here? For me with Daily Build reporter's sample does not crash, but confidential document I provided still crashes
Comment 10 m.a.riosv 2011-06-26 05:45:38 UTC
The attachment (id=48423)

works in Libo 3.3.3
works in OOo dev 3.4.0 dev300m106(build 9582)
Comment 11 m.a.riosv 2011-06-27 14:08:12 UTC
May be bug 38469 it's the same.
Comment 12 m.a.riosv 2011-06-27 14:15:40 UTC
Also with bug 38717.

Not the same explanation, but the file also crash moving fields.
Comment 13 Markus Mohrhard 2011-06-29 21:55:01 UTC
Katarina already pushed her patch to the master branch and I now pushed to the 3-4 branch, but Kohei might want to have a look at the patch when he's back, so not marked resolved yet.
Comment 14 m.a.riosv 2011-07-01 15:50:52 UTC
Remain in Libo 3.4.1RC3
Comment 15 m.a.riosv 2011-07-02 06:22:18 UTC
Seems to be fixed in Libo 3.4.1
Comment 16 Rainer Bielefeld Retired 2011-07-02 07:15:58 UTC
My confidential document still crashes with  "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]"
Comment 17 Markus Mohrhard 2011-07-02 08:19:53 UTC
patch is not in 3.4.1 but will be in 3.4.2
Comment 18 m.a.riosv 2011-07-07 01:52:02 UTC
Then samething different is there, because in 3.4.1, I can move the fields without problem in the attachemt, where I can't do before.
Win7x64 Libo 3.4.1 OOO340m1(build:103)
Comment 19 Rainer Bielefeld Retired 2011-07-07 02:30:51 UTC
> Then samething different is there,

yes, see my Comment 9!
Comment 20 Kohei Yoshida 2011-07-07 23:56:08 UTC
Well, I'm still a bit puzzled on why the fix works, but it seems to work just fine, so let's leave it at that.

I'll mark this resolved.
Comment 21 m.a.riosv 2011-07-08 02:12:16 UTC
(In reply to comment #19)
> > Then samething different is there,
> 
> yes, see my Comment 9!

Rainer Sorry, I had not noticed.