Bug Hunting Session
Bug 38546 - No available language modules , spell check is impossible
Summary: No available language modules , spell check is impossible
Status: CLOSED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-21 21:17 UTC by Marty Turner
Modified: 2011-12-22 05:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of Language Settings (192.44 KB, image/png)
2011-06-21 21:34 UTC, Marty Turner
Details
LO ~/.libreoffice tree list (5.59 KB, text/plain)
2011-06-21 23:38 UTC, Marty Turner
Details
/opt/libreoffice3.4 tree lsting. (149.98 KB, text/plain)
2011-06-21 23:39 UTC, Marty Turner
Details
Available Language Packages now populated (489.87 KB, image/png)
2011-06-23 15:00 UTC, Marty Turner
Details
Automatick spell checking now works (444.35 KB, image/png)
2011-06-23 15:01 UTC, Marty Turner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marty Turner 2011-06-21 21:17:55 UTC
After a fresh install of LO 3.4.0 RC2, I'm still having spell check problems the same as described in bug report #36285 (I came up to this version because it hasn't worked for me since 3.1 or so).

Same symptoms as 36285 (which is NOT fixed per its final comments, at least not in the version that installs on X86_64 (AMD). No.

"Available language modules" is empty, no AutoSpellcheck

LibO_3.4.0rc2_Linux_x86-64_install-rpm_en-US/
LibO_3.4.0rc2_Linux_x86-64_helppack-rpm_en-US/

- Open Writer via swriter.exe
- Type: ASDF (or any spelling error)

No red wavy line
Expected: Red wavy line for spelling error.

<F7>: No spell check available
Spelling: [None] – "The spell check is complete"

Tools > Options > Language Settings > Writing Aids
"Available language modules" is empty, 
although the bundled dictionaries are shown in Extension Manager

My system Info: Mandriva 2010.2 installed from LO RPMs downloaded from the website. 

Note that on my WinXP (sp3), Win7 (Ultimate), and Mac (10.6.7) systems spelling works just fine (various 3.x versions). But this problems seems to persist for some reason on Linux X86_64. 

Please fix this for real this time. I really, really like LO over OO but do need spelling (and have to work on my Linux system as well as my others.

Sorry about "Version" being wrong about but 3.4.0 RC2 was not listed, so I had to put "other".
Comment 1 Marty Turner 2011-06-21 21:34:20 UTC
Created attachment 48264 [details]
Screen shot of Language Settings

Screen shot of my LO language settings in swriter.
Comment 2 Marty Turner 2011-06-21 21:35:44 UTC
Added screen shot of my swriter language settings.
Comment 3 Rainer Bielefeld Retired 2011-06-21 22:14:45 UTC
I modified Version due to report (RC2 is identical with release).

That all sounds similar to "Bug 37195 - Dictionary access lost after LibO upgrade", and that is not fixed for 3.4.1. Same roots?

@Marty Turner:
"Language Modules" are dictionaries? You upgraded from an other 3.4 version?
Please report bugs with initial status UNCONFIRMED!

@manj_k:
You also are active in Bug 37195, what do you think?
Comment 4 Rainer Bielefeld Retired 2011-06-21 22:30:03 UTC
No, "Language Modules" are in 
'Tools > Options > Language Settings > Writing aids'
Please excuse me for the dim-witted question!
Comment 5 Marty Turner 2011-06-21 23:38:14 UTC
Created attachment 48268 [details]
LO ~/.libreoffice tree list

My ~/.libreoffice tree listing.
Comment 6 Marty Turner 2011-06-21 23:39:59 UTC
Created attachment 48269 [details]
/opt/libreoffice3.4 tree lsting.

A tree listing of /opt/libreoffice3.4
Comment 7 Marty Turner 2011-06-21 23:43:59 UTC
RPM listing of rpms installed:

rpm -qa | grep libreoff
libreoffice3.4-writer-3.4.0-12
libreoffice3.4-impress-3.4.0-12
libreoffice3.4-calc-3.4.0-12
libreoffice3.4-en-US-3.4.0-12
libreoffice3.4-base-3.4.0-12
libreoffice3.4-draw-3.4.0-12
libreoffice3.4-3.4.0-12
libreoffice3.4-math-3.4.0-12
libreoffice3.4-ure-3.4.0-12
libreoffice3.4-dict-en-3.4.0-12
marty@localhost ~ $
Comment 8 Marty Turner 2011-06-22 15:06:45 UTC
BTW LibreOffice@bielefeldundbuss.de, sorry I didn't do the correct initial status as this is my first LO bug report (and it's been quite a while since I used Bugzilla (where I've worked it's been proprietary products like INFRA and JIRA)). I did look at "Status" below which only shows NEW, ASSIGNED, and RESOLVED, so would you please point me to which setting I should have used for UNCONFIRMED? Thanks, I'll get this right yet (oh, was it perhaps in KEYWORDS above?). Marty
Comment 9 Rainer Bielefeld Retired 2011-06-22 21:49:46 UTC
@Marty Turner:
My question concerning upgrade was not exact enough. I read that you did "a fresh install of LO 3.4.0 RC2", I forgot to ask whether you deleted you user profile before you did the installation (for WIN it's in <C:\Users\user\AppData\Roaming\LibreOffice\3> for example). I have to admit though that current investigations do not lead to this direction.
Comment 10 Marty Turner 2011-06-22 22:24:01 UTC
(In reply to comment #9)
> @Marty Turner:
> My question concerning upgrade was not exact enough. I read that you did "a
> fresh install of LO 3.4.0 RC2", I forgot to ask whether you deleted you user
> profile before you did the installation (for WIN it's in
> <C:\Users\user\AppData\Roaming\LibreOffice\3> for example). I have to admit
> though that current investigations do not lead to this direction.

Yes, I deleted that directory (on Linux it would be for example /home/marty/.libreoffice (or ~/.libreoffice for short form). I did this and the following as suggested in one of the other earlier iterations of this problem (and would always unless I was upgrading instead of installing from scratch to fix a problem such as this (once this is fixed of course, I will then upgrade instead of fresh-install)).

1. Uninstall the libreoffice RPMs.
2. Delete any files left in /opt/libreoffice (in this case it's /opt/libreoffice3.4).
3. Delete the libreoffice user directory (e.g. /home/marty/.libreoffice).

Hope that's helpful.

Thanks,
Marty
Comment 11 manj_k 2011-06-23 02:12:34 UTC
Taking some facts into account:

1. [see Attachment 48269 [details] - '/opt/libreoffice3.4 tree lsting'] 
The program directory .../share/prereg/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend
shows 'lu7p0dbp.tmp' (with 'dictionaries.xcu' [dict-en?]).
So it seems: not similar to Bug 36285.

2. Bug 37195 doesn't occur with a clean installation, and a new default user profile. Comment #10 indicates such a new user profile.
So it seems: not similar to Bug 37195.

@Marty Turner:
Please confirm that 'configmgr.ini' (program directory) doesn't differ from 'configmgr.ini' (user profile directory).

Both should have this entry 
'$BUNDLED_EXTENSIONS_PREREG/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/lu7p0dbp.tmp/dictionaries.xcu'.

For details:
https://bugs.freedesktop.org/show_bug.cgi?id=37195#c24
Comment 12 Andras Timar 2011-06-23 03:41:13 UTC
(In reply to comment #6)
> Created an attachment (id=48269) [details]
> /opt/libreoffice3.4 tree lsting.
> 
> A tree listing of /opt/libreoffice3.4

You don't have 
/opt/libreoffice3.4/basis3.4/program/libhyphenli.so 
/opt/libreoffice3.4/basis3.4/program/liblnthli.so 
/opt/libreoffice3.4/basis3.4/program/libspellli.so 

It's no surprise that you miss their functionality. Did you install libobasis3.4-ooolinguistic package?
Comment 13 Marty Turner 2011-06-23 14:58:37 UTC
(In reply to comment #12)
> (In reply to comment #6)
> > Created an attachment (id=48269) [details] [details]
> > /opt/libreoffice3.4 tree lsting.
> > 
> > A tree listing of /opt/libreoffice3.4
> 
> You don't have 
> /opt/libreoffice3.4/basis3.4/program/libhyphenli.so 
> /opt/libreoffice3.4/basis3.4/program/liblnthli.so 
> /opt/libreoffice3.4/basis3.4/program/libspellli.so 
> 
> It's no surprise that you miss their functionality. Did you install
> libobasis3.4-ooolinguistic package?

Hi:

Turns out that was it: for some reason the libobasis3.4-ooolinguistic package was not installed. I use Mandriva Control Center package manger by pointing it as the RPMS directories of the basic and help "RPMS" directories after untarring and for some reason this package wasn't installed. I'm just a basic RPM user, but was this package perhaps missing from some manifest or some such thing and thus the "automatic" package/sub-package selection of this package was  omitted when I installed? (Point being, I've installed OO for years doing it this way and until roughly LO 3.1 the way I did it used to work). Is there a "master" manifest list I should be using so as to avoid this sort of problem (i.e. a needed package not being installed)? It sure seems to me that if one indicates one wants English installed, then the "linguistics" package should be installed automatically (i.e. without manually installing it.

Anyway, thanks very much for all the help and sorry this ended up being this "simple" (as all problems are once they're understood).
Comment 14 Marty Turner 2011-06-23 15:00:47 UTC
Created attachment 48359 [details]
Available Language Packages now populated
Comment 15 Marty Turner 2011-06-23 15:01:41 UTC
Created attachment 48360 [details]
Automatick spell checking now works
Comment 16 Marty Turner 2011-06-23 15:03:13 UTC
Please feel free to close this unless there actually is some "RPM" packaging issue to take care of.

Again, many thanks.
Comment 17 Marty Turner 2011-06-23 15:32:22 UTC
Just an additional quick note (post-mortem) for Mandriva users who might be reading this:

I went back and completely uninstalled LO:

1. Manddriva Control Center > Install and Remove Software (select all LO packages for uninstall).
2. delete the /opt/libreoffice3.4 (rm -fr)
3. delete my user prefs (rm -fr ~/.libreoffice)

After reading the readme file (in my case, README_en-US) I used its Mandriva-recommended method of installation (uninstallation done above) :

sudo urpmi *.rpm

Upon invoking swriter spell-checking worked just fine (i.e. without any other manual steps on my part). While this is good, I am confused in that using the MCC method worked fine for OO and LO before roughly 3.1. So it seems "something" has changed; perhaps MCC's package install is problematic or maybe it's something that changed in LO packaging, but nonetheless the safest way to make sure LO is correctly installed on a Mandriva system is to make sure and follow the README's suggested way (I know, I'm a developer too and I'm asking you to READ the README first ;0) ).
Comment 18 Marty Turner 2011-06-23 15:50:42 UTC
One "last" item I left off my previous post: for those unfamiliar with using RPM, my comment on using sudo urpmi (sudo urpmi *.rpm) means it should be used in the LO RPMS directory per the following example:

cd /home/marty/install/LibO_3.4.0rc2_Linux_x86-64_install-rpm_en-US/RPMS
sudo urpmi *.rpm

cd /home/marty/install/LibO_3.4.0rc2_Linux_x86-64_helppack-rpm_en-US/RPMS
sudo urpmi *.rpm

marty@pogo install/LibO_3.4.0rc2_Linux_x86-64_helppack-rpm_en-US/RPMS $ rpm -qa | grep libreoff
libreoffice3.4-dict-es-3.4.0-12
libreoffice3.4-impress-3.4.0-12
libreoffice3.4-writer-3.4.0-12
libreoffice3.4-3.4.0-12
libreoffice3.4-calc-3.4.0-12
libreoffice3.4-en-US-3.4.0-12
libreoffice3.4-draw-3.4.0-12
libreoffice3.4-base-3.4.0-12
libreoffice3.4-math-3.4.0-12
libreoffice3.4-dict-fr-3.4.0-12
libreoffice3.4-dict-en-3.4.0-12
libreoffice3.4-ure-3.4.0-12
Comment 19 Andras Timar 2011-06-24 08:30:12 UTC
closing
Comment 20 Andras Timar 2011-06-24 08:30:33 UTC
.
Comment 21 Björn Michaelsen 2011-12-22 05:52:16 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.