Bug Hunting Session
Bug 36285 - LibO 3.4 beta1 – No available language modules, spell check is impossible
Summary: LibO 3.4 beta1 – No available language modules, spell check is impossible
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 39079 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-15 21:20 UTC by manj_k
Modified: 2011-12-22 05:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
"Available language modules" is empty, no AutoSpellcheck (103.65 KB, image/png)
2011-04-15 21:20 UTC, manj_k
Details
share\prereg LibO 3.4 Beta 1 (30.03 KB, image/png)
2011-04-19 07:00 UTC, manj_k
Details
share\prereg LibO 3.3.2 (52.03 KB, image/png)
2011-04-19 07:02 UTC, manj_k
Details
'share_prereg_libreoffice-3-4~2011-06-20_07.21.58_LibO_3.4.1rc1.png' (68.21 KB, image/png)
2011-06-22 10:15 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manj_k 2011-04-15 21:20:35 UTC
Created attachment 45692 [details]
"Available language modules" is empty, no AutoSpellcheck

3.4.0-beta1/win/x86/LibO_3.4.0beta1_Win_x86_install_multi.exe
[LibreOffice 3.4.0 DEV300m103 Build 1 / on WinXP]

- Open Writer via swriter.exe
- Type: ASDF (or any spelling error)

No red wavy line
Expected: Red wavy line for spelling error.

<F7>: No spell check available
Spelling: [None] – "The spell check is complete"

Tools > Options > Language Settings > Writing Aids
"Available language modules" is empty, 
although the bundled dictionaries are shown in Extension Manager.
Comment 1 Kohei Yoshida 2011-04-18 18:38:55 UTC
What's your language / locale?  I have the en-US version and this version shows Hunspell, Libhyphen Hyphenator, and OpenOffice.org New Thesaurus under Available language modules.  (BTW we probably want to change that to LibreOffice, but that's another bug report...)
Comment 2 manj_k 2011-04-19 00:56:08 UTC
LibO_3.4.0beta1_Win_x86_install_multi.exe is a multilingual version.

Administrative installation (setup /a)

My options:
Language of user interface: English (USA)
Default languages for documents (Western): English (USA)

The cause of this issue seems to be that the bundled dictionaries
are not registered during the install process. (Why?)

There are missing the usual dictionaries.xcu files in the directories

<program files>\LibreOffice 3\share\prereg\bundled\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\<xy>.tmp_\

and

<user profile>\LibreOffice\3\user\extensions\bundled\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\<xy>.tmp_\

I'll review that issue with a new test installation later today.
Comment 3 manj_k 2011-04-19 01:19:30 UTC
Correction

There are missing the usual "<xy>.tmp_\dictionaries.xcu" folders in the directories

<program files>\LibreOffice_3\share\prereg\bundled\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\

and

<user_profile>\LibreOffice\3\user\extensions\bundled\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\
Comment 4 manj_k 2011-04-19 06:58:48 UTC
New administrative installation with a "clean" user profile.
No changes, the issue persists.

See the attached screenshots: 
comparison "share\prereg" between LibO 3.3.2 and LibO 3.4 Beta 1

Only an intuition, maybe a related bug report:
Bug 36263 - No icons in user interface (root cause: ZIP handling totally broken)
See comment #13 by Tor Lillqvist.
Comment 5 manj_k 2011-04-19 07:00:24 UTC
Created attachment 45816 [details]
share\prereg LibO 3.4 Beta 1
Comment 6 manj_k 2011-04-19 07:02:17 UTC
Created attachment 45817 [details]
share\prereg LibO 3.3.2
Comment 7 Kohei Yoshida 2011-04-19 07:03:57 UTC
Tor, has this also been fixed by Bug 36263 as the reporter suggests?
Comment 8 Don't use this account, use tml@iki.fi 2011-04-19 07:05:08 UTC
Nope, this is unrelated to that.
Comment 9 wope 2011-04-19 11:49:44 UTC
If you upgrade from 3.3.2, all is ok.
Only on a clean system (without any LibO installed, and no user settings) this occurs
Comment 10 Don't use this account, use tml@iki.fi 2011-04-20 03:28:57 UTC
In the build which will hopefully become available as beta2 once fully uploaded and spread out to mirrors, this problem seems to be gone. I don't know if this bug actually had the same root cause as bug #36263, or whether it was fixed by some other change. Resolving as WORKSFORME.
Comment 11 manj_k 2011-04-20 07:21:42 UTC
Yep, is fixed now in <libo_3.4.0beta2_win_x86_install_multi.exe> from "daily".
(Verified, and works fine for me.)
Comment 12 Rainer Bielefeld Retired 2011-06-21 22:14:54 UTC
"Language Modules" are dictionaries?
That all sounds similar to "Bug 37195 - Dictionary access lost after LibO upgrade", and that is not fixed for 3.4.1. Same roots?

@manj_k:
You also are active in Bug 37195, what do you think?
Comment 13 Rainer Bielefeld Retired 2011-06-21 22:30:00 UTC
No, "Language Modules" are in 
'Tools > Options > Language Settings > Writing aids'
Please excuse me for the dim-witted question!
Comment 14 manj_k 2011-06-22 10:13:55 UTC
@Rainer Bielefeld:
In contrast to this Bug 36285 there aren't any missing files under 'share\prereg' in Bug 37195 
(see attached screenhot 
'share_prereg_libreoffice-3-4~2011-06-20_07.21.58_LibO_3.4.1rc1.png').
Comment 15 manj_k 2011-06-22 10:15:02 UTC
Created attachment 48292 [details]
'share_prereg_libreoffice-3-4~2011-06-20_07.21.58_LibO_3.4.1rc1.png'
Comment 16 Rainer Bielefeld Retired 2011-06-22 11:11:31 UTC
@manj_k: Good point
Comment 17 Rainer Bielefeld Retired 2011-07-09 02:33:14 UTC
*** Bug 39079 has been marked as a duplicate of this bug. ***
Comment 18 Rainer Bielefeld Retired 2011-07-09 02:34:36 UTC
"Bug 39079 - LO 3.4.1 Final 2011.07.01 - Spell Check still broken" seems to show that problem still exists?
Comment 19 manj_k 2011-07-09 10:58:48 UTC
(In reply to comment #18)
> "Bug 39079 - LO 3.4.1 Final 2011.07.01 - Spell Check still broken" seems to
> show that problem still exists?

This problem (missing 'dictionaries.xcu' files in the program directory) didn't occur anymore (for me, on WinXP) since LibO version 3.4.0 Beta2 (i.e: v3.4.0 Beta 2-5, RC1, release; v3.4.1 RC1-2, release; current v3.4 daily 'libreoffice-3-4_2011-07-08_09.49.19').

So I think bug 39079 isn't a duplicate of this bug 36285.
But 'Bug 37195 - Dictionary access lost after LibO upgrade' seems to be a 'strong candidate'. 

Please see also my comment there:
https://bugs.freedesktop.org/show_bug.cgi?id=39079#c2 .
Comment 20 Björn Michaelsen 2011-12-22 05:37:12 UTC
Remove infoprovider from closed and resolved bugs.
Comment 21 Björn Michaelsen 2011-12-22 05:51:26 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.