Bug Hunting Session
Bug 39079 - LO 3.4.1 Final 2011.07.01 - Spell Check still broken
Summary: LO 3.4.1 Final 2011.07.01 - Spell Check still broken
Status: CLOSED DUPLICATE of bug 36285
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-08 13:56 UTC by TG2
Modified: 2011-12-25 03:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot - Sample LibO 3.4.1 clean install - no defects... (39.20 KB, image/png)
2011-07-09 12:03 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TG2 2011-07-08 13:56:15 UTC
Previous bug #36285
https://bugs.freedesktop.org/show_bug.cgi?id=36285

seems to still be there in LibreOffice 3.4.1 Final (2011.07.01)

In Writer, deliberately misspelling any word and then running spell check gets "Continue checking at the beginning" answering yes yields "The spellcheck is complete".

Tried setting Languages from "Default - English (USA)" to "English (USA)" (entry without "Default -") for all settings, with no change in spell check failure

Under "Writing Aids", the Available language modules is blank, with the "edit" button being grey/un-selectable.

Previously installed was 3.4.0 with the same bug, 3.4.1 was tried as a fresh install and as an upgrade from 3.4.0

Have uninstalled 3.4.1, installed 3.3.3 and confirmed problem is not there.  Available language modules correctly shows Hunspell, Libhyphen, Openoffice.org, 

Performed an upgrade from 3.3.3 to 3.4.1 which does also allow spell check to work, however, the 3.4.1 upgrade using "typical" did not respect having Office 2003 already installed, and leave the office file extensions alone (3.3.3 install on "typical" honored extensions without question!).

RE-uninstalled 3.4.1, corrected Office 2003 extensions, reinstalled 3.3.3 confirmed "Typical" left extensions alone, reinstalled 3.4.1 using *custom* and left extension options unselected, and spell check is still working.

SO, 3.4.0 and 3.4.1 both have a problem from clean install to have no working spell checker.
Comment 1 Rainer Bielefeld Retired 2011-07-09 02:33:14 UTC
Hope that not every user will file a new "me too" issue for
Bug 36285 - LibO 3.4 beta1 – No available language modules, spell check is impossible

*** This bug has been marked as a duplicate of bug 36285 ***
Comment 2 manj_k 2011-07-09 05:03:45 UTC
@TG2:
>[...]
> SO, 3.4.0 and 3.4.1 both have a problem from clean install to have no working
> spell checker.

I suppose this bug 39079 is a duplicate of 
'Bug 37195 - Dictionary access lost after LibO upgrade'

1. Please check (for 3.4.0 and 3.4.1):
Are there any missing files in the LibO program directory '...\share\prereg'?
My experience: that's all right with both versions.
See: https://bugs.freedesktop.org/show_bug.cgi?id=36285#c14 
and the attached screenshot.

2. Please have a look at bug 37195, especially
https://bugs.freedesktop.org/show_bug.cgi?id=37195#c24 
and 
try the workaround (with 3.4.0 and 3.4.1), described there:
https://bugs.freedesktop.org/show_bug.cgi?id=37195#c28
Does it work?
Comment 3 TG2 2011-07-09 08:33:32 UTC
(In reply to comment #1)
> Hope that not every user will file a new "me too" issue for
> Bug 36285 - LibO 3.4 beta1 – No available language modules, spell check is
> impossible
> 
> *** This bug has been marked as a duplicate of bug 36285 ***

Sorry, since 36825 was marked as closed resolved / "worksforme" and didn't seem linked to another ticket, I figured I could have changed status on that ticket (if permitted) or open a new ticket.  I chose the path that seemed fairly logical (new ticket)  The fact that I did reference 36285 should have hopefully suggested that I did at least search for and find something similar.  I hope you would find forgiveness for the lessor of us users.
Comment 4 manj_k 2011-07-09 12:02:02 UTC
(In reply to comment #2)
> [...]
> 1. Please check (for 3.4.0 and 3.4.1):
> Are there any missing files in the LibO program directory '...\share\prereg'?
> My experience: that's all right with both versions. [...]

Attachment: Screenshot - Sample LibO 3.4.1 clean install - 
no defects in the directory
'LibO_34_test_clean\share\prereg\bundled\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend'.
Comment 5 manj_k 2011-07-09 12:03:03 UTC
Created attachment 48920 [details]
Screenshot - Sample LibO 3.4.1 clean install -  no defects...
Comment 6 Björn Michaelsen 2011-12-22 05:35:32 UTC
Remove infoprovider from closed and resolved bugs.
Comment 7 Björn Michaelsen 2011-12-22 05:49:21 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 8 manj_k 2011-12-25 03:42:04 UTC
CLOSED