Bug Hunting Session
Bug 36263 - No icons in user interface (root cause: ZIP handling totally broken)
Summary: No icons in user interface (root cause: ZIP handling totally broken)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: x86 (IA32) Windows (All)
: highest blocker
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
: 36278 36281 36284 36344 36345 36346 36348 36350 36353 36359 36360 36402 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-15 08:55 UTC by Yakov
Modified: 2011-04-20 01:25 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot 1 (39.16 KB, image/png)
2011-04-15 11:58 UTC, vitriol
Details
screenshot 2 (41.59 KB, image/png)
2011-04-15 11:58 UTC, vitriol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yakov 2011-04-15 08:55:26 UTC
There are no icons in user interface at all.
Comment 1 vitriol 2011-04-15 11:56:51 UTC
UI under Windows is completely broken. No icons, no controls, no zoom slider, labels shifted and unreadable...
See attached screenshots. Impossible to be tested.
Comment 2 vitriol 2011-04-15 11:58:14 UTC
Created attachment 45679 [details]
screenshot 1
Comment 3 vitriol 2011-04-15 11:58:48 UTC
Created attachment 45680 [details]
screenshot 2
Comment 4 Zack 2011-04-15 12:17:59 UTC
Confirmed.  Running Windows 7 Home Premium x86.
Comment 5 Rainer Bielefeld Retired 2011-04-16 00:44:25 UTC
*** Bug 36278 has been marked as a duplicate of this bug. ***
Comment 6 ercolinux 2011-04-16 22:13:13 UTC
Confirmed: same problem in Windows XP 32
Comment 7 Don't use this account, use tml@iki.fi 2011-04-17 01:14:34 UTC
The Version field is incorrect, I am sure you mean 3.4 beta 1. But that alternative is not available, sure. So let's use "unspecified".)
Comment 8 Jean 2011-04-18 00:08:27 UTC
Same problem with 3.4 beta1 on Win 7 Home (like Zack). Just changed to "LibO 3.3.4 beta 1" by mistake ; sorry !
Comment 9 Petr Mladek 2011-04-18 03:29:36 UTC
Tor, could you please have a look?
Comment 10 Rainer Bielefeld Retired 2011-04-18 05:21:39 UTC
Modified Version due to report
Comment 11 Rainer Bielefeld Retired 2011-04-18 05:41:25 UTC
Bug 36343 - No main LO icon
Might be a DUP or at least show an additional aspect
Comment 12 Caolán McNamara 2011-04-18 05:53:26 UTC
*** Bug 36350 has been marked as a duplicate of this bug. ***
Comment 13 Don't use this account, use tml@iki.fi 2011-04-19 02:08:05 UTC
Fixed now in the libreoffice-3-4 branch, will cherry-pick to master right away, too.

commit 99e0b6fac7f5fa49d47e1943682b6956db312e48
Author: Tor Lillqvist <tlillqvist@novell.com>
Date:   Tue Apr 19 11:51:49 2011 +0300

    Export the two UNO component functions
    
    Fixes zip archive handling which was spectacularly broken in 3.4 beta1
    on Windows.

 package/source/manifest/UnoRegister.cxx |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)
Comment 14 Don't use this account, use tml@iki.fi 2011-04-19 02:37:52 UTC
*** Bug 36284 has been marked as a duplicate of this bug. ***
Comment 15 Don't use this account, use tml@iki.fi 2011-04-19 02:51:16 UTC
*** Bug 36344 has been marked as a duplicate of this bug. ***
Comment 16 Don't use this account, use tml@iki.fi 2011-04-19 02:52:00 UTC
*** Bug 36345 has been marked as a duplicate of this bug. ***
Comment 17 Don't use this account, use tml@iki.fi 2011-04-19 03:12:56 UTC
*** Bug 36348 has been marked as a duplicate of this bug. ***
Comment 18 Don't use this account, use tml@iki.fi 2011-04-19 03:15:55 UTC
*** Bug 36281 has been marked as a duplicate of this bug. ***
Comment 19 Don't use this account, use tml@iki.fi 2011-04-19 04:21:39 UTC
*** Bug 36360 has been marked as a duplicate of this bug. ***
Comment 20 Allen 2011-04-19 07:12:15 UTC
>     Fixes zip archive handling which was spectacularly broken in 3.4 beta1
>     on Windows.

IMO, Beta 1 should be withdrawn and an Alpha pushed out that has this bug fixed.  It makes no sense to me to spend more time testing a release that contains this bug.
Comment 21 Rainer Bielefeld Retired 2011-04-19 07:40:37 UTC
@Allen:
Full ACK, although I am a survivor concerning software with bugs I did not install the Beta after I read of those problems. And too many problems might be have this one as root.
Comment 22 Petr Mladek 2011-04-19 08:59:35 UTC
> IMO, Beta 1 should be withdrawn and an Alpha pushed out that has this bug
> fixed.  It makes no sense to me to spend more time testing a release that
> contains this bug.

Sure, I am just going to tag sources for beta2 build. LO is huge, so it will take 2-3 days until the build is available on mirrors for all architectures.
Comment 23 Don't use this account, use tml@iki.fi 2011-04-19 16:34:29 UTC
*** Bug 36402 has been marked as a duplicate of this bug. ***
Comment 24 Don't use this account, use tml@iki.fi 2011-04-20 01:21:50 UTC
*** Bug 36346 has been marked as a duplicate of this bug. ***
Comment 25 Don't use this account, use tml@iki.fi 2011-04-20 01:23:51 UTC
*** Bug 36353 has been marked as a duplicate of this bug. ***
Comment 26 Don't use this account, use tml@iki.fi 2011-04-20 01:25:10 UTC
*** Bug 36359 has been marked as a duplicate of this bug. ***