Bug Hunting Session
Bug 38561 - save without password does not work
Summary: save without password does not work
Status: RESOLVED DUPLICATE of bug 37825
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.5 target:3.4.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-06-22 04:01 UTC by gdvalle
Modified: 2011-12-23 14:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gdvalle 2011-06-22 04:01:28 UTC
I have an .ods file containing my films, about 4800 lines.
Occasionally I update it and save it with a password. No problem.
Occasionally I save it in .xls format WITHOUT A PASSWORD, for use on my smartphone. That does not work: I obtain an .xls file WITH AN UNKNOWN password !!
The same happens if I save in .ods format "without a password": I obtain a file protected by an unknown password.
This bug is with version 3.40.

Regards
Giovanni
Comment 1 Andras Timar 2011-06-23 04:39:54 UTC
3.3.2 is working well -> regression
If I save in .ods format "without a password": I obtain a file
protected by the original password. Save as XLS works the same as for the reported (saved with unknown password).
Comment 2 Markus Mohrhard 2011-06-23 06:45:44 UTC
I have a look into it, let's see if I find the problem
Comment 3 Markus Mohrhard 2011-06-23 16:25:39 UTC
Ok, both cases have the same reason. We don't clear the password data structure when we deselect the checkbox.

Can someone have a look if this happens in writer too? The code seems to be shared between all apps?
Comment 4 Markus Mohrhard 2011-06-26 16:47:19 UTC
I have a fix for 3.4 and will send it to the mailing list for review.
Comment 5 Andras Timar 2011-06-30 06:22:40 UTC

*** This bug has been marked as a duplicate of bug 37825 ***