Bug Hunting Session
Bug 37825 - An Opened Encrypted File can't be saved Unencrypted
Summary: An Opened Encrypted File can't be saved Unencrypted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Kohei Yoshida
URL: http://lists.freedesktop.org/archives...
Whiteboard: target:3.5 target:3.4.1
Keywords:
: 38561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-01 09:40 UTC by orcmid
Modified: 2014-02-06 01:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Documents and Screenshots to Demonstrate that once Encrypted, the Document can't be saved Unencrypted. (371.96 KB, application/x-zip-compressed)
2011-06-01 09:40 UTC, orcmid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description orcmid 2011-06-01 09:40:52 UTC
Created attachment 47435 [details]
Documents and Screenshots to Demonstrate that once Encrypted, the Document can't be saved Unencrypted.

Once a file is encrypted with LibreOffice 3.4.0rc2 (x86 in Vista under Virtual PC on Windows 7 x64), it can be opened but the opened document cannot be Saved unencrypted.  This happens even though the Save As ... dialog has the "Save with Password" option not checked.

REPRODUCTION

In the attached Zip, as follows:

Encryption-2011-05-31-1223-unEncryptable.odt
 is a document that was saved with read-only, with protection of change-tracking on, and encrypted.  The encryption password is "unEncryptable".

Encryption-2011-06-01-0847-unEncryptable.png
 shows the Enter Password for decryption dialog to open 1223-unEncryptable.

Encryption-2011-06-01-0848-unEncryptable.png
 shows the Save As without "Save with password" attempt to make a new,
unencrypted version of the document.

Encryption-2011-06-01-0849 ...
 shows the Document Properties General tab brought up as part of the Save As...

Encryption-2011-06-01-0851 ...
 shows the Document Properties Security tab brough up as part of the Save As...
 Note that the file was set to Open read-only and with Record changes
set Protected, but this is not reflected in the greyed out File sharing options.

Encryption-2011-06-01-0836-unEncryptable.odt
 is the document that was saved as the result of the preceding sequence.  The
user did not set the password on this file, but it is encrypted anyhow.

Encryption-2011-06-01-0854-unEncryptable.png
 shows the Enter Password dialog that has to be satisfied before the -0836
document will open.  The newly-saved document is encrypted anyhow.
 The "unEncryptable" password works.

Encryption-2011-06-01-0856 ...
 shows that the read-only condition has been removed, however.  Now the File | Properties dialog accurately reflects that Record changes is set and protected.  (I don't remember which password I used to set this.  Try "foolish" if you want to see if the Unprotect works.)

Encryption-2011-06-01-0868 ...
 shows another attempt to do a Save As, this time with the just-opened (and further-edited) -0836 document. Note that "Save with password" is not checked.

Encryption-2011-06-01-0859 ...
 shows that the Document Properties | Security tab is still for the writeable
document

Encryption-2011-06-01-0900-unEncryptable.odt
 is the new saved document

Encryption-2011-06-01-0901-unEncryptable.png
 shows that the last-saved document is STILL an encrypted one.
Comment 1 Petr Mladek 2011-06-09 02:25:06 UTC
I wonder if it is related to the bug #37628. The encryption and
password handling has changed dramatically between 3.3 and 3.4, see https://bugs.freedesktop.org/show_bug.cgi?id=37628#c2
Comment 2 Kohei Yoshida 2011-06-09 06:35:19 UTC
I'll take a look.  But my plate is getting full for 3.4.1, so this may slip to 3.4.2.  If the fix is too invasive, however, we'll do this for 3.5.
Comment 3 Rainer Bielefeld Retired 2011-06-10 02:58:15 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 4 Andras Timar 2011-06-30 06:22:40 UTC
*** Bug 38561 has been marked as a duplicate of this bug. ***