Bug Hunting Session
Bug 38731 - Papiamentu not avaliable as language
Summary: Papiamentu not avaliable as language
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks: 51227
  Show dependency treegraph
 
Reported: 2011-06-27 20:28 UTC by Ace Suares
Modified: 2013-01-07 11:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
first pap_cw spellchecker, but under pt_br for lack of proper language entry (60.78 KB, application/vnd.openofficeorg.extension)
2011-06-27 20:28 UTC, Ace Suares
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ace Suares 2011-06-27 20:28:13 UTC
Created attachment 48493 [details]
first pap_cw spellchecker, but under pt_br for lack of proper language entry

Hi,

I live in Curacao, formerly part of the Netherlands Antilles, but now a separate country within the Kingdom of the Netherlands. Don't be fooled, it's not in Europe, but in the Caribbean Sea...

Quite a while ago I reported this bug in OOo:

   http://openoffice.org/bugzilla/show_bug.cgi?id=107230

and to my knowledge, it was accepted and integrated.

However, in LibreOffice 3.3 (the one that comes with Ubuntu 11.04), 
version: OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5,
I can not find the language entries in the list of languages.

Can anyone enlighten me if the languages are or are not integrated in this version of LibreOffice?

If not, I have the following remarks:
- for our spellchecker to work, we need an entry in the language table.
- Curacao will have country extention .cw , see
   http://www.iso.org/iso/pressrelease.htm?refid=Ref1383
- Bonaire will have .bq and Aruba has .aw

The iso language code is pap, and the name Papiamento. Since all three islands have a different dialect and different spelling, I assume we will end up with three codes:

pap_aw Papiamento (Aruba)
pap_cw Papiamento (Curacao) -> BUT we call our language Papiamentu (not -o)
pap_bq Papiamento (Bonaire) -> Also called Papiamentu locally

Since the official language name is Papiamento, I think the names in the list can be as above, although I'd really like to do it like this:

pap_aw Papiamento (Aruba)
pap_cw Papiamentu (Curacao)
pap_bq Papiamentu (Bonaire)

Either way, we would be very happy when these languages will be added because we have a spellchecker ready for over a year and we are using it under pt_br for lack of our proper language codes.

Hope to hear from you,

Ace Suares
Comment 1 Andras Timar 2011-06-29 04:31:25 UTC
Please check LibreOffice 3.4 and let us know, if you need further fixes.
Comment 2 Ace Suares 2011-06-29 06:27:17 UTC
In 3.3 I discovered that the language IS available under character see https://www.facebook.com/photo.php?fbid=2213172972619&set=a.1648000043649.91775.1346396946&type=1&ref=nf

but it is NOT under Tools->Language!

I will check 3.4

We will need changes eventually since the country codes have changed as indicated below.

Thx

ace
Comment 3 Don't use this account, use tml@iki.fi 2011-06-29 06:40:05 UTC
Are you perhaps confusing the set of languages in which the LibreOffice user interface is available with the set of languages for which so-called writing aids (dictionaries, spelling correction, thesauruses) is available?

And anyway, for Linuxes, doesn't LibreOffice use the languages installed for the "system" spell checking?
Comment 4 Björn Michaelsen 2011-12-23 12:21:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Björn Michaelsen 2011-12-23 17:01:21 UTC
needinfo keyword redundant by needinfo status.
Comment 6 Ace Suares 2011-12-23 18:16:56 UTC
On software freedom day 2011, we released the pap_an spellchecker, see the announcement at http://opencuracao.com

However, the following steps have to be taken:

pap_an does not exist anymore; the correct code is pap_cw.

So we will have

pap_aw Papiamento (Aruba)
pap_cw Papiamento (Curacao)

in fact, there could be

pap_bq Papiamento (Bonaire).

These changes are the result of changes in country codes since 2010-10-10

Can these changes be included in 3.5?
Comment 7 Rob Snelders 2012-05-27 04:03:14 UTC
Hi,

If we change this then the dictionary-file will also need to change. Otherwise it won't register correctly.

So we'll need to have a contact with the persons behind OpenCuracao.com so they can change the extension when LibreOffice changes to enable this.

Also would it be good to create a proper locale for Curacao, Bonaire and Aruba.
Comment 8 Ace Suares 2012-05-27 05:08:57 UTC
Hi Rob,

I'm the person who opened the bug ticket and made the dictionary.

Thanks for picking this up!

There are still three items that need to be cleared:

1. move pap_an to pap_cw (and call it 'Papiamento (Curacao)')
   pap_aw is not changed (and call it 'Papiamento (Aruba)')
   there is at the moment no consensus about pap_bq or pap_nl, so leave them out for now.

2. At the moment, there is a bug, that prevents from setting the language in any other place the the 'Character' dialogue. Apparently, the list of languages to choose from differs in various menus and dialogues. If you'd install the current spellchecker, then you won't see it under Tools -> Language ! But you will see it under Format -> Character. Obviously the list of possible languages differs in those two cases.

3. I can update the dictionary tomorrow; I can make a locale for as far as I know what to fill in (but our country hasn't ever thought about a locale and many of these things are officially undecided, because half of the people learn the US system and the other the Dutch system, so you would see 1,222.90 as often as 1.299,22 

But at least we can make a start.

Bonaire is special. It's NOT a separate country; at the moment it's NOT a separate language either. It is part of the country the Netherlands (which itself is together with Aruba, Curacao and St. Maarten in the KINGDOM of the Neterlands). But, even though it's part of the country the Netherlands, it has it's own ccTLD which it shares with Saba and St. Eustatius (Statia), namely .bq
So, maybe one day we will see pap_bq, but not yet.

Rob, I hope I am making sense here. Could you please let me know what you need to fix this?

Thx,

Ace

Ace Suares
Suares & Co NV
Gravenstraat 4
Otrobanda, Willemstad
Curacao

www.suares.com www.opencuracao.com openup.opencuracao.com
ace@suares.com
skype:acesuares
+599.96780060
Comment 9 Eike Rathke 2012-06-18 05:47:14 UTC
I'll take care of pap-CW and pap-BQ and mappings.

To have locales available not only as character attribution but also under Tools->LanguageSettings and in number formats we need locale data, please see https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data
Comment 10 Ace Suares 2012-06-18 08:07:54 UTC
Eike, what do you mean by 'I take care of'? What do you need from me to proceed? And pap-BQ is really not existing yet, by the way. pap-AW is!

ace
Comment 11 Rob Snelders 2012-06-18 15:08:33 UTC
Hi Ace,

Eike will do the needed changes for this.

What Eike needs to know is if the pap_an can be replaced with the pap_cw or with pap_bq or if a new one needs to be created. I think that one can be replaced with pap_cw. But as I'm not a native (although I did live on Curacao for a while) I'm not totally sure.

The problem that the languages don't appear in the language-tab of the options-dialog is that they don't have a locale. That's needed for the languages to appear there. If you want to define a locale the please follow the guide on https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data. But it seems hard to do that for the lands as there isn't really a standard on the lands as you explained. I'm not sure then how to solve it.

Eike can you assign the ticket to yourself if you are going to solve this?
Comment 12 Ace Suares 2012-06-19 01:38:10 UTC
Thanks for the feedback!

I will try to make a locale ASAP, and I will just make a choice to copy the Dutch locale for the main part.

pap_an can be transferred to pap_cw one on one,
I just need to update the spellchecker for it.

pap_aw will stay as is

pap_bq is too early to make I think, but if you want to be done with it, well please go ahead :-)

And now for the suggested text next to the choices:

pap_aw: Papiamento (Aruba)
pap_cw: Papiamento (Curacao)
pap_bq: Papiamento (Bonaire)

In english, the language is called Papiamento. The () means the country where they are spoken (Except Bonaire is not a country). Curacao (not Curaçao) is the correct spelling in English, as far as I know.

I would be very happy to see this fixed!

Cheers
ace
Comment 13 Eike Rathke 2012-06-19 11:40:18 UTC
(In reply to comment #12)
> pap_an can be transferred to pap_cw one on one,
> I just need to update the spellchecker for it.

Please note that we'll need both, pap-AN and pap-CW, to be able to read documents created with the then actual pap-AN code.


> pap_bq is too early to make I think, but if you want to be done with it, well
> please go ahead :-)

Yes, so we'll be done with that.

> And now for the suggested text next to the choices:
> 
> pap_aw: Papiamento (Aruba)
> pap_cw: Papiamento (Curacao)
> pap_bq: Papiamento (Bonaire)
> 
> In english, the language is called Papiamento. The () means the country where
> they are spoken (Except Bonaire is not a country).

According to ISO 3166 it is BONAIRE, SINT EUSTATIUS AND SABA, http://www.iso.org/iso/country_codes/iso_3166_code_lists/country_names_and_code_elements.htm
I hope mentioning Bonaire will be enough here without pulling anyone's political animosities..

Regarding spelling: earlier some insisted that for Netherlands Antilles it was  Papiamentu and for Aruba it was Papiamento. So now Papiamento for all three?

> Curacao (not Curaçao) is the
> correct spelling in English, as far as I know.

ISO 3166 says CURAÇAO
Comment 14 Not Assigned 2012-06-20 02:01:41 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb6fec1bd39be9f6d660623abd2b25400a34b9ac

fdo#38731 added Papiamento (Curaçao) [pap-CW] and (Bonaire) [pap-BQ]
Comment 15 Ace Suares 2013-01-07 11:13:41 UTC
Thanks for adding the code for pap_CW! I will (after a very long delay) try to upload the locale for pap_CW soon.

Re: Bonaire: although BQ is for three islands, the only island where Papiamento is spoken is Bonaire. So there really is no Papiamento in St Eustatius or Saba. Those are English language countries...!

Cheers